I upgraded to Windows 10 a week ago, and then installed a fresh copy of it on a SSD. Everything worked fine, until File Explorer suddently started to behave weird: When I double-click on a folder, it opens in a new window (despite having "Browse Folders" set to "Open in same window"), and when I copy a file, it freezes for ~10 seconds, after which it crashes and restarts (however, the file is copied just fine). The crash also happens randomly when I browse Control Panel.

Things I tried already:

  • Reset Windows. The problem was fixed temporarily, but came back after a couple of days.
  • Uninstalled last update.
  • Booted in Safe Mode.
  • Removed all shell extensions using shexview.

Nothing worked. The crash event log:

Log Name:      Application
Source:        Application Error
Date:          8/30/2015 6:30:18 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      D180-M1
Faulting application name: Explorer.EXE, version: 10.0.10240.16431, time stamp: 0x55c9bd76
Faulting module name: windows.storage.dll, version: 10.0.10240.16405, time stamp: 0x55b46055
Exception code: 0xc000041d
Fault offset: 0x0000000000120dec
Faulting process id: 0xc48
Faulting application start time: 0x01d0e3408ef60455
Faulting application path: C:\WINDOWS\Explorer.EXE
Faulting module path: C:\WINDOWS\system32\windows.storage.dll
Report Id: 3f9927d9-ad92-45c6-a325-dace805f2099
Faulting package full name:
Faulting package-relative application ID:
  • 1) What is your antivirus (+version) 2) Do you have a card reader?
    – user360854
    Commented Aug 30, 2015 at 17:36
  • 1) Right now, the out-of-the-box windows defender, client version 4.8.10240.16384 2) No
    – D180
    Commented Aug 30, 2015 at 17:42
  • Try browsing to a random file in the My Documents folder, select (right-clicking the file) File Properties and open "File History". Wait after it has finished displaying everything, then reboot. Report whether it still crashes after that.
    – user360854
    Commented Aug 30, 2015 at 17:44
  • Still crashes...
    – D180
    Commented Aug 30, 2015 at 18:00
  • 2
    @Jason I use WinDbg. this may be a bug. You get a STACK_OVERFLOW because some parts of code repeat over and over again (RECURRING_STACK: From frames 0x8 to 0x1). I've asked Microsoft if they have any information. I'll post here if I get information. Commented Aug 31, 2015 at 4:13

1 Answer 1


I had a similar issue. It seems that what caused it for me was trying to customize explorer using command line. I ended up with the copy/move crash, and open-in-new-window issue.

This is the command that broke things for me:

%SystemRoot%\explorer.exe /e,/root,::{450d8fba-ad25-11d0-98a8-0800361b1103}

I chanced upon this case, and it seems that resetting folder options in the registry might keep you from having to do a system restore, or recreating the user. Here's the related KB.

I ended up only having to delete and recreate BagMRU, and Bags (I compared my registry before and after corruption for differences, I also compared to the MS case).

[HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU]

[HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags]

There were more differences, but this was the first I tried and it solved at least the open-in-new-window issue. I wasn't experiencing the crashing anymore because I had done a system restore.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .