4

I updated my machine to Windows 10 but I have issues to get it working. The error I got when I installed Virtualbox (version 5.0.3) is:

Callee RC: 
REGDB_E_CLASSNOTREG (0x80040154)

I have Googled around and I found this issue and have tried the options stated in the accepted answer but this did not work.

When I do the following:

regsvr32 /u VBoxC.dll 

It says VBoxC.dll could not be loaded. Could not find module.

Any suggestions?

Edit

As suggested in the posts below I have tried various things. Still no solution. I am still getting the same error. What strikes me is that I don't have a C:\Users\User\.VirtualBoxdirectory. And every time I reinstall VirtualBox the directory is NOT created.

Edit 2

As I have literally tried everything and didn't get it working I decided to change my os to Ubuntu. Thanks everyone for the big help.

@moderators: what's with the bounty? How should I go about this? There's no solution to this problem that worked for me....

17
  • 1
    is the file even located in that directory?
    – Ramhound
    Aug 30, 2015 at 18:51
  • 1
    You have to find the file on your computer, its unsual to be in SYstem32 though
    – Ramhound
    Aug 30, 2015 at 19:17
  • 1
    Are you by chance trying to install a 64-bit Vbox on a 32-bit host?
    – Ramhound
    Aug 30, 2015 at 19:32
  • 2
    0x80070005 is a permission problem. So be sure you are doing that command as a user with permission to the file.
    – Ramhound
    Aug 30, 2015 at 19:42
  • 1
    Try to uninstall completely VirtualBox, reboot, then reinstall while unchecking "VirtualBox Bridged Networking" in the installer.
    – harrymc
    Sep 3, 2015 at 8:40

4 Answers 4

2

Have you seen this StackOverflow post? It applies to your case. I happened to see exactly the same problem (on one of my student's laptops ;-), of all places), and solved it by combining the two answers, i.e., first by disinstalling completely as mentioned in the second answer, then checking the xml file mentioned in the first one.

The rationale for this is something you have stated,

Have you tried to simply reinstall the application? – Ramhound

@Ramhound yep a few times. – sanders

and then the weird problem you have had with the loading of VBoxC.dll

So I would uninstall as a regular user, then as admin seek out all register keys associated with VirtualBox and delete them, then re-install, then check the xml file mentioned in the first, accepted answer mentioned in the post linked above.

Of course, you may just want to check first the xml file without going through the hassle of a complete, but manual, uninstall.

If, after the complete uninstall, you should have still the same problem, you may wish to re-try the other solutions offered to your problem, since the issue with permission and registry jeys is such as to (potentially) void the usefulness of the proposed solutions. So try once again the one you mentioned, and make sure you have a suitable version of Microsoft .NET Framework installed.

Please let me know whether any of this works, it did for me.

6
  • 1
    I have tried this. I reinstalled VirtualBox it seems that I dont have a .VirtualBox. dir in my users directory. I remember removing the directory I few days ago. Also which version of the .NET framework should I install.
    – sanders
    Sep 3, 2015 at 7:09
  • 1
    @sanders VirtualBox seems to make no specific assumption about it, anyone suited to Windows 10 seems to be Ok. Sep 3, 2015 at 7:15
  • 1
    Ok so what do you reccomend me to do? I can't even get the GUI of VirtualBox to start
    – sanders
    Sep 3, 2015 at 7:16
  • 1
    @sanders Sorry, only good answer is: do the thorough uninstall mentioned above and in the link provided, install .Net Framework, re-install VirtualBox as a non-privileged user. Sep 3, 2015 at 7:28
  • 1
    which version of the .NET framework should I use? Also it's weird to me that I don't have a .VirtualBox directory where the XML file should be
    – sanders
    Sep 3, 2015 at 16:47
2

You might want to consider this.

I had installed Windows 10 Enterprise, upgrading from Windows 8.1 Enterprise and ran into the issue of the Windows 10 locking up quite frequently.

After some digging, I had found out that the Hyper-V manager for Windows 10 was still reading the configuration of the Hyper-V manager for Windows 8.1. It wasn't until I did a complete reset of Windows 10 (to clear any previous version configuration) did it work beautifully.

Although it might not seem directly related to your issue, my point is, Windows Hyper-V, especially in Windows 10, might be fighting over resources with your VitualBox installation.

I would suggest from the Program Files --> features to run, remove Hyper-V, reboot and run from the command prompt (in admin mode) sfc /scannow

Then reboot, and try running your VirtualBox (after you reinstall your VBox that is as was suggested by the previous poster).

3
  • Hello, where can I find Program Files --> features to run???
    – sanders
    Sep 3, 2015 at 16:44
  • @sanders press Windows Key + R, type control in. In the next windows click on Applications or Programs (I am on a german installation) and than on Activate or Deactivate Windows-Features. You should find Hyper-V there.
    – Kimmax
    Sep 4, 2015 at 6:20
  • @Kimmax there is no Hyper-V in that list.
    – sanders
    Sep 4, 2015 at 11:50
2

If the current version of Virtualbox seems incompatible with Windows 10, and since all the suggestions proposed in the answers and comments, by myself and by others, have not worked, it seems that this only leaves three options :

  1. Wait for Virtualbox to be fixed for Windows 10
  2. Downgrade to Windows 7
  3. Convert to Hyper-V.
    The GUI is different from VB, but it has the same basic functionality and may offer better performance for Windows guests.
3
  • It's Virtualbox that is incompatible with Windows 10, not the other way around. But otherwise these are the options. They're taking their time in fixing it though, for some reason. Sep 6, 2015 at 7:51
  • @harrymc I started playing around with the Process Monitor and I saw it tried to start C:\Users\Jigal\Downloads\VBox-Win10-fix-14040-x86.exe form the svchost.exe But that file does not exist anymore. How can I make sure this process doesn't start anymore so that it doesn't look foor this file anymore?
    – sanders
    Sep 6, 2015 at 8:36
  • It's trying apparently to execute this workaround (see the Update section). It's very strange that VB executes a workaround. You might try following that advice in the link.
    – harrymc
    Sep 6, 2015 at 11:53
2

Any suggestions?

As of today (09/09/2015) there is a new release, that was actually released yesterday. Which seems to solve my problems, that have been pretty much the same.

My system setup with same problems was:

  • Windows 10 Pro 64bit (upgraded from a Windows 8.1 Pro 64bit)
  • VirtualBox 5.0.2
  • No Hyper-V Features activated/installed

I've just installed the new release from VirtualBox, which you can download here as usual.

Before that I had to switch in and out USB 2.0 vs 1.1 and vice versa, then the VM started occasionally.

Now it seems to work out of the box. (Tested few times, rebooted after installation)

There are also several issues that have been fixed, see the VirtualBox Changelog.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .