4

I have a VMWare Player version 6.0.0 installed on my machine since when I was using Windows 7 x64. Some time ago I updated the later to Windows 10 and when I started my Linux Ubuntu Gnome with VMWare, a problem appeared.

I have a external Samsung HD connected via USB 2.0 to my PC. Back when using Windows 7.0, when I started the Ubuntu inside VMWare this would automatically reconnect the external HD to Ubuntu and everything would work fine. But this didn't occur after the update to Windows 10: I don't remember the first message, but the external HD couldn't be connected to the Ubuntu virtual machine.

Now everytime I run the VM the external HD remains connected to the host Windows 10. An icon, disabled, appears in the VMWare menu and I have the possibility to ask it to connect. When I do so, the external HD is disconnected from the host Windows 10, but fails to be connected to the VM; instead, after something like 2 minutes, a warning message appears:

VMWare error message

I searched the web for explanations, but no comments were found for this problem for this particular situation and I can't judge if the answers for other ocasions when similar driver errors occured would work for me.

So why this error and what should I do?

Found resources:

EDIT:

After downloading a newer version of VMware Player, the device still wasn't automatically connected to the virtual machine as usual and when I tried to do it manually, I got an even worst scenario:

Problem when connecting to USB device

Everything was working fine before trying to do the connect. The "VMware stop working" pop-up appeared right after clicking one of the "Runtime Error" message boxes that started appearing one after the other.

  • Can you try VMware Player 8? – jamesdlin Sep 3 '15 at 17:34
  • @jamesdlin if you can provide me with the installer, sure! ^^ – Momergil Sep 3 '15 at 18:05
  • @jamesdlin thanks for the link. I downloaded, installed and tried it; the result appears in the "EDIT" section above. – Momergil Sep 5 '15 at 2:25
  • Oh dear. You probably would be better off reporting this bug to VMware's community forums (Player > Help > Support > Online Community). – jamesdlin Sep 5 '15 at 6:43
1

You probably should try a newer version of VMware Player. As of writing, the current version is 12.0 (I wrote 8 in an earlier comment, but I got confused because VMware recently renumbered it to be in sync with the VMware Workstation version number.)

VMware Player is free for personal use, so you probably might as well upgrade. If nothing else, by running the latest version, you're much more likely to get help from VMware or from other users if you run into problems.

| improve this answer | |
1

It's not just you, I have verified this is a VM Player Bug, or Windows 10 issue.

I have tested with Windows 10 RTM, also newer builds every few months after released, including Windows 10 1511 Build 10586 in March 2016. Tested with VM Player 12, also Version 12.1.0 Build-3272444.

This is a screenshot of the error, showing

"Runtime Error! Program: C:\Program Files (x86)\VMWare\VMware Player\vmplayer.exe R6025 - pure virtual function call "

All the tests I've done is on a clean install. No other 3rd party programs, just Windows 10 and VM Player. One time I even installed all the C++ runtime redistributables from 2005-2013, still same results without installing them.

The current solution is to either downgrade back to Windows 7 for VMPlayer. Or Switch to VirtualBox if you have to use Windows 10.

Click This to View Picture

This crazy error occurs everytime a USB device is plugged / unplugged "Microsoft Visual C++ Runtime Library".

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.