0

So, I bought Asus EeeBook E402MA (Intel N2840, 2GB RAM) which comes with Windows 8.1 x64 pre-installed on 32GB eMMC. First I tried upgrade it to Windows 10, but upgrade tool said that I need more space for upgrading. So I decided to remove recovery partition and increase Windows partition size. I removed it with GParted, but after remove, Windows 8.1 wasn't booting again. Okay, no problems, product code for Windows I already saved, so I just remove any partitions from it and tried installing again (Windows 8.1 x86 MSDN version), but setup can't detect eMMC. I tried Load Drivers option, but none of drivers I tried also can't find eMMC. Asus Support page for this model don't provide any drivers for eMMC. After that I insert 2,5" HDD and installed Windows 8.1 on it. After installed all drivers from Asus, Device Manager shows this - Driver Manager

I tried almost any card reader driver, none of these helped. I contacted with Asus technical support already, but before they answer me, maybe there is someone who can help me (uses same laptop and can provide me driver, etc). Thanks!

1
  • This driver is most likely shipped with Windows. However, there seems to be an issue preventing it from starting. The logical conclusion would be that Setup (which runs on a stripped-down version of Windows itself) is having the same problem.
    – Daniel B
    Aug 31, 2015 at 9:38

4 Answers 4

0

Problem solved. You cannot install Windows to UEFI-based computers in BIOS mode - https://technet.microsoft.com/en-us/library/cc749064%28v=ws.10%29.aspx It's simple - with GParted created two partitions on eMMC (one 4GB and second 25GB (all left free space)). Then with Linux Mint copied all files to 4GB from Windows 8.1 x64 .iso file. Then in USB flash (formatted FAT32) copied this one - https://svn.code.sf.net/p/edk2/code/trunk/edk2/ShellBinPkg/UefiShell/X64/ (rename shell.efi to SHELLX64.EFI). After that disabled Secure Boot and launched "Launch EFI shell from filesystem device" option from BIOS. Selected 4GB partition and typed command \efi\boot\bootx64.efi which started Windows Setup. Now I was able to see eMMC and installed it to 25GB partition. Should be noted that Windows x86 will not work for this. This is why my computer (2GB RAM) was sold with x64 pre-installed Windows.

0

Solution : Now install Rufus and create usb with gpt for uefi, later select ONLY fat32 and create usb flash with win8 or 10. Finally, reboot the system and boot with uefi... The partitions will be create only automatic and select partition 4.

0

This solved my problem with an eMMC SanDisk INAND 32GB storage on my Lenovo Ideapad 100.

In fact, I tried just about everything from installing Linux to booting Windows off USB and nothing worked. I almost gave up and trashed the laptop with 32-bit UEFI.

The key is SHELLX64.efi from https://svn.code.sf.net/p/edk2/code/trunk/edk2/ShellBinPkg/UefiShell/X64/

Put that on any flash drive and you can boot with UEFI enabled and then it will automatically boot to another flash drive with Windows 10 64-bit on it.

0

The alternative, switch into legacy mode through the bios (just for the install then switch back on afterwards) boot Linux mint, run disks from the start menu, use the three bar menu button to format the emmc as mbr/dos. When complete, click the + sign under the drive ui and add an ntfs partition.

Reboot with windows installation media and proceed to install, once installed, switch secure boot back on in the bios. Should be a goodun.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy