I installed FreeVPN to access a site restricted only to the USA. I uninstalled it some time later and am using astrill.com some times.

Either since installing FreeVPN or Astrill, I cannot login with Yahoo! Messenger. I did what the troubleshooting says but I don't have any proxy/port set there and I don't use IE as my default browser, I use Firefox.

Tried to uninstall the Messenger then a clean install. The same thing.

screenshot of troubleshooter dialog

  • Maybe there's some virus scanner that is trying to outsmart you? See if there's any option in your virus scanner to secure Instant Messaging, and if so: temporarily disable that? – Arjan Jan 20 '10 at 8:51
  • I use Microsoft Security Essentials & Spybot Search&Destroy. I disabled them both, same thing. I think we're starting to run out of options :( – ChristianM Jan 20 '10 at 11:23
  • I tried to get into Connection Preferences again, but this popped-up img717.imageshack.us/img717/4126/capturew.jpg After I pressed ok it did opened the Preferences, but maybe it's saying something. (It's chineese for me) – ChristianM Jan 20 '10 at 11:43
  • Not giving up yet ;-) That error is not very descriptive indeed, but it might indicate that your Messenger is using old and new things at the same time. You do not have BOTH version 8 and 10 installed, do you? And: did you ever go into that preferences earlier without that error message? And do the preferences indeed state "direct connection"? (To get something out of this: when pressing Alt-PrintScreen you'll get a screen capture of just the active window. Just in case you didn't know that.) – Arjan Jan 20 '10 at 16:01
  • I didn't had both version 8 and 10 before, but I did installed it a few hours ago, so I don't think the 8 version did anything bad. That's my first time I see that error when I try to access the Preferences. Yes, at Connection Preferences the Messenger is set to Connect directly to the Internet. (I'm using the Snipping Tool of Windows 7, but thanks for the PrtScr advice :D ) I think I'll give you the correct answer anyway, because you deserve the 100 bounty points anyway. – ChristianM Jan 20 '10 at 17:16

I don't have any proxy/port set there and I don't use IE as my default browser, I use Firefox.

Given the troubleshooting screen, I assume that (unless set up differently in Messenger itself) Yahoo! Messenger uses the same settings as IE. So you might need to change these settings even though for browsing you don't use it. So you'll need to figure out if the VPN you're using provides such proxy server, and then make IE or Messenger use it.

See also Yahoo's Troubleshooting Tips for Messenger Sign-in Issues. If your connection to the web is through a HTTP proxy, then you won't be able to make or receive voice calls with your PC, according to What ports are used for calling with Yahoo! Messenger? But I assume sending text messages should always work.

Note that the details show the problem:

Resolving host name vcs1.msg.yahoo.com

This should yield, but you get:

Connecting to Virtual IP server

This is an IP address for a private network, not for the internet. So I assume that the VPN service you use also uses its own DNS server, to relay all your requests through their own web servers. That DNS server then does not give your browser or Messenger the true IP address, but a private address. This way they can add advertisements, but that also breaks the secure connection that Messenger tries to use (man-in-the-middle attack), and hence Messenger will refuse to operate.

If I am right, then some possible workarounds to make Messenger bypass this service:

  • Explicitly use a different DNS server, like OpenDNS or Google DNS.

  • Add the domains that Yahoo! needs to your hosts file, to map them to Yahoo!'s IP address directly. (But: how to know what domains it needs? And what if they change? Better try a different DNS server.)

Both workarounds might not work at all, if the VPN server you use does not allow for direct access to internet IP addresses. (And I guess they'll indeed disallow that, as relaying your requests is the only way they can add the advertisements.)

Can you provide any details on the exact VPN service you're using? Did you try other secure sites, such as https://gmail.com or some internet banking? And above all: can you access https://login.yahoo.com like suggested in your screen capture, without any security warnings? (You can try another browser for a first test as well.)

If you're using thefreevpn.com (somehow, I don't really trust that site) then here's a note from the main developer, which makes me think that HTTPS over its default port should be no problem:

currently we allow SSH, FTP, HTTP/HTTPS, ICQ.

  • I uninstalled the FreeVPN before I even saw that I couldn't log in. But I'm using Astrill.com now. Any other secure site is working and I can access login.yahoo.com without any security warnings. So, I just add to the windows hosts file ? – ChristianM Jan 19 '10 at 17:34
  • @ChristianM: Did you get with FreeVPN or Astrill? From what I've quickly found on the net, Astrill promotes itself as a VPN, but is really a proxy. As during installation it wants you to close your browsers, maybe it has set up a proxy in your browsers? Or maybe it has set up some system-wide proxy? If so, then hopefully you can copy those details into Messenger's preferences as well. But first you must try to get those details... In Firefox, type about:config in the location bar (URL bar) and then type proxy to quickly see proxy-related settings. Anything there? – Arjan Jan 19 '10 at 17:53
  • There you go Arjan : img12.imageshack.us/img12/5606/capturexb.jpg Thx for trying to help me. – ChristianM Jan 19 '10 at 20:00
  • Ok, img12.imageshack.us/img12/5606/capturexb.jpg shows that Firefox knows about some previous proxy on port 8080, but the configuration network.proxy.type = 0 means no proxy is currently enabled. So: if Firefox works fine then that's not because Astrill made it use some proxy. So, did you get with FreeVPN or Astrill? Did Astrill give you any link to some documentation? (By the way: did I rewrite your question correctly?) – Arjan Jan 19 '10 at 21:02
  • Kinda.. I don't use Astrill all the time. Only when I watch something on that site. So, I don't think Astrill is the problem. You said Y! Messenger uses the same settings as IE. I can't find any setting that I could even change and test the login. Also, I use a PPPOE connection, my messenger is set tot connect directly to the internet. Any other information I could give you ? – ChristianM Jan 19 '10 at 21:10
  1. Go to

    Internet Explorer > Tools > Internet Options > Advanced

  2. Click Restore advanced settings

  3. Click Reset... of the Reset Internet Explorer settings section

I had the same problem a few minutes ago and this is what I did to fix it:

I have both firefox and IE and each one uses a different proxy. Just go to IE tools > Internet Options > Connections > LAN Settings and remove the use proxy checkbox. Make sure that it's off and now use the yahoo. It should work, and be sure that your yahoo connection setting is set to connect to internet not with http.


It's usually caused by WinHTTP Web Proxy Auto-Discovery Service I guess, make sure it is running or make that service always run automatically

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.