3

I am using the Hyper-V Manager and following a Microsoft Learning tutorial. I already have the three folders representing the Virtual Machine in:

C:\Program Files\Microsoft Learning\20488\Drives\20488B-LON-SP-01

The folders are:

 1. Snapshots 
 2. Virtual Hard Disks
 3. Virtual Machines

The Virtual Machines folder contains the .exp file, the virtual hard disks contains the .vhd file and the root of all those three files there is a XML file.

The problem is that whenever I point to the root directory (20488B-LON-SP-01) I get the message: No virtual machine files found.

But as you see the files are there. I am using a Windows 10 and Hyper-V Manager Version: 10.

  • Please define what you mean by "root directory" in this context. What happens if you point it at the "Virtual Machines" directory? – Ƭᴇcʜιᴇ007 Aug 31 '15 at 18:22
  • @Ƭᴇcʜιᴇ007 question was updated, thanks for the remarks. – Tito Aug 31 '15 at 18:46
  • @Tito - Instead of putting the solution in the question you should submit an answer. – Ramhound Aug 31 '15 at 18:59
  • @Ramhound done, just don't understand why -1 on my question. I believe is a common issue and this question is quite useful. – Tito Aug 31 '15 at 19:11
  • @Tito - To encourage you to properly ask a question then answer it. I don't find questions which contain the solution within them, to be helpful to the community, so I vote accordingly. If that is a problem feel free to bring it up in the proper place. I am honestly tired of having to justify my downvotes, because when I do provide feedback, the person almost never agrees with my feedback anyways and I end up getting serial downvoted by that person. – Ramhound Aug 31 '15 at 19:14
1

I have found a work around, but it is not very elegant: Just followed the first solution from here:

If you have access to the original host then find and copy the Virtual Machine .xml file to the local folder that contains the .exp file. (The names will be the same other than the .xml or .exp file extension.) Delete the .exp file and then try the import again, except this time select the next folder down - the one that contains the "Virtual Hard Disks" and "Virtual Machines" folder.

Also I have changed the VM folder's location from Program Files to a private folder, since I was suspicious could be a security access problem, even apparently the both folders have the same security configuration.

Still it was not importing the virtual machine, but them I created a new virtual machine and pointed the hard disk for the .vhd file inside the Virtual Hard Disks folder. I still have more 14 virtual machines to import, maybe that is not the best answer, but it solved the problem.

| improve this answer | |
  • Worked with me. Thanks dude you made my day. – Hazem Abdelwahab Feb 24 '18 at 16:17
  • And if we don't have access to the original device? I'm looking at a bunch of exported VMs from one device that hyper v manager can't "find" on another. And the original device is long gone. – Douglas Gaskell Aug 1 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.