0

I am trying to remote desktop into a server 2012 R2 machine from a Windows 7 SP1 machine. The error message I get is:

Remote Access Cannot Connect
1)  Remote access not enabled
2)  Remote computer turned off
3)  Remote computer not available

They are both on the same local network, and within the same domain. The server 2012 R2 machine is running on Hyper V. I am able to ping to and from the machine, and I am also able to remote desktop from the machine to another server.

What I have tried so far.
I have obviously turned on Remote Desktop in the System\remote settings area. I also have 10 CAL's installed on the machine.

I have checked and double checked the Firewall settings to make sure they are enabled.

I have port 3389 unblocked for both TCP and UDP in user mode, and also in shadow mode for TCP. I also tried enabling them by creating my own rules for the port.

I have also tried running the flushDNS command in the cmd prompt. Nothing has worked so far.

  • You turned on Remote Desktop in System\Remote Settings... but did you also add your user account or group to the allowed users list? – Joel Coehoorn Aug 31 '15 at 18:28
  • If you fully turn off the Windows firewall does it work? If you RDP to "localhost" on the server itself, does it answer? – Ƭᴇcʜιᴇ007 Aug 31 '15 at 18:29
  • Yes, I added myself, as well as a Group – Cory R. Platt Aug 31 '15 at 18:29
  • Firewall off - still does not work. – Cory R. Platt Aug 31 '15 at 18:31
  • No, it does not respond when I try to connect to local host. – Cory R. Platt Aug 31 '15 at 18:33
0

On your Server run this Powershell command

Enable-NetFirewallRule -DisplayGroup "Windows Remote Management"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.