3

Here's the network route.

Windows 8.1 SSD

--> AC Gigabit Wifi 5ghz Intel(R) Dual Band Wireless-AC 7260 Link Speed 173Mbit

--> ASUS Dual Gigabit router RT-AC87R

--> Cat 6

--> Windows 8.1 SSHD

Transfer initiated via windows built-in file transfer mechanism (explorer drag & drop) on network. Dialog showed 9 to 13 megabytes per second average transfer one large gigabyte file.

I have tested this in the same room as the router, full signal. According to my android app, there is very little channel interference (none on 5ghz, and not much on 2.4ghz)

How do I ensure my 1 gigabit Wi-Fi runs reasonably near the expected speed? (It's currently 17% of the expected speed, while in the same room & no outside interference)

enter image description here

  • You forgot to ask a question. Is your question "why is this"? Or "what can I do about it"? Or "how can I troubleshoot"? – David Schwartz Aug 31 '15 at 22:38
5

I went into my router settings and changed Wi-Fi Channel Bandwidth from 20 Mhz to 80 Mhz and my speed more than doubled. Files are transferring at 4x, and speedtest shows a 2x speed boost.

I didn't know it, but apparently AC Gigabit only functions with a 80Mhz bandwidth. So in other words, there are settings on a gigabit router that literally make it into a slower router. Who knew.

enter image description here

| improve this answer | |
2

That seems about right to me. The link speed is 173Mbps, or about 21MB/s (there are 8 bits in a byte). All data has to be sent twice, one to the access point and once from the access point, so that gives about 10MB/s. That's about what you're seeing.

If one side of the connection is wired, you don't have to send the data twice. But you lose the ability to piggy-back requests onto acknowledgements. And it still takes quite a bit of time to turn the link around. So this is really still in the range of reason.

| improve this answer | |
  • Sure, that makes sense. But how is my connection 173Mbps? That's like 17% of what I should be getting? – Jonathan Aug 31 '15 at 19:26
  • @JonathanLeaders there are so many factors that affect wireless speed. Distance from the router, objects between you and the router, possible frequency interference, etc. – DrZoo Aug 31 '15 at 19:32
  • The router is 5 ft away, nothing in the way, and my android app shows no other signals in the 5ghz range. I have a 5 bar signal. And I get 17% the speed? I'm not sure that makes sense – Jonathan Aug 31 '15 at 19:39
  • @JonathanLeaders, 173Mbps is the max data rate for your two spatial stream client at 20MHz. – YLearn Aug 31 '15 at 19:54
  • 1
    @JonathanLeaders How do you figure? With 100% perfect channel utilization and acknowledgements magically being free, you're still getting about 75Mbps (because 9 MB/s equals 75 Mbps) which is far more than 17% of 173Mbps. – David Schwartz Aug 31 '15 at 20:03
2

The router has Gigabit LAN, not Gigabit WiFi. Wireless AC tops out at 600Mb.

Gigabit WiFi is VMT: (Vendor Marketing Technology), Vendors realized Ethernet + WiFi = more sales. :P

I've seen throughput claims of 1.7Gbs which is nuts. :)

| improve this answer | |
-1

This worked for me for improving file transfer speed over Windows:

Disabling "Large Send Offload (LSO)"

Large Send Offload is a technique of improving network performance while at the same time reducing CPU overhead. Apparently it does not work very well, so it was suggested to disable it. If you would like to know about LSO, check this MSDN article from 2001.

LSO is an option located in a Device Manager under your network adapter, so this solution requires Administrator Privileges.

Follow these steps:

  1. Open Start Menu, right-click on Computer and select Properties
  2. Under Control Panel Home located on the left side of the window click on Device Manager
  3. You will get a list of all devices on your machine. Expand Network Adapters.
  4. Find your Network Card and double-click on it.
  5. Select Advanced tab. You will get a list filled with different options.
  6. Select Large Send Offload V2 (IPv4) and set the value to Disabled
  7. Do the same for Large Send Offload V2 (IPv6) if it is available
  8. Click OK

I did this on both windows machines

I did NOT have to restart

and I did NOT have to disable LSO V1

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.