This question already has an answer here:

I’m trying to set up a new network at my home and am having issues... in short, I can access the internet through my modem directly, but not through the router. Here is a brief writeup for today's 4 hours of troubleshooting.

Equipment used:

  • Comcast Xfinity cable internet (Blast upgrade: 105mbps)
  • Motorola SURFboard SB6121 modem
  • ASUS RT-AC56U router

Had the new house wired up with Xfinity this morning. Cable guy was here for just over an hour. Modem was registered and hooked up. He plugged it into my PC directly, and the Internet was working very quickly and reliably, with speeds as advertised.

When he left I proceeded to disconnect the modem from the computer, and add the router to the setup. The router is verified working, I’ve been using it as recently as Saturday on the DHL connection back home. Though the wireless network activates and is strong, and appears to connect to the Internet, webpages will not load. Wired connections through the router show the following error:

Connected: No internet access.

Windows troubleshooting yields the error message

The remote device or resource won't accept the connection.

I did some research on that error message, and got a lot of minor problems with quick solutions, the most popular being disabling proxy settings, that did not help me. So I moved on to search terms like "Internet through modem not router." This brought up more complicated answers having to do with the modem grabbing the MAC address of the computer instead of the router, or not being able to grab a router address at all. This sounded logical to me so I did some playing with it.

I have tried:

  • Different cables
  • Resetting and rebooting the router
  • Power cycling the modem
  • Cloning the MAC address of the PC and assigning it to the router
  • Different orders of restarting equipment, hoping the modem would identify with the router

All several times and in different orders, with no luck.

In short, all devices are working, I have internet to the modem, and communication is strong to the router, but no internet access wired or wirelessly.

Not sure where to go from here. Got any ideas?

UPDATE: Here is some additional information.

When I switch from using the modem for connection back to trying the router, I get a network error window stating:

Windows has detected an IP address conflict. Another computer on this network has the same IP address as this computer.

When running the ipconfig while pulling Internet directly from the modem, I get 4 results under DNS Servers:

2001:558:feed::2
2001:558:feed::1
162.150.21.49
162.150.8.49

When running the ipconfig while connected to the router, only one DNS server is listed:

192.168.1.1

marked as duplicate by JakeGould, Community Sep 1 '15 at 3:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    As the person who answered the question I am now voting to close this one on, this is a simple case of the MAC address being associated to your computer and not the router itself. To allow the router to now connect you must reset Motorola SURFboard SB6121 from your computer, disconnect the Ethernet cable, wait for the modem to restart and then plug the Ethernet cable from the modem into the WAN port on your router. More details in my answer here. – JakeGould Aug 31 '15 at 23:17
  • Also, did you ever at any point ping a known IP address like Google’s DNS servers at 8.8.8.8? If you can ping a known/working IP address bute named hosts fail then that means your DNS is screwy but the base Internet connection is active and working. If pinging a known IP address like 8.8.8.8 your external network connection is completely dead. – JakeGould Aug 31 '15 at 23:23
  • @JakeGould thank you for your help. I am trying to follow your detailed instructions from the other thread on resetting the cable modem. However, when I press "Reset All Defaults" and click OK, nothing happens (no confirmation message or reaction from the modem). Can you advise? – Andrew Pfluger Aug 31 '15 at 23:30
  • Just hit that button as I describe and disconnect the Ethernet cable. Look at the modem itself. The lights should be cycling as it resets itself. Another option is to completely power down the modem, wait like 15 minutes or longer and then power it up and connect it only to the router. The goal is to make sure the MAC address is reset on the modem. If for some reason that does not work, login to your Comcast account and see if there is a way to reset the modem from there. This kind of stuff is annoying but a common occurance. – JakeGould Aug 31 '15 at 23:32
  • @JakeGould it has been several minutes with no reaction from the lights on the modem. I am looking at the instructions here: surfboard.com/wp-content/uploads/2014/07/… Which would suggest that perhaps "Restart Cable Modem" is what I'm looking for? I did try disconnecting the modem for an extended time, and then connecting exclusively to the router, to no avail. – Andrew Pfluger Aug 31 '15 at 23:36

Make sure you're connecting the WAN port of the router (it should be blue on your ASUS RT-AC56U) to the LAN port of the cable modem.

  • 1
    Also make sure your router's WAN port is configured to obtain its address by DHCP. Also verify the DNS addresses the router obtains as this is why webpages don't load (their names can't be resolved so error out). – Kinnectus Aug 31 '15 at 21:33
  • Hi Spiff, yes, I have verified that the WAN port on the router is connected to the LAN port on the modem. – Andrew Pfluger Aug 31 '15 at 22:01
  • Hi Big Chris, I have verified that the WAN is set up for DHCP. Any chance you'd be able to walk me through testing your second recommendation? Not sure how to do this. Thanks – Andrew Pfluger Aug 31 '15 at 22:05
  • Hi Andrew, when replying to someone who wasn't the one who posted the Answer, be sure to @-tag them so they get notified. @BigChris – Spiff Aug 31 '15 at 22:07
  • Roger that, thanks for the heads-up, Spiff! – Andrew Pfluger Aug 31 '15 at 22:11

Similar to the comment by @BigChris above, one thing you can try is to make sure the DNS servers are the same when connected directly to the modem as when connected to the router.

To do this, follow these steps:

  1. Connect your computer to the modem.
  2. Ensure internet is accessible.
  3. Open a command prompt window, and type ipconfig /all.
  4. Look for DNS Servers, and note what IP addresses are listed there.
  5. Connect your computer to the router, and the router to the modem.
  6. Open a command prompt window, and type ipconfig /all.
  7. Compare these DNS server addresses to the previous list. They should be the same since you are still connected to the same service provider.

There may be websites to help with this test, such as http://dnscheck.pingdom.com/. Note that I haven't tested these sites... :-)

For more information on the ipconfig command, please see this link.

This test will not solve the problem, but it will confirm that the router sees the same DNS servers as the modem.

  • Nope. “…one thing you can try is to make sure the DNS servers are the same when connected directly to the modem as when connected to the router.” Many routers might handle the DNS via it’s own address such as 192.168.1.1 which then uses the main ISP DNS addresses the modem would provide. – JakeGould Aug 31 '15 at 23:30
  • hm. Is this the same person as the original question? If you have two accounts, you can have them merged. if not, well this is a little strange. – Journeyman Geek Sep 1 '15 at 3:54
  • @JakeGould, thanks for the correction. – Pflugs Sep 1 '15 at 10:41
  • @JourneymanGeek, I can understand the confusion. He's my kid brother. :-) – Pflugs Sep 1 '15 at 10:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.