0

Like the very flawed thing it was designed to be, UEFI is causing me some some serious problems. Allow me to begin.

I have an HP pavilion 4540s laptop. It originally came with windows 8, I got it used from a friend I trusted. Due to some issues with him attempting to install Manjaro linux, windows 8 was completely removed from the computer; but wait there is more.

Turns out since it shipped with windows 8, it also came with UEFI's "protection". Without windows 8 on the computer I cannot disable UEFI to install the GNU/linux distro I would like to use (incidentally I would like to use Majaro as well).

So my real question is how do I disable UEFI without using windows. I am pretty desperate for a computer so I am willing to take risks.

0

I am not sure why you must have a running Windows 8 to disable SecureBoot. After all what Windows 8 does if you go to the setting to change Secure Boot is reboot the Computer into BIOS.

Have you checked the settings in your BIOS? On Boot, press the Button to go into BIOS. From here go to Security tab and on the very bottom of the tab there should be Secure Boot Configuration. After a warning message you should be presented with options to enable Legacy Boot and Secure Boot.

If you wan't to use Linux Legacy Boot is mainly what you want.

But even with UEFI enabled you should be able to use Manjaro. I am running a Thinkpad with UEFI enabled and use Arch Linux (Manjaro is based on that) on this machine.

There are also guided on the Manjaro Wiki Page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.