2

I would like to run an interactive R job on a server. I would also like to enable X11 forwarding so I can view my graphs. However, I am having problems. My laptop is a Mac OS 10.9.4.

I have tried ssh -X to the host, then

bsub -J Rlive -Is -XF -M 50000 -R "select [(mem >16000)]" 

And now I get this error:

-bash-4.1$ bsub -J Rlive -Is -XF -M 50000 -R "select [(mem >16000)]" R
Job <562564> is submitted to default queue <medium_priority>.
<<ssh X11 forwarding job>>
<<Waiting for dispatch ...>>
waller@10.11.123.17's password: 
Sep  1 11:54:29 2015 26918 3 7.06 xagent main: initenv_() failed.

My DISPLAY variable seems fine.

-bash-4.1$ echo $DISPLAY
localhost:15.0

is there something I have to do with Xauth?

Any help is appreciated.

thanks

Thanks for the debugging suggestion, this is what I get:

waller@submaster:~>bsub -J Rlive -Is -XF -M 50000 -R "select [(mem >16000)]" R
Job <562888> is submitted to default queue <medium_priority>.
<<ssh X11 forwarding job>>
<<Waiting for dispatch ...>>
Sep  1 21:26:12 2015 33277 7 7.06 nios/main(): Nios running in standalone mode
Sep  1 21:26:12 2015 33277 7 7.06 nios/main(): Nios running in sbdMode mode
Sep  1 21:26:15 2015 33277 7 7.06 nios/acceptCallBack(): jobId 562888 opCode 562888
Sep  1 21:26:15 2015 33277 7 7.06 nios/acceptCallBack(): niosExecSSH(ssh -X -n 10.11.123.63 /opt/lsf/7.0/linux2.6-glibc2.3-x86_64/bin/xagent /opt/lsf/7.0/linux2.6-glibc2.3-x86_64/etc 28918..)
<<Waiting for xagent to report remote DISPLAY on 10.11.123.63. Press Ctrl+C to terminate ...>>
Sep  1 21:26:15 2015 33277 7 7.06 niosExecSSH: Final cmdLine: ssh -X -n 10.11.123.63 /opt/lsf/7.0/linux2.6-glibc2.3-x86_64/bin/xagent /opt/lsf/7.0/linux2.6-glibc2.3-x86_64/etc 28918 submaster 42107 /usr/share/lsf/conf
Sep  1 21:26:15 2015 33313 7 7.06 niosExecSSH: about to launch ssh -X -n 10.11.123.63 /opt/lsf/7.0/linux2.6-glibc2.3-x86_64/bin/xagent /opt/lsf/7.0/linux2.6-glibc2.3-x86_64/etc 28918 submaster 42107 /usr/share/lsf/conf
Sep  1 21:26:15 2015 33313 7 7.06 niosExecSSH: sshPathName = ssh
Sep  1 21:26:15 2015 33313 7 7.06 niosExecSSH: sshArgs[0] = ssh
Sep  1 21:26:15 2015 33313 7 7.06 niosExecSSH: sshArgs[1] = -X
Sep  1 21:26:15 2015 33313 7 7.06 niosExecSSH: sshArgs[2] = -n
Sep  1 21:26:15 2015 33313 7 7.06 niosExecSSH: sshArgs[3] = 10.11.123.63
Sep  1 21:26:15 2015 33313 7 7.06 niosExecSSH: sshArgs[4] = /opt/lsf/7.0/linux2.6-glibc2.3-x86_64/bin/xagent
Sep  1 21:26:15 2015 33313 7 7.06 niosExecSSH: sshArgs[5] = /opt/lsf/7.0/linux2.6-glibc2.3-x86_64/etc
Sep  1 21:26:15 2015 33313 7 7.06 niosExecSSH: sshArgs[6] = 28918
Sep  1 21:26:15 2015 33313 7 7.06 niosExecSSH: sshArgs[7] = submaster
Sep  1 21:26:15 2015 33313 7 7.06 niosExecSSH: sshArgs[8] = 42107
Sep  1 21:26:15 2015 33313 7 7.06 niosExecSSH: sshArgs[9] = /usr/share/lsf/conf
The authenticity of host '10.11.123.63 (10.11.123.63)' can't be established.
RSA key fingerprint is 97:14:a7:a9:76:ba:8d:3a:5f:0a:ff:01:4a:8d:b2:ff.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '10.11.123.63' (RSA) to the list of known hosts.
waller@10.11.123.63's password: 
Sep  1 21:26:29 2015 28928 3 7.06 xagent main: initenv_() failed.
Sep  1 21:26:29 2015 33277 7 7.06 niosExecSSH: ssh -X -n 10.11.123.63 /opt/lsf/7.0/linux2.6-glibc2.3-x86_64/bin/xagent /opt/lsf/7.0/linux2.6-glibc2.3-x86_64/etc 28918 has exited.
Sep  1 21:26:29 2015 33277 3 7.06 nios/acceptCallBack(): niosExecSSH() failed.
Sep  1 21:26:29 2015 33277 7 7.06 kill_self(): Nios kill_self, exit_sig=0 exit_stat=-1
  • Can you try running it in debug mode? As described here. You don't have to change lsf.conf, just set the environment variables in the same shell that you do the bsub. – Michael Closson Sep 1 '15 at 14:40
  • thanks - I added the output to running in debug mode above – user2814482 Sep 1 '15 at 20:13
  • Hmm.. It didn't provide any useful info. A common cause for initenv_() failure is that the env vars LSF_ENVDIR, LSF_CONFDIR, or LSF_SERVERDIR are changed or lost in xagent's environment. Is it possible that ssh or the shell (.bashrc, etc) is changing them? – Michael Closson Sep 2 '15 at 16:25
  • Is EGO enabled in your cluster? (i.e., what is the value of the parameter LSF_ENABLE_EGO in lsf.conf?) – Michael Closson Sep 2 '15 at 16:33
  • -bash-4.1$ echo $LSF_ENVDIR /usr/share/lsf/conf -bash-4.1$ echo $LSF_CONFDIR -bash-4.1$ echo $LSF_SERVERDIR /usr/share/lsf/7.0/linux2.6-glibc2.3-x86_64/etc – user2814482 Sep 3 '15 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.