1

I was using Windows 8 when I encountered this problem. My laptop's WiFi detects all WiFi networks but does not detect my office's WiFi. I am in range and my phone and colleague's laptops are connected to this network without any issue. I used to connect to this network before this issue occured. My laptop's WiFi can see other networks and can connect with them properly.

To resolve this issue I tried these things.

  1. From 'Device Manager' uninstalled the WiFi adapter's driver and re-installed WiFi drivers I have downloaded from HP site. I am using HP laptop Pavilion g6 2207-tx. No luck.

  2. Re-stared PC. No Luck.

  3. Installed another Windows 8 O.S. on another partition(after formatting the partition) of the Hard Disk. This time I was stuck to see that in installation process Windows 8 installation program asks me to join a WiFi network when the installation was just about to finish. Same thing happened here too, except my office's WiFi I was able to see other WiFi networks. (I am still surprising from where Windows 8 installation program picked the WiFi driver?). BTW I skipped that process of joining WiFi and completed installation of Windows 8. Same situation.

  4. I guessed that Windows 8 installation might have picked driver from the original Windows 8 installed on another disk partition. So this time I installed Windows 8 again. But in installation procedure I have deleted all the partitions and re-created new fresh partitions. Installed the OS on one of new partition. But No Luck(Also WiFi driver was surprisingly there. Installation procedure asked me to join a WiFi network but missing my desired network).

  5. Now I guessed WiFi driver was in windows 8 disk image. So I installed Windows 7 this time (Also deleted and created fresh disk partitions). After successful installation of windows 7 I installed WiFi driver. It is working but office's WiFi network is still not shown but others are.

  6. I have renamed my Office's WiFi.but still I can't see on my laptop. But changed name is visible on all other devices. Some one on web suggested this.

4
  • What WiFi standard is your router/access point using? The Laptop seems to work with /b /g /n standards – benjamin Sep 1 '15 at 13:19
  • Is the office WiFi running on the 5GHz channels exclusively? It might be the case in some rare situations. Are you in europe? Perhaps the laptop's wifi card is configured to ignore channels that are not valid in the US, such as 12, 13 and 14. – Ray Foss Sep 1 '15 at 15:53
  • @benjaminS WiFi standard is /b/g/n on router and laptop both. – stackOverflow Sep 2 '15 at 6:00
  • @Ray How can I know if the WiFi is running on the 5 GHz channels exclusively. Previously it was running properly. – stackOverflow Sep 2 '15 at 6:02
1

I've been reading all over the Internet for a fix to my sudden issue of not recognizing certain networks and nothing worked.

Today I started messing with stuff on my own and managed to fix it!

It was so simple:

I changed the Wireless Mode of my Intel Adapter (see the attached screenshot). The first one I switched it to worked. Not sure if this is anyone else's problem, but it was mine.

enter image description here

2
  • It seems unlikely that your problem was the same as the one in the question. – Blackwood Aug 30 '18 at 22:37
  • This solved a similar issue of mine. Where my laptop was unable to find my specific wifi router. – WaterRocket8236 Dec 19 '20 at 4:37
0

I encountered same problem. What I did was to roll-back the wi-fi driver from the properties page and the issue was resolved. Hope it helps someone.

-1

I had the same problem using Dlink 650L router. I found a solution by correcting the time in the WiFi router. After I changed the timezone and date it's working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.