1

I am at my wit's end. I'm trying to install Windows (7 or 8, I've tried both) on my Dell Latitude E6430. I currently have Xubuntu 15.04 installed with Grub 2.02~beta2-22ubuntu1.1. I want to dual-boot Xubuntu with Windows and I have allocated a partition for Windows.

My problem is, I am unable to boot my Windows install media in EFI mode. My SSD has GPT, so I need to boot the Windows installer in an EFI mode, legacy will not work. I have tried creating install media using the following methods:

On my Xubuntu system

  • ms-sys -7 and dropping the ISO contents on to the USB drive This produced an image that could only be booted with legacy-boot.
  • ms-sys -n and dropping the ISO contents on to the USB drive This was not bootable.
  • unetbootin I could not get any Windows install media to boot that was created with unetbootin

On a normal Windows System

  • Rufus This seemed to be the closest I got to working... I was able to manually use the UEFI boot settings on my computer to browse for the bootmgr.efi file on my USB drive when I created the image with Rufus. Unfortunately, when I tried to boot this way, I was told that the computer could not boot the selected media.

In all cases, the install media would never show up in my list of boot options automatically, and the only time it would show up at all was after I manually added the rufus-created entry.

Failing the traditional boot path, I thought I may be able to create a temporary grub entry that would boot my USB drive. The entry that I tried to use was:

insmod usbms  
insmod part_gpt  
insmod part_msdos  
insmod fat  
insmod search_fs_uuid  
insmod chain

set root='(hd1,1)'
search --no-floppy --fs-uuid --set 749A5FBD9A5F7A96
chainloader (${root})/bootmgr.efi

I also tried versions pointing to just about every .efi file on the USB drive. I used the grub ls command to verify that the files I was trying to boot actually existed, but they would all give me the same message, a very long string of path info terminated with:

/EndEntire

error: cannot load image.

I am going insane, could someone lend some advice?

EDIT: I have since been able to get the flash-drive recognized. Here are some photos of my process:

This is my UEFI config menu, you can see that I'm choosing the BOOTX64.EFI file for this entry. BIOS Menu

Finally the flash drive was recognized automatically, but when I tried to boot it... Recognized Flash Drive

Nothing. This is as far as I've ever gotten with a UEFI boot so far. FAIL

  • 1
    Which Windows boot media image are you using and where did you get it? The USB should be formatted as FAT32 - see this procedure. If you manage to boot Windows, follow this thread. I note that the normal and painless method is to install Xubuntu after Windows. – harrymc Sep 5 '15 at 8:57
  • I am trying to boot the windows 8.1 32-bit install media. I got it directly from Microsoft's product recovery page. I do not have access to a Windows install to follow that formatting guide. I know it is much easier to install Windows first, but I have been without Windows on this laptop for about a year and I'm finally giving in to a dual-boot for Photoshop and Lightroom. – Nate Mara Sep 5 '15 at 9:57
  • Use the Windows USB/DVD Download Tool to create the USB.If it doesn't help, please add screenshots of your BIOS options for UEFI and Secure boot, because it should boot automatically when chosen in the boot options menu without manually choosing BOOTX64.EFI. – harrymc Sep 5 '15 at 13:09
  • I just noticed : 32-bit Windows cannot boot with UEFI nor use GPT! Get the 64-bit media. – harrymc Sep 5 '15 at 15:54
  • imgur.com/gLZ5T0R oh man. Thank you. I have been trying to get this working for a week and it was just that simple. If you post that as an answer, I'll send that bounty your way. – Nate Mara Sep 5 '15 at 17:00
1
+50

The facts about Windows 7 (and later) are :

  • Windows 7 32-bit needs to be booted from BIOS, which implies that it must be booted from MBR.
  • Windows 7 64-bit can be booted from BIOS/MBR, but can also boot from EFI/GPT.

Therefore, only the 64-bit version of Windows 7 and later can use UEFI and GPT, and this is the version you should get.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.