10

I can't seem to figure this one out. I was using windows 7 and I had no issues with being VPN'ed into work and browsing websites. Since switching to Windows 10, it's another matter.

Windows 10 and no VPN, no issue. I can ping google.com and immediately get a response as well as the IP address. Windows 10 and VPN, The initial ping takes a good 10 seconds before getting responses. Once I get the IP it's fast, but the initial DNS lookup is slow. I can ping addresses directly and there's no delay so it's definitely DNS related.

I've done this in PowerShell:

Get-VpnConnection

Set-VpnConnection -Name "VPN Name" -SplitTunneling $True

I believe it works in the sense that very little traffic goes through the VPN, but DNS requests are still slow.

I've also disabled IPv6 from the VPN connection.

If it were possible to set the DNS servers to be used by the vpn connection, I think my issue would be gone, but I can't set them. The properties button on IPv4 doesn't do anything... at least not for the VPN connection.

Any other suggestions to get this to work smoothly?

  • 1
    See if this answer improves the situation. – harrymc Sep 4 '15 at 14:08
  • It didn't seem to unfortunately. – Recognizer Sep 4 '15 at 14:33
  • 1
    It seems like Windows 10 VPN is full of bugs and missing code. Try setting DisableParallelAandAAAA as described here and DisableSmartNameResolution as described here. Reboot after each change. It seems like VPN problems in Windows 10 have driven many people back to Windows 7/8, so you should be thankful that your problem is only a 10 seconds lag. – harrymc Sep 4 '15 at 18:33
  • I might actually switch back to 7 myself. – Recognizer Sep 4 '15 at 19:38
  • If you have upgraded from 7 to 10 and not deleted the folder Windows.old, then going back is easy. – harrymc Sep 4 '15 at 21:31
3
+50

If in the current version of Windows 10, VPN seems to have too many problems, this might leave only two options :

  1. Wait for VPN to be fixed in Windows 10
  2. Downgrade to Windows 7, as described below :

If you have installed Windows 10 over Windows 7, and you have kept the resulting folder C:\Windows.old, then you can use it to return to Windows 7.

This is the procedure :

  • In the Windows 10 Start menu select Settings
  • Click Update & Security
  • Under "Go back to a previous version of Windows", click Get started
  • Enter some angry message text into the "Why are you going back?" screen
  • Click Next and wait, as this will take some time
  • You will need to have your password to Windows 7 once the process is finished.

This is further explained in detail with screenshots in the article : How to downgrade Windows 10.

If you have deleted the Windows.old folder, a clean install of Windows 7 is probably the only remaining way to downgrade.

Ensure that you have a complete backup of your data before starting.

7

Disable IPv6 both on your NIC and the VPN. That did it for me.

  • How does one do this exactly? – Ramhound Sep 9 '15 at 12:58
  • THANK YOU! worked for me too. @Ramhound, Network and Internet> Ethernet> Change Adapter options> <select your adapter>, right click properties. Uncheck Internet protocol version 6> OK. – asp316 Sep 10 '15 at 23:03
  • @asp316 - I know how. I was asking for clarification so the answer was of acceptable quality. – Ramhound Sep 11 '15 at 0:59
1

I had this problem in Win 10 - Chrome / Firefox and Edge. I disabled IPV6 on the ethernet NIC and the DNS lookup up time reduced from 20+ seconds to almost instantaneous. Settings / Network & Internet / Ethernet / Change Adapter Settings / Properties - and untick Internet Protocol V6.

1

I had a same problem and found a solution which worked for me. What I did was to change the binding order of adapters in Windows 10 in such a way that Wifi has less priority than VPN. Here's how to do that:

  1. Open a PowerShell as Administrator
  2. See all the adapters with the command netstat -rn
  3. View the interface index using the command Get-NetIPInterface
  4. Change the metrics of the Wifi adapter to be a bigger number than the VPN (in my adapters list the VPN was listed as Microsoft Wi-Fi Direct Virtual Adapter)

You make this change with the following command: Set-NetIPInterface -InterfaceIndex "type the interface index of the wifi card inside double quotes" -InterfaceMetric "type the new metric which should be a bigger number than the virtual adapter inside double quotes"

I hope that helps, it worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.