I remember messing around with partitions in linux a while back and I clearly did something wrong at that time and now I can't seem to format my hard drives in Windows 10. In the screenshot below you will see my 3TB hard drive of which I am only able to format 2TB, I can't access that last unallocated part for some reason.

enter image description here

There are also two empty "drives" shown here which is actually a single 2TB hard drive which I seem to be unable to format or access in any way.

enter image description here

When I am stuck like this unable to format my hard drives using the Windows Disk Management Utility what are some good things I can try after this in order to be able to use my harddrives again? Are there any good ways of diagnosing a possible hard drive hardware problem?

Both hard drives are internal disk drives connected via SATA cable.

  • See Windows support for hard disks that are larger than 2 TB for a very full explanation on the 2TB issue. – DavidPostill Sep 2 '15 at 7:54
  • Have you tried your external HDD on a different machine? If it works on another PC( try a Windows different from 10) it's likely a problem with your USB host controller drivers. You should also look for the HDD manufacturer diagnostics tool and run it to scan the HDD health. – Techpumpkin_WD Sep 2 '15 at 14:55
  • I had the same problem in Windows 7, at that time I got the same issue on two different computers. At this moment I do not have another computer to test on. This is an internal HDD not a USB drive. Thanks for the tip about the manufacturer diagnostics tool, I will definitely look into that. – Markus Tenghamn Sep 2 '15 at 20:19

For the first disk - the 3TB that you can only use 2TB of - that is a limitation of MBR (Master Boot Record) disks. Just like the way that FAT32 can only store files up to 4GB in size, MBR can only handle up to 2^32-1 sectors in its partition table, with each sector being 512 bytes (4 billion * .5 thousand = 2 trillion = 2TB). You need to convert the disk to a GPT (GUID Partition Table) disk in order to use the rest of the space. It should have come that way, but maybe Linux converted it back to MBR; I've found some bugs in GNU Parted recently relating to GPT disks. Disk Management on Windows can convert a MBR disk to GPT, but you may need to delete all the partitions first (which means you'll lose any data on the disk that you don't back up first).

For the other disk, I don't really know what's going on there. I would check to see if BIOS/UEFI can see the disk, and reports it as healthy; if so, I would then check to see if another computer can access it or not. You could also try checking in the Windows command-line tool diskpart to see what it says - list disk and then select and check the details of the disk - but I'm less sure what the problem is there.

  • Thanks! I will backup and try your first solution tomorrow, I learned something new about MBR :) As for diskpart the disk simply shows with status "No Media". I will investigate further tomorrow and mark this as the best answer unless someone happens to come up with a signifigantly better answer. Thanks! – Markus Tenghamn Sep 1 '15 at 23:24
  • There is a way to convert MBR to GPT in Linux, did it some time ago, maybe I will find the link. This would safe you some restore time, of course you should backup anyway.. – Kimmax Sep 2 '15 at 17:21
  • I am selecting this as the answer as I was able to fix the problem with the 3TB hard drive because of this answer. @Kimmax was right about the drives showing "No Media" was simply card readers, see his answer below if you feel comfortable with Linux. – Markus Tenghamn Sep 2 '15 at 20:55
  • 1
    I found my solution here and used the AOMEI Partition Assistant Lite Edition to solve my issue, it did not remove any data on my disk but I still recommend backing up. I am not affiliated with the software and site. – Markus Tenghamn Sep 2 '15 at 20:57

First of all the two devices without space are some kind of card readers, most likely mounted into your front panel on your case and connected internally by USB, don't mind them.
Now to your HDD:

As mentioned in @CBHacking's answer you need to convert your disk from MBR to GPT. This can be done without losing data. Although the process is fairly safe, you should (as always) get a backup of the data.
Converting without data loss is possible because:

  • MBR is inefficient enough
  • Recreating the partition with the exact same parameters will cause the file system to reappear completely intact

When the MBR was written to your hard drive it will most likely have a size of 2048s, the standard size of the MBR at the moment or 63s when you used a really really old tool to format your drive. However since GPT only uses the sectors 1 to 33 there will be enough space to fit GPT in in both cases.
The simplest way I know (and used before) is the following:
Boot up a linux live cd with has gdisk on board (Finnix for example) and identify your disk. You could do the following:

$ ls /dev/disk/by-id/

which gives me as an example

ata-Samsung_SSD_850_PRO_1TB_[serial number]

back. Identify your hard drive this way. Now you have to start gdisk and specify your hard drive as parameter. Example:

You may have to drop the sudo if you are 'root' already

$ sudo gdisk /dev/disk/by-id/ata-Samsung_SSD_850_PRO_1TB_[serial number]

Drop any -part1, -part2 etc. (You can use the TAB key for autocompletion)
After this you should see something like this:

GPT fdisk (gdisk) version 0.8.5

Partition table scan:
MBR: MBR only
BSD: not present
APM: not present
GPT: not present

Found invalid GPT and valid MBR; converting MBR to GPT format.
THIS OPERATION IS POTENTIALLY DESTRUCTIVE! Exit by typing 'q' if you don't want to convert your MBR partitions to GPT format!

Don't worry nothing is written to your hard drive yet. You should now create the Bios Boot Partition by pressing n. Use the default partition number and press enter. Now you have to type in the first sector which is 34 (because GTP itself ends at 33) and press enter again. Now the last sector is needed which is 2047 (because your first data partition starts at 2048), press enter again. Now gdisk want's to know which type the partition is of, it's the Bios Boot Partition which has the hex code ef02 which you have to type in and press enter again.
When you see

Changed type of partition to 'BIOS boot partition'

you type in s and press enter again to sort your partition IDs.
When you think you did something wrong you can press q and enter without writing anything to the hard drive and start over. If you think everything is fine you can press w and enter which should exit the program like this:

Final checks complete. About to write GPT data. THIS WILL OVERWRITE

Do you want to proceed? (Y/N): y OK; writing new GUID partition table (GPT) to .
Warning: The kernel is still using the old partition table.
The new table will be used at the next reboot.
The operation has completed successfully.

You can now reboot and should be able to re size the partition as you like in windows (although you can also do it with gdisk).

You should be good to go. Have fun!

See this and this for more background information.

  • Interesting but wouldn't I overwrite when I get to the "Final checks complete. About to write GPT data. THIS WILL OVERWRITE EXISTING PARTITIONS!!" step? In my case I will make a backup but I don't see how it would be better than the answer by @CBHacking You were right about the cardreaders, I had recently switched to a new case and my hard drive did not show up. Turns out I had a lose cable from when I put everything together. Thanks! – Markus Tenghamn Sep 2 '15 at 20:30
  • You are right, the partitions would be overwritten and replaced by the gpt 'style' partitions, but the data wouldn't be affected, because the data partitions still start and end and the same sectors. Think of it like a map of the world. If you remove the borders and replace them by new lines in a new color the country itself wouldn't change and can still be accessed the same way, just the way the border information is stored has changed. Your tool did the same as above automatically for you. Hope I could help! – Kimmax Sep 3 '15 at 6:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.