0

This is a common problem I've had on multiple computers in the past. Currently it is happening often on one computer at work. I'll download an installer for a program from the web (typically using Chrome), then click the button in the bottom of the browser to open it, and nothing happens. I'll try the same from Windows Explorer and I get the busy mouse pointer (blue spinning circle alongside it) but nothing will happen even if I wait 10 minutes or more.

This happens with both .msi and .exe files, although not all the time. Currently I'm getting it with the Python 2.7.10 64-bit installer. It seems to be pretty random. The only thing that seems to work reliably is rebooting the entire machine, then opening from Explorer (where I get the "This program was downloaded from the internet, are you sure you want to run it?" dialog). EDIT WHILE I WAS WRITING THIS: I can actually get it to work by copying the file then opening the copy. Don't know why though.

My current guess is that something, possibly my antivirus (I have Microsoft Security Essentials installed) knows the file was downloaded from the internet and wants to scan it before it runs, but is somehow failing to do so.

Some other symptoms/things that don't work:

  • Closing Chrome (and manually killing all remaining processes) doesn't help.
  • Killing and restarting explorer.exe doesn't help.
  • Right-clicking on the file in explorer and selecting "Properties" gives the same result as trying to open, a busy pointer and nothing else.
  • Trying to rename the file in explorer while it was "busy" (attempting to release whatever lock has been put on it) crashes explorer.
  • Have you tried opening the file properties (in Explorer) and selecting "Unblock" then "OK"? This removes the "mark of the web" that causes that scare screen. I realize this would only treat the symptom, not the cause, but it might be useful as a work-around. – CBHacking Sep 1 '15 at 23:44
  • See the third bullet point above - this kills Explorer (at least when I'm already trying to opening it). – JaredL Sep 1 '15 at 23:49
  • Try doing it on a file you've just downloaded (to the Downloads folder or similar, not to the low-security Temporary Internet Files folder, where everything is considered untrusted) but haven't tried to open yet. This will help determine whether the problem is the MotW or something else. – CBHacking Sep 1 '15 at 23:56
  • So more than an hour after I originally double-clicked it the first file opened (or showed the dialog box asking if I wanted to open). I cancelled and tried clicking "properties" on it, and... nothing. Not even the busy pointer. I assume it will pop up in another hour. I downloaded another installer from the same page (32-bit Python 2.7), opening properties dialog works immediately. I closed without changing anything and the installer opens just fine on its own. The effect seems to be totally random. – JaredL Sep 2 '15 at 0:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.