13

Does anyone know, how can I bring back the old nautilus behaviour?

In old version (Debian <7), when I typed, the nautilus moved to first file that started with that typed phrase.

In new version (Debian >=8, maybe current Ubuntu too), the program search in entire tree (current and child directories) which is very anoying for common files, that are presented multiple times.

3

In short, you can't! Not currently with Debian anyway, the dconf key has been removed.

It's been marked as a bug for the last two years, so it doesn't look like anything is going to change in any hurry.

Best option is to switch to nemo, branched from gnome2 Nautilus, still maintained but without the insane new "features" they've added to Nautilus itself.

12

I think this might achieve what you want.

Files->Preferences->Search&Preview:
Search -> Search in subfolders: -> Never

It seems that this setting would cause the search in the current folder only.

Or you might change this setting in CLI:

gsettings set org.gnome.nautilus.preferences recursive-search 'never'

BTW, My debian release is stretch.

3
  • 1
    Thanks, works for me on Ubuntu v18.10. – Stephen Niedzielski Mar 16 '19 at 17:22
  • Thanks. works for ubuntu 18lts. life saver. otherwise nautilus is quite useless to find a local file, i know is in the current folder. – melchi Jan 8 '20 at 11:30
  • This should be the real answer. It worked. It's really annoying trying to search for a file/folder that you know exists in current directory, and system goes like "Hey, Im going to search the whole fucking tree for around 1 minute and return you every irrelevant result" – Eksapsy Oct 18 '20 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.