4

I am trying to add sound to a custom built workstation with an Intel S2600CW motherboard; the “vanilla” S2600CW model. This motherboard does not have any built-in sound (for security reasons?), so I added a SoundBlaster Audigy RX PCI-E soundcard. I have installed the latest version of the Audigy driver package. Unfortunately no sound can be heard.

Here is what I did to test:

  • played back audio via VLC, Media Player, Firefox and Windows Speaker Setup Test dialog
  • tested with external speakers and 2 different sets of headphones
  • tested Front Out/Headphone Out, Rear Out/Side Right and Center ports
  • verified via audio control panel that soundcard is activated and set as default playback device
  • de-activated NVIDIA HDMI audio devices via Playback panel
  • green volume meter in Sound > Playback control panel moves up and down during playback, indicating sound is being output
  • verified that Windows Audio and Windows Audio Endpoint Builder services are running
  • verified keys under HkeyLocalMachine > Software >Microsoft > Windows > CurrentVersion > MMDevices > Audio > Renderer include AudioEndpointBuilder and Audioserv in permissions
  • used Windows Sound troubleshooter but it didn't find anything
  • Device Manager lists all sound devices as working properly
  • no relevant warnings/errors in Event Viewer
  • updated BIOS to version 01.01.0009

Is there anything else I can try?

  • 1
    Does another sound card work in this computer? Does this card work in another Windows 7 computer? – harrymc Sep 6 '15 at 19:52
  • 1
    I considered it but from my experience, my friends tend to bang USB sticks with their knees, permanently damaging the USB ports. I can't imagine them plugging in headphones and being consistently cautious enough with the cable. Perhaps I could use sufficient zip-ties... – glenneroo Sep 6 '15 at 20:07
  • 1
    I guess your trouble with USB sticks could be solved by using a short usb 'extension' chord, something like this I mean. – Legolas Sep 7 '15 at 0:08
  • 1
    Have you tried the sound card in a different slot? I've encountered a variety of issues with Intel server boards handling certain slots differently than others (don't ask me why). – Twisty Impersonator Sep 9 '15 at 2:19
  • 1
    DxDiag 32-bit version says everything is OK. DxDiag 64-bit version warns me that ctaud2k.sys is not digitally signed by Microsoft (and thus not WHQL certified). – glenneroo Sep 9 '15 at 16:41
1

I exchanged the card with a TerraTec Aureon PCIe 7.1 card and had the exact same problem.

So I exchanged that one with a very cheap no-name USB sound card and voila, I have sound!

  • Happy something worked! And stuff like this is the reason I mainly use a Mac Mini nowadays. 9 times out of 10 I can plug in a basic USB device and it just works. Simpler times in a way! – JakeGould Sep 12 '15 at 2:00
  • I don't think it's fair to compare a dual Xeon (24 logical core) system with 128GB of RAM and an M.2 SSD to a Mac Mini, especially in terms of rendering 3D video ;) – glenneroo Sep 13 '15 at 10:22
0

Devices not functioning as designed is a common symptom when system firmware is not fully updated.

As far as I can tell, the most recent BIOS version for that family of Intel boards is 01.01.0009. To check your BIOS version without restarting your system:

Type msinfo32 in the Windows search bar. The System Information window will open. In the main System Summary, you can find your current BIOS Version/Date for comparison. To perform the recommended firmware update, you need to have BIOS version 01.01.0003. If you have that version, you can download the firmware update here, which applies to the entire Intel S2600CW family.

Here are the instructions for installing the firmware update.

  • 1
    I have updated from 01.01.0003 to 01.01.0009 and unfortunately still no sound. – glenneroo Sep 9 '15 at 17:12
  • Now that firmware has been updated, can you verify that the device driver installation is clean? Open Device Manager, right-click on the card and click Properties. Select Uninstall and be sure to select the checkbox for Delete the driver software for this device. Click OK and reinstall the driver from this link [link]support.creative.com/Products/…) If the drive is not digitally signed, you should receive a notification from Windows about it. – Austin Sanderson Sep 9 '15 at 17:36
  • Did as you suggested but the driver installed without any warnings or errors. DxDiag 64-bit still says ctaud2k.sys is not digitally signed. Tomorrow will be 14 days since buying this card, which is the last day to return it for a refund, which I will be doing. I will be picking up a cheap USB sound card instead. This soundcard was overkill for the job anyways, I just needed a single line-out plug. – glenneroo Sep 9 '15 at 20:14
  • Interesting. Worth a shot: try this one. It looks like a different driver but supposedly still compatible. I would definitely head back to the store if this does not work. support.creative.com/downloads/download.aspx?nDownloadId=13176 – Austin Sanderson Sep 9 '15 at 20:41
0

I'm wondering it you tried these two:

  1. Plugging in a normal 2.1 system into the Rear/SR slot, and explicitly going to creative software on your pc and changing to 2.1 system.

  2. Go to bios setting and CLOCK down the PCI 2.0 slots to PCIE 1.0 speed, if there is an option. There might be some option worth playing around surely.

Perhaps a PCI riser such as this one may help?enter image description here

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.