6

On Windows 7 we had the option of changing the order of keyboard layouts, so I could have my preferred layout as first to have it be the default at startup.

On Windows 10 I can’t find that option anymore. How can that be achieved in Windows 10?

  • 2
    Control panel -> Language. Pay your attention to Advanced settings as well (I hope Win-10 behaviour could be similar to Win-8) – JosefZ Sep 2 '15 at 20:43
  • @JosefZ Thanks. But Windows 10 is different. - No way to change it from there. – ispiro Sep 2 '15 at 20:48
  • I'm on Windows 10 and @JosefZ's approach worked. You can still access the Control Panel's language options, it exists in duplicate with the new Settings app. – Nicolas Louis Guillemot Jul 11 '17 at 23:16
4
  • Control Panel > Clock, Language, and Region > Change Input Methods > Options (for the given language)
  • Remove all layouts but the one you prefer at the top
  • Save
  • Go back into Options, and add the layouts back in the order you prefer

Very clunky, but it's the only way I've found to set it.

| improve this answer | |
  • 2
    This is the correct answer still. Just reorganize the keyboards by adding and removing until the stack is ordered. – Hugo M. Zuleta Jul 31 '18 at 11:34
  • 1
    Jesus Christ, is Microsoft even reading this or just avoiding questions like this all the time?? – Arturas M Oct 16 '18 at 20:11
  • 2
    There's no "Clock, Language, and Region\Language" for me, only "Clock and Region". I'm on 1803. – Anton Duzenko Apr 10 '19 at 15:52
0

In Windows 10 press Windows + R, write "control" and press Enter. It will open Control Panel.

Go to "Control Panel\Clock, Language, and Region\Language".

In "Change your language preferences" page select any language and use "Move up" or "Move down" buttons above.

Screenshot

| improve this answer | |
  • 2
    There's no "Clock, Language, and Region\Language" for me, only "Clock and Region". I'm on 1803. – Anton Duzenko Apr 10 '19 at 15:51
  • I have English, Danish and Russian. English and Danish share an input method, but two different keyboards. It is only possible to drag between English and Russian input methods, so I always have Danish in between. Danish can only be last if Russian is the default input method. This doesn't work very well with my work flow. – globetrotterdk Feb 16 at 14:36
0

Rearrange them in Language settings: (Settings -> Time & Language -> Language)

Preferred languages

| improve this answer | |
  • How to add a good inline image that improves the question. Copy and paste in the body. Windows has an inbuilt hotkey (Win + Shift + S) which executes Snipping Tool. Any screen captured will be copied to the clipboard. – somebadhat May 8 at 23:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.