I have two computers connected by an Ethernet cable. One is a Windows 8.1 devbox, and the other is a CentOS 7 development server with only a terminal interface (No GUI). The development server will at first only interface with the devbox.

How can I set up Windows 8.1 to enable PuTTY SSH connections to the CentOS 7 server through the Ethernet cable?

Here is a screen shot of the Network Connections dialog box in Windows 8.1 showing that it sees the Ethernet connection, but is calling it unidentified by default:

enter image description here

I need to learn the IP of the CentOS 7 server box and also set up home networking to make the connection happen. However what specific steps do I take to set this up?

1 Answer 1


As there is no routing device between the two, you need to assign an IP address for each of them, additionally being both in the same subnet. So, for example, you can assign the IP address (assuming these are not used, otherwise, you need to choose a different LAN segment): and to the Windows box. and to the Linux box.

For the windows machine:

  • Right click on the interface you refer on the snapshot, and click Properties.
  • Click on Internet Protocol Version 4 (IPv4)
  • Click on Use the following IP address
  • As the IP address field, enter (or a different one if this is already been used)
  • As the subnet mask, enter

For the linux machine:

You need to find out which interface matches your physical interface. To do that, you can access the /etc/sysconfig/network-scripts directory and run ls ifcfg-*. You'll get one file for each network address card you have. To edit the settings of the one that is connected, assuming it's called ifcfg-eth0, you would run vi ifcfg-eth0 (vi is the editor, you can use nano or pico or whatever you feel comfortable with), and put a content like this:


Then you just need to run:

ifdown eth0 && ifup eth0

There's no need for a gateway since as said there's no routing (and is not needed).

Now, on the linux box, you need to make sure that the sshd daemon is listening to that interface too. You can check that running:

netstat -atpn

And see what is the local address for SSH. It should be something like That would mean it listens to all interfaces, which is what you need. If not, you'll need to edit your /etc/ssh/sshd_config file and make it listen for this P2P interface as well.

  • Thank you, but how do I assign the IPs? What specific steps? Also, in CentOS, typing netstat -atpn results in a command not found error, however, I am able to vi /etc/ssh/sshd_config. Your answer is more like comments that do not give specific actionable steps that can be used by a new user. Can you please update it with specific steps?
    – CodeMed
    Sep 2, 2015 at 21:32
  • I've edited my answer to include the details you mention. As for the netstat command, verify you have the net-tools installed, if not, install it with yum install net-tools
    – nKn
    Sep 2, 2015 at 21:43
  • Thank you. The windows steps worked easily, but you had me in the networking tab to set IPs. Do I need to go in the sharing tab also and enable connections from the CentOS server? Also, ls ifcfg-* resulted in ifcfg-eno1 ifcfg-lo. How do your instructions change based on these results? Finally, the CentOS server is not yet connected to the internet, so yum is not yet an option. And it is not yet connected to my devbox, so I cannot ssh any rpm files in. Do I have to establish an internet connection from CentOS? Or is there another way?
    – CodeMed
    Sep 2, 2015 at 21:58
  • There's no need to enable connections on the CentOS server. If you got those interfaces, then my eth0 is your eno1, simply replace the naming and it should be ok. If you don't have access to internet, simply verify that the SSH daemon is listening to all the interfaces editing /etc/ssh/sshd_config and checking if there's a like like ListenAddress If not add it and run systemctl restart sshd
    – nKn
    Sep 2, 2015 at 22:10
  • This works now. Thank you and +1. Just out of curiosity, why did you pick those ip addresses?
    – CodeMed
    Sep 2, 2015 at 22:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .