3

I'm having a curious issue in my Windows 10 Pro 64: the task manager keeps telling I'm using 100% of CPU no mather what: it's just there, fixed, doens't matter which are the consumptions of the listed processes. I tried to find some solutions on the web (such as this link), but I couldn't find anything suitable and applicable for my specific situation (i.e. my Windows 10 version).

How could I possibly solve this problem? I quite don't see my PC being slower because of this, but still is clearly a bug since there is no way my PC would be constantly using 100% of CPU without droping not even 0.1% at least once.

Any help appreciated.

EDIT:

Funny: I noticed that by using the "Users" tab in Task Manager, I can easily notice the difference between the "real" PC consumption and the value W10 is giving me:

Difference in use

(Of course, this assuming the total use of the CPU's processing isn't supposed to be higher then the sum of what is used by each user)

EDIT 2: Now a relevant observation: going to the "Details" tab in Task Manager, I can verify that most of the CPU usage is really being consumed by the "System Idle Time" as you may see in the image below:

Idle Time consuming most of the CPU process

And well this is what I would expect! So it seems there is no process or service actually consuming high CPU, it's the Task Manager itself that is considering Idle Time as a normal process and summing it to the other "real" process and then showing the "100%" value.

3

The worst part about this is it prevents the CPU from throttling down when there's no activity. Here is how I recommend solving it:

  1. Open control panel
  2. Select System and Security
  3. Select Power Options
  4. Select Change Plan Settings (the active one if you have more than one)
  5. Reset to defaults.

The CPU utilization and the clock speed should immediately start dropping.

  • This solved the same exact problem in seconds. – user4749 Oct 11 '16 at 6:33
1

I've experienced something similar with Windows 10 but it was my HDD usage that was constantly at 100%

There are some registry modifications used to fix the CPU issues to the on you are having.

Launch the Registry Editor by typing regedit.exe in the Start menu and navigate to the following path:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker

Look for the Start entry and change its value from dword:00000003 to dword:00000004 (simply replace the 3 at the end of the value with 4).

Changing this value could have an impact on Cortana’s performance, but it appears to be closely connected to the high CPU usage in Windows 10. In case you’re not using Cortana at all, you’re on the good side. Otherwise, setting reminders won’t work.

Link to Softpedia solution in case the above method does not work. http://news.softpedia.com/news/windows-10-high-cpu-usage-fix-490908.shtml

Some suggestions for my HDD issue where to turn off "windows search" and "superfecth" and this brought down the usage to where it should be 1-3% and it was just a bug with Windows 10.

This link shows how to disable services Try turning off indexing and windows search, I had an issue with windows 10 where my HDD was constantly at 100%, after disabling those two services it brought it right back down.

If the above methods do not work i'd suggest running this tool http://www.7byte.com/

It tests your CPU and motherboard in general for errors, it could just be the CPU is coming to the end of it's life span.

-2

I dont use the standard windows Task Manager, I use Process Hacker. I have never seen the User tab. Windows has a very simplistic Cpu usage algorithm. And it is often wrong about the usage, especially about other programs where it can tell you that they are using 100% of cpu. When all they are doing is polling for something with no impact on speed.

So, System Idle is probably not immune to the same stupid algorithm. In a sense it using 100% of the cpu.

I would say, just ignore it. I don't think that there is anythign wrong with your setup. And I don't think that there is anything you can do to fix it.

protected by Community Jul 1 '16 at 3:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.