2

I have Windows 10 Pro (upgraded from Windows 8.1 Pro) and am having trouble joining the domain. All existing profiles and settings work, but today I needed log in with a user account which never logged in to that computer before. And I got the message:

There are currently no logon servers available to service the logon

Tried these steps: log in to local admin, leave domain, reboot, changed computer host-name, reboot again, join domain.

But now I'm stuck because I can't join domain again. I got message that domain name is not found or can't be contacted.

I removed the computer from DC active directory, flushed DNS on computer and DC, rebooted DC, changed DNS manually on computer, enabled NetBIOS over TCP/IP on IPv4. But nothing helps, always get the same message that domain is not found or can't be contacted.

This is what I found in WINDOWS\debug folder in one text file (doesn't remember file name)

09/03/2015 15:49:29:477 NetpDoDomainJoin
09/03/2015 15:49:29:477 NetpDoDomainJoin: using current computer names
09/03/2015 15:49:29:477 NetpDoDomainJoin: NetpGetComputerNameEx(NetBios) returned 0x0
09/03/2015 15:49:29:477 NetpDoDomainJoin: NetpGetComputerNameEx(DnsHostName) returned 0x0
09/03/2015 15:49:29:477 NetpMachineValidToJoin: 'IVETA-PC'
09/03/2015 15:49:29:477 NetpMachineValidToJoin: status: 0x0
09/03/2015 15:49:29:477 NetpJoinDomain
09/03/2015 15:49:29:477     HostName: Iveta-PC
09/03/2015 15:49:29:477     NetbiosName: IVETA-PC
09/03/2015 15:49:29:477     Domain: NEPLPADOME
09/03/2015 15:49:29:477     MachineAccountOU: (NULL)
09/03/2015 15:49:29:477     Account: NEPLPADOME\administrator
09/03/2015 15:49:29:477     Options: 0x27
09/03/2015 15:49:29:493 NetpValidateName: checking to see if 'NEPLPADOME' is valid as type 3 name
09/03/2015 15:49:29:555 NetpCheckDomainNameIsValid [ Exists ] for 'NEPLPADOME' returned 0x0
09/03/2015 15:49:29:555 NetpValidateName: name 'NEPLPADOME' is valid for type 3
09/03/2015 15:49:29:555 NetpDsGetDcName: trying to find DC in domain 'NEPLPADOME', flags: 0x40001010
09/03/2015 15:49:44:559 NetpDsGetDcName: failed to find a DC having account 'IVETA-PC$': 0x525, last error is 0x0
09/03/2015 15:49:59:562 NetpDsGetDcName: failed to find a DC in the specified domain: 0x54b, last error is 0x0
09/03/2015 15:49:59:562 NetpJoinDomainOnDs: NetpDsGetDcName returned: 0x54b
09/03/2015 15:49:59:562 NetpJoinDomainOnDs: Function exits with status of: 0x54b
09/03/2015 15:49:59:562 NetpJoinDomainOnDs: NetpResetIDNEncoding on '(null)': 0x0
09/03/2015 15:49:59:562 NetpDoDomainJoin: status: 0x54b

What can be causing this? The server is old and wasn't me who configured Server 2003 and DC. I don't think that there is any special configuration, just simple DC.

I can ping server from cmd by name and IP address. I use the same network as the domain. After changed DNS to server IP address (which is one by default when use automatic) and re-registered DNS, I got the same error.

dns connection error

  • 1
    Windows server 2003 is not supported anymore. You expect it to work with Windows 10, which was released just recently? – kinokijuf Sep 3 '15 at 15:06
  • I found peoples who's said that it works. With Windows 8.1 I was able join domain to Server 2003. So why this can't be able with Windows 10? – Fesiitis Sep 3 '15 at 15:12
  • @Fesiitis - Windows 10 isn't Windows 8.1. Windows 8.1 was released within the support cycle of Windows Server 2003. Windows 10 was released after support had been retired. – Ramhound Sep 4 '15 at 13:38
1

Flushed DNS with ipconfig /flushdns, added two DWORD entries to HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters - DomainCompatibilityMode = 1 and DNSNameResolutionRequired = 0 and rebooted computer. After that I was able join domain.

0

Ensure that you can ping the server from your administrator command line. Also, reset your IPv4 settings to the same Network as your domain. Then from the windows 10 system, re-register the DNS: ipconfig /registerdns.

Do a ping of the server:

i.e. ping 10.253.1.1 ping NetBIOS (name) ping FQDN

Let me know what you cannot ping.

0

1) Make a DNS flush, on CMD console on Windows 10:

ipconfig /flushdns

2) Add to windows registry:

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters  
DomainCompatibilityMode = 1  
DNSNameResolutionRequired = 0  

3) Reboot Windows 10

4) Add workstation to the Domain

5) Done.

protected by Community Feb 16 at 16:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.