-1

A CentOS 7 VM is running in virtualbox inside a Windows 8.1 host. I am trying to set up Bridged Networking, but am getting the following error highlighted in green in the print screen:

enter image description here

However, when I try to adapt to the error message by selecting a Bridged networking adapter, there are no options from which to select, as shown in this print screen:

enter image description here

So how do I select a bridged networking adapter in virtualbox and thus resolve this error by successfully configuring bridged networking?

3
  • How are you running VirtualBox? Do you run it as Administrator or with your normal account (I assume you're a local Administrator on the host box?)? A quick forum read and Run as Administrator and standard running the VB can sometimes result in "Not Selected" for bridged connections...
    – Kinnectus
    Sep 3, 2015 at 18:11
  • @BigChris Running VirtualBox as a normal user did not solve the problem. There still are no options for network adapter from which to select. Do you have any other suggestions?
    – CodeMed
    Sep 3, 2015 at 18:29
  • @BigChris The solution was to upgrade to the newest version of VirtualBox, which I wrote in an answer below. Thank you for your suggestion.
    – CodeMed
    Sep 4, 2015 at 0:24

1 Answer 1

0

The answer to this question was to upgrade VirtualBox from version 4.2 to the new version 5.0. The upgrade enabled the Network Settings dialog to autopopulate the Bridge Adapter options. This did not require any change to the setup of using just one Ethernet cable to connect the two computers.

3
  • 3
    This is not really an answer because if the network connection on the host OS machine was properly recognized, that “Name:” pulldown under “Bridged Adapter” would have options already in place. Perhaps VirtualBox 5.0 has nicer accommodations for direct Ethernet-to-Ethernet connections but I am using VirtualBox 4.3.30 and have all options available when selecting “Bridged Adapter” without thinking twice and this has been the case—at least with me—since at least VirtualBox 3.0. Meaning what you believe “solved” this issue could just be a big coincidence and nothing more. Sep 4, 2015 at 0:32
  • Again, one of numerous possible solutions, but valid nonetheless.
    – CodeMed
    Sep 4, 2015 at 0:34
  • Nope, this is not one of “numerous possible solutions” but you are correlating it as such in your mind. There is 100% no reason that “Name:” pulldown should have been empty for “Bridged Adapter” in VirtualBox 4.2. My assertion is the direct Ethernet-to-Ethernet connection is causing you more problems than it solves. Sep 4, 2015 at 0:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.