2

I have recently upgraded two PCs from Win 8.1 to Win 10. I also have a Windows Home Server box which I use to back up the PCs.

The PCs are woken automatically every day at 10am for the WHS backup. They also appear to automatically wake during the night sometimes (I assume for Windows automatic updates). Most of the time the PCs will sleep automatically after backup or update occurs, but sometimes they just stay awake (one of the PCs has just been awake for 10 hours since the daily backup completed).

I experienced a similar problem on Win 8.1, which eventually stopped, although I didn't identify a specific cause, but this now seems to have reoccurred after upgrading to Win 10.

I have tried running powercfg diagnostics: /energy reports some errors, but nothing that would prevent sleep, and /requests reports nothing keeping the PC awake. I have run the power settings troubleshooter (nothing identified) and have checked my power scheme settings are set for sleeping correctly.

The frustrating thing is that this is an intermittent problem; most of the time the PCs sleep correctly after finishing whatever they are doing, but every few days they just fail to go to sleep. I am unable to identify anything that is keeping them awake, or whether the sleep function is just failing to kick in for some reason.

Can anyone suggest possible fixes, or other ways of diagnosing why sleep is not behaving correctly on my PCs, please?

1

You can get a list of what is blocking sleep with "powercfg". Press Windows-X or otherwise reach an "admin" command prompt. Enter as follows:

C:\Windows\system32>powercfg /requests
DISPLAY: None.

SYSTEM:
[DRIVER] High Definition Audio Device (HDAUDIO\FUNC_01&VEN_10EC&DEV_0900&
SUBSYS_1458A0B2&REV_1000\4&1c3e785f&0&0001)
An audio stream is currently in use.
[DRIVER] \FileSystem\srvnet
An active remote client has recently sent requests to this machine.
[PROCESS] \Device\HarddiskVolume4\Program Files\Windows Media Player\wmpnetwk.exe
Media Sharing has been enabled through Windows Media Player.

AWAYMODE:None.
EXECUTION:None.
PERFBOOST: None.

Here three things are blocking sleep.

  • +1 but I wish I could give you +10 because I'd never heard of Win-X! I have no idea why not! – Ryan Jul 26 '17 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.