3

I'm trying to set up a second screen on my laptop. I plugged the screen using the VGA port and go to Preferences -> Display.

The screen is correctly detected, but when I try to activate it, an error is raised:

Failure of the configuration application: %s (translated from the French sentence from the screenshot below)

GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.cinnamon.SettingsDaemon was not provided by any .service files

Screenshot of the error

I don't know if it can help:

~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)

I did not find anything on the Internet about this specific setting... Does anyone know how to fix this? Thanks.

5

I received this error because cinnamon-settings-daemon was not running. You can check if it is running as the following command will list it:

pgrep -fa cinnamon-settings-daemon

If cinnamon-settings-daemon appears in the output of the above command then your issue is different to mine. Otherwise, run it from the terminal as follows:

cinnamon-settings-daemon &

This should enable you to change the screen settings.

Out of interest, cinnamon-settings-daemon wasn't starting on login because of this issue. Doing the following and then running cinnamon-settings-daemon fixed it for me:

rm -f ~/.config/monitors.xml{,.backup}
| improve this answer | |
  • I totally forgot about this post... I resolved my issue two or three weeks later... by upgrading to Linux Mint last version :-) I will never know if this could resolve my issue, sorry. – Maxime Lorant Nov 24 '15 at 15:18
  • Confirmed this works on a fresh install of Linux Mint 18 – crypdick Dec 5 '16 at 3:37
  • similar issue on Ubuntu 17.10 and additionally the daemon was renamed. i needed to launch /usr/lib/x86_64-linux-gnu/cinnamon-settings-daemon/csd-xrandr in a terminal to make the gui work. – mnagel Feb 28 '18 at 13:24
  • Can confirm @mnagel 's solution. I ran this in a terminal and during this time I applied the settings and didn't receive the error anymore. – Vlad May 3 at 6:35
1

Old thread but i had exactly the same issue as written. I solved the issue by removing cinnamon-settings-daemon-xrandr.desktop from the .config/autostart and restarting.

rm -f ~/.config/autostart/cinnamon-settings-daemon-xrandr.desktop

Removing ~/.config/monitors.xml did not work in my instance.

Linux Mint 19.2 Cinnamon (v4.2.4), Kernal 4.15.0-70-generic

| improve this answer | |
0

I resolved the problem by upgrading to the last version of Linux Mint.

I don't know if the answer of @Homme Zwaagstra would solve the issue, so I prefer to accept my own answer.

| improve this answer | |
0

I had a similar problem to what Homme Zwaagstra described. The difference, however, was that I had accidentally turned off cinnamon-settings-daemon as a startup application. If you are having this problem you could open up your startup applications manager and make sure that cinnamon-settings-daemon is running on startup.

| improve this answer | |
0

It has been answered many answers already, its about the cinnamon-settings-daemon not running.

On Linux Mint this deamon is supposed to be automatically started at startup.

Go to Menu > Startup Applications.

Make sure Cinnamon Settings Daemon - xrandr is enabled.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.