2

Running Windows 8.1 as host OS and connected to WLAN via wireless USB plugged-in to my machine.

Using VMware Player 7 I cannot establish a connection to the internet using either 'Bridged' or 'NAT' network modes.

If I launch Linux Mint as a guest OS within VMware Player I can go in and manage VM Player settings -> network adapter -> bridged -> configure adapters and choose the correct Realtek Wireless LAN network adapter (same one successfully used within host OS). Still cannot connect to the internet in VM.

I have also tried with other guest OS such as Ubuntu and Kali but no success.

I can also click on Removable Devices in VMware Player menu and see the correct 'Realtek USB WLAN' but is not currently connected. I choose the option to 'Connect(Disconnect from host)' and yet still no connection within the VM.

Tried turning off Windows Firewall but no difference.

Does anyone know how to resolve this?

EDIT:

Below is a screenshot of what happens when I try installing VMware tools with a guest OS selected and powered on. I am logged-in as root and have mounted the CD drive following the terminal as instructed in the VMware Player documentation that shows the way to install tools. As I already stated in the comments section of this question, the issue is I cannot locate the .tar installer.

enter image description here

  • Are you sure the problem isn't in your Linux Mint configuration? – Ƭᴇcʜιᴇ007 Sep 4 '15 at 15:19
  • Did you install the latest VMWare tools? – Metalzwerg Sep 4 '15 at 15:20
  • @Ƭᴇcʜιᴇ007 in what way? I have also tried with other guest OS such as Ubuntu – smoggers Sep 4 '15 at 15:30
  • That little piece of info would be good to know for those trying to help you, wouldn't you agree? ;) Please consider editing your question and adding that information (and anything else you've already tried) into it. – Ƭᴇcʜιᴇ007 Sep 4 '15 at 15:32
  • @Robin I have tried to install tools but cannot locate the .tar installer, probably because it cannot download it from the internet – smoggers Sep 4 '15 at 15:33
0

If it exists, you can find your VMWare tools installation in /usr/bin/

To manually execute, you would run vmware-toolbox-cmd in that directory.

Getting the toolkit without an Internet connection might be tough if removable media is also not recognized by the VM. You could share a folder from the host OS by editing virtual machine settings with the VM powered down. That is the next troubleshooting step.

  • thanks for the advice, I've checked /usr/bin/ and can only see 'vmwarectrl' and 'vmstat'. thing is, removable media is recognized by the VM; each time I power on the VM a pop-up message says 'the following device can be connected....Realtek USB WLAN' which is the exact NIC that is used within the host OS and that I want to use inside Mint VM. I shall try obtaining the VMware tools via my host OS and try the shared folder approach – smoggers Sep 4 '15 at 21:24
  • It looks like there is a way to download the tools through the VMWare player, if it uses the host connection. With the guest OS powered on and selected, click Player>manage>Install VMWare tools. Also, looks like you can mount the CD ISO from command line here: kb.vmware.com/selfservice/microsites/… – Austin Sanderson Sep 4 '15 at 22:17
  • Yeah I know of that way but remember the whole problem is I cannot for whatever reason use the host connection. I have already tried the terminal install method but there is no .tar installer to use – smoggers Sep 4 '15 at 22:29
  • I think it is worth a try since the VMWare player is running on the host and has access to the host connection. If you can update it with the VMWare player, it might work. I just created a VM with no OS, and it was able to download the tools. Since there was no OS, my logic says it must be using the host connection. You may have to disable the network adapter in the VM Settings so it hopefully defaults to your host connection. Then you can turn it back on. – Austin Sanderson Sep 4 '15 at 22:43
  • I don't know how you are doing that. When I load VMware and try to get tools from the menu without a OS it is not even giving me the option to get the tools. Then when I click on a OS (that is powered off) and try to get tools from the VM menu (without the OS running) the install tools option is greyed out. – smoggers Sep 5 '15 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.