2

The drive in question is a 3TB SATA Seagate (ST3000DM001-9YN166; Firmware: CC4H) hard disk drive and my system is Windows 7 64-bit.

I had some GPU trouble a while back and required to hard-reset a few times because video output would freeze; driver updated a dying GPU killed it, tried getting helped, each time I “tried” a fix, I would need to hard-reset to get back into windows to try another driver version.

After giving up and removing the GPU and returning to Windows, one of my drives disappeared.

I’ve tried TestDisk and Diskpart, neither can even see the drive.

I have it running on my external USB enclosure, one of the partitions of 4 became RAW. I’ve since formatted it and left it as unallocated under the assumption theres most likely a bad sector in that region.

I’ve tried putting the drive back into my PC and it still cannot be seen by Windows.

Any suggestions as to why the drive is not recognized when connected to the PC via SATA but works fine in an external USB 3.0 enclosure?
One of the partitions is a main data drive letter so I'm constantly writing/reading from it, its working right now in the enclosure.

0

I see two possible culprits:

  1. The disk is not getting adequate power to spin up. If the disk drive has been degrading, it might require more power to spin up than usual. USB 3.0 may be providing adequate power. Check power cables also.
  2. You somehow wrote your boot sector files to the secondary hard drive. In this case, it should be visible by Disk Management but not Windows Explorer.

The following steps will erase the hard drive if used. I recently encountered the second case with a hidden drive. I could see it but only in Disk Management and could mount the drive and access the contents through it. I attempted to format it at the command prompt:

    diskpart
    list vol
    sel vol x, where `x' is the volume number associated with the drive 
    clean

If the drive contains the boot sector, it will not let you clean the drive.

In the case of number two above, you'll need to migrate the boot sector files from the secondary hard drive to the primary. Found this SO answer which should help with case #2

  • Over SATA, the drive does not appear in Disk Management either. in disk management, is the first partition on the left, the first "sector" where the boot should have been written to? because its just happens to be my XP dual-boot partition, thought it would make it easy if I made it the first partition. It cant be power, using a Corsair AX850 PSU, I can hear the drive spinning when plugged in via SATA. – HyeVltg3 Sep 5 '15 at 17:47
  • Is it enabled in BIOS? Does it show up in BIOS where you can see the size? What command did you run in diskpart to search? Have you verified storage drivers? – Austin Sanderson Sep 5 '15 at 18:07
  • Will be able to check this tomorrow, been very busy, hence why Im replying at 3am haha. How exactly can you "verify storage drives" ? I dont think it appears in bios when I checked a while back (will double check) With disk part, I only get to "list" and it never shows the drive, if I did it now, while the problem 3TB is connected via USB 3.0, I'd see it with the list cmd. – HyeVltg3 Sep 6 '15 at 6:50
  • So you are running an XP dual-boot configuration? Are you running multiple drives or 1 drive with multiple partitions? Your original post only mentions Windows 7. Can you boot to XP from plugging the drive into the computer SATA ports? Those details + screenshot of your Disk Management will help in your question. I'm now thinking it is a difference in the partition schemes for drives larger than 2TB that contain boot files, making Windows 7 not recognize the partition. You might also need to assign a drive letter to it. XP boot sectors are hidden in Win 7. – Austin Sanderson Sep 6 '15 at 23:07
  • Over SATA Over USB Just leaving these here. Sorry for the late reply, been very busy. I am not using XP dual-boot anymore since a recent format, main reason I updated video drivers and all my problems started. As you can see from the Disk Management, I AM running multiple drives. Also checked Bios the 3TB drive is not detected (this is via SATA). Should I try to remove/format the XP Partition? – HyeVltg3 Sep 10 '15 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.