2

I'm running Windows 10 with Firefox 40.0.3 as my default browser. I'm running multiple Firefox profiles simultaneously, one for development and one for browsing. One of the profiles is set as default. The issue is that whenever I, while having the default profile window open, try to open a link from some other program, I see the following error message

Firefox is already running, but is not responding. The old Firefox process must be closed to open a new window

Following screenshot shows the error message that pops up when I, e.g, click "More Skins" in Windows media player. This action is probably meant to open a new Firefox tab.

The same error message pops up when the default profile is running and I try to launch Firefox again (by using its shortcut or Cortana).

enter image description here

Update

I've just realized something that might be vital to resolving this issue. I've the dev profile set as default but whenever I try to open a link from external app while having both profiles' windows open, it tries to open it in the instance running in other (browsing) profile. When I go ahead and click the close button, it display another error that states

Your Firefox profile cannot be loaded. It may be missing or inaccessible

enter image description here

3
+50

I would to ask for additional info using the comment, but I can not post comments on StackExchange Network yet. Because of being a newbie and not having enough reputation points.

I currently run Linux, but I met such behaviour in the past, no matter of operating system used.

How do you start Firefox instances? Do you use original shortcuts in Start menu / Desktop / Quicklaunch? If yes, you should create the new shortcuts (on the Desktop) with different parameters. Just tell me how do you start Firefox and if you ever edited the parameters for the shortcuts, I will try to find out and write more.

You might also copy-n-paste the content of the profiles.ini file that Firefox uses, this would be helpful. It should be somewhere in the %APPDATA%\Mozilla\Firefox folder or similar.

EDIT 1:

EDIT 2:

OK, you're starting Firefoxes the correct way.

1) The parameter -no-remote should be actually in your devel profile target, so add the -no-remote to the target of the shortcut you're actually using to launch your devel Firefox. Remove the -no-remote parameter from the browsing profile.

2) Check your profiles.ini file as mentioned above. It should contain following lines at the very beginning of the file:

[General]
StartWithLastProfile=0

[Profile0]
... file continues...

If it does not contain the first two lines, backup the profiles.ini and add the lines. Or change the StartWithLastProfile value from 1 to 0.

After editing the shortcuts and the profiles.ini file, the expected behaviour is:

a) if you click the link from any other application and the Firefox browsing is already running, it should be opened in the browsing profile.

b) if you click the link from any other application and the Firefox browsing is not running, the profile manager should be launched. You will select the browsing profile from the dialog, do not check any of the checkboxes and confirm. The link should be opened in the Firefox browsing profile.

It works for me on Linux and as far as I remember, it also worked for me on Windows in the past.

  • I use desktop shortcuts for initially launching Firefox. I've created shortcuts for both profiles on desktop having different -p parameter, e.g., shortcut for my browsing profile has following target "C:\Program Files\Mozilla Firefox\firefox.exe" -p browsing -no-remote – Ejaz Sep 8 '15 at 13:12
  • I Still can not post comments to the other users' posts. I will post comment my own answer, but this comment technically belongs to the question. This problem most likely has nothing to do with Firefox safemode or even Windows safemode. Therefore the steps @harrymc recommends should have no effect. – user5265 Sep 8 '15 at 13:56
  • It worked! The misspelling of --no-remote to -no-remote was the issue. The error doesn't not show up after I've corrected it in both of my shortcuts. Thank you. I'm not able to award you the bounty, "wait 2 hours" says the system. – Ejaz Sep 8 '15 at 17:22
  • One more edit. I've read the documentation on the Mozilla website to improve the answer to be the most correct. I also did some additional testing on my PC with my Firefox profiles. All these final findings & results are now composed in the answer. The parameter "no remote" is actually -no-remote (sorry for my mistake before) and the changing to --no-remote (as I erroneously suggested before) is actually equal to deleting the parameter, this is why it worked for you. You can now delete the --no-remote from your browsing profile and add the he -no-remote back to your devel profile. – user5265 Sep 8 '15 at 18:07
  • @ Ejay: Regarding the update of the question: Links from other applications will always be opened in the default profile. Which is dev now, you need to modify the dev profile shortcut by removing -no-remote parameter from the target & add the parameter back to the browsing profile. Let me know about the result, but I believe it will fix it all, as I was able to reproduce the described behaviour. The dialog texts are slightly different (bc of different OS), but the meaning is the same. Comment to long, continues... – user5265 Sep 9 '15 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.