0

Is it possible to enable logging in to a domain through a shared VPN connection?

I work from home. I picked up a new laptop from the office which is already joined to the domain, but I stupidly forgot to login while connected to the office's network before bringing it home. So now of course I cannot log in because of no cached credentials and no connection to the VPN. I get this error when attempting a login:

There are currently no logon servers available to service the logon request.

Now I could make the long journey back to the office just to plug in, but in the spirit of learning something new, I wanted to see if it was possible to share the VPN connection established by the old laptop with the new laptop. So I did the following:

  1. On the old laptop, I connected its WiFi and established a VPN connection; everything is accessible as expected.
  2. On the virtual network adapter for the VPN connection on the old laptop, I enabled Internet connection sharing, using the Ethernet connection as the "Home network connection"
  3. I connected an Ethernet cable from the new laptop to the old laptop.
  4. I attempted the login on the new laptop.

Unfortunately, I still get the "no logon servers available" error.

Is there anything special I have to do to enable the new laptop to reach the domain's logon servers through the shared VPN connection?

Update 1:

Maybe ICS is not working. Connected another computer via Ethernet, and DHCP is not giving it an address.

Update 2:

OK, maybe it is working but something is up with DHCP? On that Linux box, dhclient eth0 got it go acquire an IP address. I cannot verify for sure whether the new laptop (Windows 7) is getting an IP address or not, but at least it seems ICS is working and can use DHCP.

Update 3:

This may relate to DNS. When I connect my Linux box to the old laptop, nmcli dev show eth0 does not list any DNS servers, so perhaps the new laptop just cannot resolve the logon server names.

Update 4:

DNS does not seem to be working on the old laptop. When connected with the Linux box, nslookup superuser.com <old laptop IP> errors out with:

;; connection timed out; no servers could be reached

I even tried forwarding the UDP & TCP ports for DNS to a real DNS server, and that didn't change anything.

Update 5:

Even lookups via Google's DNS server fails. Though I can ping 8.8.8.8 just fine, nslookup times out. Perhaps there's some packets being blocked when doing DNS lookup.

0

If you can login locally on the new laptop, create and connect a VPN connection that is available for all users, then use fast user switching to login whilst the VPN is active.

  • I don't have a machine login if that's what you mean. – Jacob Sep 5 '15 at 21:10
  • I mean a local user or admin on the machine not the domain. There is always one created when Windows is installed – netniV Sep 5 '15 at 21:12
  • Right, I don't have one, and I did not set up the machine. There's gotta be a local admin user, but I don't have the credentials. That's why I'm trying to use the VPN to log in. – Jacob Sep 5 '15 at 21:15
  • What is the OS on the old and new laptops ? – netniV Sep 5 '15 at 21:18
  • Oh and I think you shouldn't have the VPN as the home connection because that is the Internet one you want to share. The home is the connection it should be shared with. – netniV Sep 5 '15 at 21:19
0

I had this same issue today and managed to do it.

Like the OP, I picked up a new company laptop and forgot to do the initial log in using the corporate network at the office. I still had my previous laptop with me, which had vpn connection to the company network set up.

Here's how I did it:

  • Old PC: Windows 8.1 Enterprise with VPN to the Office
  • New PC: Windows 10 Pro
  • I connected the old PC to the internet using WiFi from a router with regular residential internet access
  • I modified the VPN network adapter to include the company's DNS Servers in the Internet Protocol Version 4 (TCP/IPv4) option
  • I enabled Internet Connection Sharing for the VPN network adapter, selected Home Networking Connection > Ethernet and enabled "Allow other users to control or disable the shared internet connection"
  • I connected to the company network using the VPN connection on the old PC

On the new PC:

  • I connected it to the old PC over ethernet cable and got a limited connection - authenticating with my corporate user failed with the "There are currently no logon servers available to service the logon request."
  • I then enabled WiFi along with the ethernet cable and connected to the same router the old PC was using to access the internet
  • I managed to log in with my corporate user on the new PC.

Afterwards I reverted the changes on the VPN adapter on the old PC, shut it down and then shut down the new PC as well and booted it again, just to confirm - successful log in with my corporate user with or without WiFi access > Solved.

  • One of the guys on IT Support had told me that the initial log in had to be done at the office using the corporate network, but there's also the possibility that in my case, the laptop had some additional configuration in order to allow initial log in outside of the corporate network. I will try to confirm it. – Wickwire Nov 6 '15 at 14:08
  • Glad that worked for you. That wouldn't have worked in my situation because I couldn't connect the new PC to my Wi-Fi network without being able to log in. If I had been able to log in as a local user, it probably would have been doable. – Jacob Nov 7 '15 at 1:17

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.