3

I recently installed windows-7 home premium 64-bit on my computer. I had two accounts on it. One admin account and one account of the type "homeuser" (I think it was).

This morning when started the computer only the admin account was visible. Logging in using the admin account I could see that the other account was also missing from the "Manage Accounts"-view.
The files for the account in the user-folder was still there though. I tried restoring my computer to the state before installing a update last night but to no avail. I could still not see the account or log on.
Running the command "control userpasswords2" I could see that the account was there though and by removing the need for passwords and setting it as default I was finally able to use it.
It is still missing from the "Manage Accounts" though and if I log off then I still can't login using it.

I found one site where a similar problem was described and that the reason was that the account had been disabled. The solution was simple:
Open "Computer Management" and navigate to "Local Users and Groups" and enable the account again. The problem is of course that in Windows Home Premium that option is not available since it only exist in the Business version.
So finally the question is: Is there a way to either control the state of an account and enable/disable it without using "Local Users and Groups" or if not is there a way hack windows to enable "Local Users and Groups"?
Or, is there any other ideas as to why my account has hid itself? :)

EDIT:
Thank you Molly for your suggestion, unfortunately it didn't work. It is still not possible to see the account at the login screen or in the "Manage account" view. Though interestingly it is possible to see it in the parental control window.

Any other suggestions to why the account has disappeared and what can be done to fix it? I can live with my workaround but it doesn't feel that stable.

  • It would be better to add comments to the answers provided instead of editing your original question. Edits should be made when you have something important to change. – alex Jan 17 '10 at 16:09
0

I just had the same issue on a Windows 7 Pro x64 box, and never had any issues on Windows 7 Ultimate x86/32bit version.

I will assume that it might be a 7 Pro issue, or bad port on Microsoft's part to x64 (or a bad software combo on a Lenovo due to all the tweaks they do with all the goofy bloatware software preinstalled.

I restored from scratch, did all updates, installed office, did all updates, set Admin passwd, enabled Admin account, rebooted. User wasn't available, but I used that user to do ALL UPDATES AND INSTALL ALL SOFTWARE. User was able to be seen in Computer Management, and not disabled account, yet could not see the user during logon, nor in CTRL PANEL in users.

Deleted the account through Comp. manage and recreated, and all is well (after deleteing the profile as well)...

  • I have since I wrote my question reinstalled my installation. I will accept your answer though since I'm pretty certain that it would work. Even if it's a bit more heavy handed than I would have liked. – Skadlig Mar 7 '12 at 7:13
3

I just had similar problem - I created new user (using Manage Computer, Local Users and Groups) and this user is not visible in login screen nor Manage Accounts.

So I noticed that user belongs only "Homeuser" group and NOT to Users group. So I add it to Users group and all works now, user is visible in login screen and Manage Accounts.

2

Is there a way to either control the state of an account and enable/disable it without using "Local Users and Groups" or if not is there a way hack windows to enable "Local Users and Groups"?

yes, you can enable/disable a user account through the Windows registry, as described in this tutorial:

How to Hide or Unhide a User Account in Vista (works in Windows 7)

see Method #2

1

I believe I may have an easier answer, providing you know the name of the "missing" account.

You can also do the following from a command prompt (Start → Run → cmd) in Windows 7 Home Premium:

net user "someone" /active:yes

To disable an account without deleting it (will also hide the account from the control panel UI) you can likewise do this:

net user "someone" /active:no
  • Interresting suggestion but it unfortunatly didn't work. – Skadlig Jul 19 '11 at 6:20
0

Check the membership of that user. In my case it was in the "Home Users" group, I have added it to the computer\Users group and then it re-appeared

-1

To share my experience too. I had problem that I couldn't login into user's account. In parental controls, user is visible and editable. I tried with registry and command prompt, even disabling and enabling visibility of account. Nothing worked. When I added registry SpecialAccount, the user disappeared from parental controls too.

If anyone had similar problem, this worked for me. I suggest checking where your user is a member of. So open this program: C:\Windows\System32\lusrmgr.msc And follow these steps, to add problematic user account into "Users" group, not just "HomeUsers": https://www.sevenforums.com/tutorials/103570-user-accounts-add-remove-groups.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.