I recently obtained a new computer, and I've been trying to map a network drive so that I can access it from This PC, similar to a normal hard drive. The network drive is a Seagate GoFlex Home connected to a router via ethernet, and the computer is running Windows 10 Home and connected wirelessly. I've tried connecting using the wizard in This PC. After I enter the credentials, I get this message:

The mapped network drive could not be created because the following error has occurred:

A specifid logon session does not exist. It may already have been terminated.

I'm certain that the credentials are correct. I do have a second computer, which has both Windows 7 and 10 installed, and it can connect fine when running either OS.

One thing that I noticed is that on the dual-boot computer, the drive is listed in Network as a computer, even if it's not mapped. It does appear in the new computer's Network folder, but as a storage device and media device. I can access it from here, but only image and sound files are listed.

I can also connect by entering the drive's IP address into a web browser. I can access all of the files from here, but it's a bit inconvenient. If I enter the IP address into Explorer instead of the device name (\\\\ instead of \\\\GOFLEX_HOME), I'm able to see the shared folders, but if I try to enter one, it asks for credentials, and after I enter them, I get the same error message.

I've tried chnging the IP address; I've tried making the workgroups of the drive and computer the same; I'm not really sure what else to try. It's worked fine for several years with the other computers, but it doesn't work from the new one.

Any suggestions?

  • This happened to me just now - my PC stopped connecting to my NAS drive. It must be something to do with the most recent Windows Update (which installed itself last night). That's not great :-/
    – Grim...
    Commented Sep 20, 2016 at 19:23

3 Answers 3


Thanks @Gurdeep for pointing us to the right directions. But SO pages are not exactly the place for link responses. Here is an excerpt of that page that contains the solution:

  • Launch the "Credential Manager" in Windows 10 (search for it in the Start Menu)
  • Open "Windows Credentials"
  • Click "Add a Windows credential"
  • Internet or Network Address: \\servername (replace with the Netbios-name of your cloudstation, or use IP)
  • User name: servername\username (replace with netbios-name and the username you are connecting with)
  • Password: Self-explanatory
  • That helped, but Internet or Network Address should start with two double slashes in my case, like: \\SERVERNAME
    – astef
    Commented Nov 20, 2016 at 20:47
  • Thanks for noticing @astef. I fixed it on the post. That happened because of backslash escaping.
    – douglaslps
    Commented Nov 21, 2016 at 12:33
  • 5
    The important part for me was using credentials in the form servername\username as the account I was using was set up on my server (a NAS) and was not tied to my Windows account.
    – CBono
    Commented May 18, 2019 at 13:54
  • 1
    I could not save the credentials in the Credential Manager but when I have the username as servername\username in the net use command it works :) The Problem existed only with PIN-login at a Microsoft 365 Account. Commented Aug 26, 2020 at 8:35
  • Using servername\username also fixed this error when encountered in the Windows Image Restore wizard.
    – zymhan
    Commented Mar 1, 2023 at 19:22

I had a problem like this, my samba share stop working after windows 10 updated, and it happened on more then one of my pc's. The samba share was setup to use no auth, guest accounts. To fix do a @douglaslps said but since username and password are not a thing just set them to random values and it should work, I set it to username:a password:(left blank). I hope this helps others out.

  • 1
    +1 Setting user/password each to "a" allowed me to access a samba share with guest login enabled
    – Matt Klein
    Commented Sep 25, 2016 at 17:01

If you have this accessing SMB1 shares, go to control panel. In my case I still had SMB1 support enabled but Automatic SMB1 removal was also installed. I uninstalled it and the problem disappeared.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .