1

I recently reinstalled Windows 10, and so lost all of the Toshiba software that came with the laptop. I have since reinstalled the AMD graphics driver, the Toshiba Function Key Desktop App, The Toshiba Value Added Package (this only gave me the battery manger and the PC diagnostic tool), so I then manually found and installed the Toshiba System Settings and the Toshiba HWsetup Utility.

Straight after the Windows 10 reinstall, the Fn keys (volume, flight mode etc) worked when I held down the Fn key, which wasn't what I wanted. After installing the Function Key Desktop App every single one of the Fn keys worked without pressing the Fn button, apart from Brightness Up and Brightness Down, which didn't work at all with or without the Fn key. Not only do they not work with the keyboard, I also cannot adjust the brightness any other way.

There are no brightness settings in the control panel power settings, and when I click the battery icon on the taskbar (Windows 10), the brightness option is grayed out! The Windows Mobility Centre brightness control allows me to move the slider but there is no actual change in brightness.

I'm not sure if the brightness settings ever worked after the Windows 10 reinstall, and if they did, I do not know at what point they stopped working. I thought it might be when I installed the AMD driver, but I tried uninstalling it and it didn't help. Neither did reinstalling it.

Why is this happening and how can I fix it?

1

The AMD driver is not responsible for your screen's brightness, Toshiba's software is. The downside is that if the key isn't working, it's likely the software is not compatible with windows 10. You can only hope Toshiba fixes that soon.

However, there is a workaround. In the Cortana search menu, type in Windows Mobility Center. Open that program, and you'll find a brightness control slider in the top left. It may not play nice with Toshiba's software and you'll see an error popup. Just close it. No harm has been done.

Here's a screenshot of the program along with the kind of error popup you might see. Quickset is Dell's keyboard function software and it wasn't particularly happy about something else changing its settings. Screenshot

  • Unfortunately the Windows Mobility Centre brightness slider does nothing. I can move it, and the numbers change, but the actual brightness does not change at all. There is also no error message, or any acknowledgement that it hasn't worked :( My guess is the hardware driver for the back lights are missing. – Blue7 Sep 6 '15 at 11:18
  • 1
    @Blue7, I'd agree. The driver probably doesn't work with Win 10. Sorry, but there isn't much you can do in that case. This kind of issue is why my laptop is still on Win 7. Intel refuses to update their GPU drivers in a timely manner. – Ethan Z Sep 6 '15 at 15:32
  • 1
    If you want to verify it, search for Device Manager and open the Display Adapter and Monitor dropdowns. You might find the error. – Ethan Z Sep 6 '15 at 15:43
  • Brilliant! I opened device manager, and double clicked the Generic PnP Monitor. It said it was disabled, and told me that items are disabled when not working properly or when causing items to conflict. I clicked enable anyway, and now my brightness control is working! Thank you! – Blue7 Sep 6 '15 at 16:59
  • @Blue7, well I didn't expect that to fix the problem, but you're welcome! Feel free to tag me again in the comments here if something goes wrong again. You might find that the next time you restart the computer the driver has been disabled again. – Ethan Z Sep 6 '15 at 18:55
0

In my case the AMD software was indeed the problem. So I rolled back the driver to the previous version. Now the Mobility Center slider actually changes the brightness.

protected by Community Oct 20 '15 at 15:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.