I am unable to add files or folders to the "Quick Access" folder in the File Manager on Windows 10. If I drag files or folders there nothing will happen but if I right click and select "Pin to Quick Access" I will get a non-descriptive popup stating Unspecified Error.

Image showing the error:

http://i.stack.imgur.com/jKTUR.png

  • 1
    This is pretty disappointing from Misrosoft given that windows 10 is pretty good otherwise. Windows 10 is littered with little issues like this. After Numerous updates (and ironically numerous freezes due to updates, another issue) the problems are still there. I wonder what microsoft changes in these cumulative updates because these issues never go away. – Ejaz Jan 19 '16 at 18:28
up vote 25 down vote accepted

To fix this issue go to these two folders:

  • %AppData%\Microsoft\Windows\Recent\AutomaticDestinations
  • %AppData%\Microsoft\Windows\Recent\CustomDestinations

Then delete all the files in those folders. This should fix the issue without any further action.

Source: SinsOfRube on Reddit

  • I posted this issue to give the solution more visibility when searching online. – karl Sep 6 '15 at 10:44
  • 2
    This solved my problem in the short term, hope it sticks! Thanks! – Deep-B Sep 20 '15 at 14:43
  • 1
    Fixed my issue. And brought back four links (desktop, documents, downloads, pictures) that I never knew were missing :D – Ejaz Jan 19 '16 at 18:36
  • 2
    For fixing Quick Access it should be sufficient to delete %appdata%\Microsoft\Windows\Recent\AutomaticDestinations\f01b4d95cf55d32a.automaticDestinations-ms. – Martin Sep 23 '17 at 11:12
  • Hah, in my case these folders were missing, i created them and everything started working again. – BladeMight Oct 8 '17 at 22:39

Turning off the automated features of quick access fixed my problem:

In Windows Explorer, on the tool-ribbon, in the View tab, under options, select "Change Folder and Search Options," In the Folder Options dialog, in the Privacy section at the bottom:

  • uncheck "Show recently used files in Quick access"
  • uncheck "Show frequently used folders in Quick access"

Once I did this, I was able to drag a folder to Quick Access which had only give me the red "forbidden" circle before.

P.S. Even with all the "show" options in the Folder Options View tab turned on and all the "hide" options turned off, I still do not see %appdata%\microsoft\windows\Recent\AutomaticDestinations\ in Windows explorer unless I paste the full path in the explorer address bar. Instead, I see %appdata%\microsoft\windows\Recent Items, which appears to be a "virtual" (fake) file.

protected by magicandre1981 Jan 9 '16 at 6:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.