I am unable to add files or folders to the "Quick Access" folder in the File Manager on Windows 10. If I drag files or folders there nothing will happen but if I right click and select "Pin to Quick Access" I will get a non-descriptive popup stating Unspecified Error.

Image showing the error:


  • 1
    This is pretty disappointing from Misrosoft given that windows 10 is pretty good otherwise. Windows 10 is littered with little issues like this. After Numerous updates (and ironically numerous freezes due to updates, another issue) the problems are still there. I wonder what microsoft changes in these cumulative updates because these issues never go away.
    – Ejaz
    Jan 19, 2016 at 18:28

5 Answers 5


To fix this issue go to these two folders:

  • %AppData%\Microsoft\Windows\Recent\AutomaticDestinations
  • %AppData%\Microsoft\Windows\Recent\CustomDestinations

Then delete all the files in those folders. This should fix the issue without any further action.

Source: SinsOfRube on Reddit

  • I posted this issue to give the solution more visibility when searching online.
    – karl
    Sep 6, 2015 at 10:44
  • 2
    This solved my problem in the short term, hope it sticks! Thanks!
    – Deep-B
    Sep 20, 2015 at 14:43
  • 1
    Fixed my issue. And brought back four links (desktop, documents, downloads, pictures) that I never knew were missing :D
    – Ejaz
    Jan 19, 2016 at 18:36
  • 3
    For fixing Quick Access it should be sufficient to delete %appdata%\Microsoft\Windows\Recent\AutomaticDestinations\f01b4d95cf55d32a.automaticDestinations-ms.
    – Martin
    Sep 23, 2017 at 11:12
  • Hah, in my case these folders were missing, i created them and everything started working again.
    – BladeMight
    Oct 8, 2017 at 22:39

Turning off the automated features of quick access fixed my problem:

In Windows Explorer, on the tool-ribbon, in the View tab, under options, select "Change Folder and Search Options," In the Folder Options dialog, in the Privacy section at the bottom:

  • uncheck "Show recently used files in Quick access"
  • uncheck "Show frequently used folders in Quick access"

Once I did this, I was able to drag a folder to Quick Access which had only give me the red "forbidden" circle before.

P.S. Even with all the "show" options in the Folder Options View tab turned on and all the "hide" options turned off, I still do not see %appdata%\microsoft\windows\Recent\AutomaticDestinations\ in Windows explorer unless I paste the full path in the explorer address bar. Instead, I see %appdata%\microsoft\windows\Recent Items, which appears to be a "virtual" (fake) file.


The culprits are indeed the files inside %AppData%\Microsoft\Windows\Recent\AutomaticDestinations

Unfortunately the files and folders inside Recent are not visible in Windows Explorer (even if you have Show Hidden items checked). So you cannot delete the contents via Windows Explorer.

However, the contents of Recent folder are visible in Windows command prompt. So to delete the contents inside Recent folder, you have to use Windows command instead.

Execute the following command in a Windows command prompt.

del /F /Q %APPDATA%\Microsoft\Windows\Recent\AutomaticDestinations\*

You will see the following folders appear under Quick access. Now you can again use Pin current folder to Quick access option.

Quick access

  • I can confirm this worked on Windows 10 in September 2023. What a weird error! But #GOTCHA: This also deletes ALL the other currently pinned quick access items :( So, perhaps the root issues is that there is a limit on how many quick access items one can have? Instead of saying you hit the limit it gives a nonsense error? Sep 15, 2023 at 0:54

From Martin's comment:

For fixing Quick Access it should be sufficient to delete %appdata%\Microsoft\Windows\Recent\AutomaticDestinations\f01b4d95cf55d32a.automaticDestinations-ms. – Martin Sep 23 '17 at 11:12

For me, this fixed it--but it restored Quick access to a much earlier version. I'm not sure where it rebuilds it from.


[This also fixes to the "Add to Quick Access button permanently greyed out" issue]

As others found out, you have to delete the contents of the following folder:


This is a folder that won't appear in Windows Explorer regardless of whether having enabled the "Show Hidden Items" option, so you have to invoke a Command Prompt to deal with it.

Furthermore, you might find out that deleting the above directory contents does not work. You may see the following error:

The System Cannot Find The Path Specified

or another error similar to that.

Therefore, the step-by-step procedure to restore the functionality without errors is the following:

  1. Open a Command Prompt (may require Administrator privileges).

  2. Copy and paste the following command:

    del /F /Q "%APPDATA%\Microsoft\Windows\Recent\AutomaticDestinations\*"

Notice the double quotes: they are required if your user name contains spaces. Otherwise, you get the "... cannot find the path specified" error. This happens because %APPDATA% would expand to space-separated multiple words and DOS interprets them as separate parameters.

  1. Press ENTER and wait.

After about two seconds you should see Quick access changing, often to completely different items. You'll see the "Freshly installed Windows" items plus others.

In my case, it restored some 5 years old quick access items (!!!). They would overlap and break the ability to add new items. I removed them and then the Quick Access action returned to full functionality.

  • I followed the instruction above. This deleted the file. Wait a few minutes and windows restores it. Unfortunately the restored quick access menu shows very old destinations that are no longer on my computer. I cannot delete these shortcuts and at this point I can no longer add to Quick Access. I have tried editing the files in notepad and deleting all contents. After saving I see the empty file AND two others that are similar. Try again to delete all, wait, and a bad one reappears Any idea where Windows 10 ver 2h22 restores these files from. Mar 5, 2023 at 21:01
  • I went through the registry and deleted all references to name of the old shortcut. Still stays there?? Mar 5, 2023 at 21:32
  • 1
    After several reboots, I was finally able to remove the offending (non existing) shortcuts using right click and unpin option. This option does not always appear in the right click menu for a quick access item. I wait a while or reboot and it seems to magically appear. Thanks to Dario Mar 5, 2023 at 22:00
  • @CharlesBisbee yes, the way the shortcuts system works is ancient, and has been updated multiple times (without bothering about pre-existing setups). Having to wait for minutes and reboot is part of the cryptic formula to make it work again. Mar 6, 2023 at 17:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .