I have a WD My Book (3TB storage, USB 3), and just like many other enthusiast owners of this external drive, I'm trying to get rid of their crapware.

Whenever I plug this device into a computer, there is a virtual CD unit that pops up called "WD Unlocker", and I'm trying to remove it physically, instead of just hiding it (I found many guides on this, and by the way none of them worked).

Steps I followed so far:

  • under OS X, I tried to initialize the physical drive several times with Apple's Disk Utility. I also tried to change from MBR to GUID and vice-versa with no success.
  • with Windows 10, I tried removing all partitions from the physical drive with the built-in Disk Manager and some other tools like EaseUS Partition Master. Obviously none of them worked.
  • frustration began to rise. I started Google-ing like crazy.
  • again, I wasted some time with OS X and some built-in command-line tools (which I guess are just the command-line counterpart of the Disk Utility app).
  • I hugged my cat and cried.
  • with Windows, I launched HP USB Disk Storage Format Tool, as somebody has claimed it to have had success, but I ended up with a "Device media is write-protected" error. I opened Microsoft's System Registry utility to force-allow write on the protected media, and just when I was about to start partying, I realized I failed once again.
  • sacrificed a lamb.
  • I connected that evil drive to my Ubuntu Server 14.04. I tried with both fdisk and parted, but I may have done something wrong.
  • browsed to SuperUser.

One strange thing I noticed is that even when the drive is unmounted, I have the option to mount separately the virtual CD and the drive itself. I have no experience with partitioned external drives, so I know not if this could suggest that they are actually two separate physical units (something "hacked" in the SATA-to-USB controller, maybe?) or it is just me unable to properly erase the hard drive and forget about that damn VCD.

  • 1
    Actually, I reformatted it more than once. I have no concerns about data on the drive, as there are none right now. The point is: for some reason the VCD is reckonized as part of a separate physical drive, hence reformatting and repartitioning just doesn't work. :)
    – fquffio
    Commented Sep 7, 2015 at 7:01
  • Unfortunately is not possible to remove completely the VCD from your external HDD, however you should be able to disable it following the instructions here. Commented Sep 7, 2015 at 14:32
  • 1
    @Techpumpkin_WD : those instructions you linked refer to the "WD SmartWare" VCD. As I stated in the question (but probably I should have pointed it out in a clearer way), I am trying to remove the "WD Unlocker" unit. By the way, the "WD SmartWare" can be fully removed using the HP USB Disk Storage Format Tool, as I was able to do with another WD drive.
    – fquffio
    Commented Sep 7, 2015 at 14:40
  • I'm sorry for the misunderstanding. However both the WD Smartware and WD Unlocker VCDs should be located at the HDD HPA ( Host Protected Area ). If you need to find a way to remove it you should look for a tool that will allow you to clear the HPA. Just keep in mind that modifying the HPA and DCO (Drive configuration overlay) can brick your HDD. And furthermore if you succeed you won't be able to use the password protection for this HDD. Commented Sep 8, 2015 at 13:44
  • 2
    Not to prioritize humor, but let me just mention that, in the annals of computing confusion, this question is brilliant. Commented Dec 6, 2020 at 3:25

13 Answers 13


To uninstall WD Unlocker, you would need to have WD Security installed.

  1. Connect your hard drive that you want to remove WD unlocker from.

  2. Double click on WD security and and a box for ""Edit Security Setting" will pop-up.

  3. There is an option for "Remove Password", if it is not already selected, select it.

  4. Put in your password and click "Update Security Setting."

  5. A box will pop-up that says "Your Password Has Been Removed." And WD Unlocker should be completely removed.

Link to Photo

  • Note that WD Security might not necessarily work with all WD encrypted USB drives. Commented Aug 6, 2019 at 23:44

For Mac OS X:

Removing physically is fairly cumbersome and apparently only doable in Linux. The following script is so fast you never see it appear.

If there were a security module that could refuse mounts based on various criteria, you could presumably hook into that. I don't know enough about that level of Mac OS X innards.

  1. Open Automator
  2. Create a new job based on "Folder Action"
  3. Set Folder Action receive source to "Other..."
  4. In the File Chooser Dialog, press Cmd-Shift-G and type /Volumes/
  5. Choose Actions → Utilities → Run Shell Script in the UI
  6. Enter the code:

if [[ -d "/Volumes/WD Unlocker" ]]; then
  hdiutil unmount -force "/Volumes/WD Unlocker"

as the script

  1. Save the script

  2. Tolerate the toothy gap: Icon Be Gone

Successful completion


Enter the wrong password five times - the option to erase drive will pop-up - all WD software will be removed and will not bother you again. It will erase the disk - so back-up its contents first ....

  • This is correct, but the erasure only applies to the partition that was encrypted. So the hard drive itself will end up still having one large, empty partition, and one small partition that contains the WD Unlocker app, as before. So this really only resets the drive back to how it was when you purchased it - it does not allow you to remove the WD Unlocker partition. Tested on Mac 10.14.6 Mojave with Western Digital My Passport for Mac 1TB drive. Commented Aug 6, 2019 at 23:27

Rightly or wrongly, I blindly trusted a random blog I had read which directed me to a utility available online: http://files.extremeoverclocking.com/file.php?f=197

I ran the executable called HPUSBFW.EXE, and targeted my mounted and unlocked WD drive location.
When it completed, I ejected my WD device and plugged in again. Only 50% of the available volume seemed to be present, but it was unlocked.

After this point I was able to use Windows Disk Management tools to resize my partition.


I've updated to latest firmware and WD Unlocker was gone


  • Didn't work for me. I updated my My Passport for Mac 1TB USB drive to the latest firmware and WD Unlocker is still there. Commented Aug 6, 2019 at 23:42

As pointed out in this reddit post, the Western Digital My Passport drives contain firmware that prevents you from ever erasing or rewriting the VCD partition that contains the WD Unlocker app. As pointed out here, you might be able to use the WD Smartware tool to hide the WD Unlocker from poping up in your OS when you plug in the drive, but you can not remove it.


I had a win10 PC, but my WD-passport was a 5 years old version, I run the default WD security, it could not find any drive! I check my version then realized my version support up to win 7. So I did the following...

Go to WD website download the latest WD security app (updated to support WIN10), unzip and install it, restart PC, run as administrator, choose remove passwords(click password hint to remind me the password), enter the password, click proceed at the bottom of the screen. (I had both WD-HDD connected and unlocked at all time)

That's it.

  1. take the drive to another PC, the unlocker icon is gone!
  2. plug back to original PC, restart, unlocker icon is gone!

It worked in my case, I hope these info help.



Install WD Drive Utilities (available for Windows / Mac) to wipe out WD Unlocker included All Data for My Passport Ultra.

Please backup My Passport Ultra data if necessary before formatting the drive.

Refer download link https://support.wdc.com/downloads.aspx?p=172

Download WD Drove Utilities and install the application Plug in the USB drive Run WD Drive Utilities and select "Drive Erase" Select NTFS / exFat format Checked the box, "I understand, ..." Click Erase Drive and that's all

Hope this helps!

  • Sorry, but this just formats the drive, without removing the system partition that is recognized as a virtual CD. Your answer does format the drive but does not solve the problem entirely.
    – fquffio
    Commented Jun 21, 2021 at 10:50

For Windows 10 use DISKPART and clean the disk. Done


I had multiple WD drives with the same issue.

  • DISKPART - Fails
  • Windows 10 Disk utilities - Fails
  • Update Firmware - Unavailable


  • Install WD Security for Windows. https://support.wdc.com/downloads.aspx?lang=en#downloads
  • Use the 'Remove Password' option within the utility
  • Removed drive safely from Windows. Reconnected Drive.
  • Single drive now visible in windows without Unlocker partition.
  • Even the stored data was available on the drive. Although I wouldn't recommend relying on that for essential data.

I did have the password for the drive so not sure of operation if that is unknown or forgotten.

This applied to several older WD drives

  • WDBAAE5000ASL-00 WD My Passport Studio
  • WDBACX0010BBK-00 WD My Passport Essentials
  • WDBACX0010BBK-00 WD My Passport Essentials

I had the same problem.

What I did was to disable the WD Virtual CD Drive that has the WD Unlocker. Just right hand click on the WD Virtual CD Drive in windows explorer, click on Properties, go to Hardware, click on the WD Virtual CD Drive and Disable Device.

Now only the full drive appears and no more WD Unlocker!!!

Hope that helps


The VCD is built into the SATA to USB adapter and is a physical chip on the PCB...doing anything in software will not delete the partition as that's how the controller was designed. If you removed the HD from the enclosure and connected it directly to your motherboard


This is on MacOS 14.6 Mojave, with a 4TB MyPassport bought in may 2020. As reported by Alex, I can't remember the WD Unlock partition showing up "out of the box": I started by using the drive after reformating it to HFS+ with Drive utility, and there was a single partition there, nothing fishy.

It is only after giving the WD utilities a try, and setting up a password, that the WD Unlocker icon started showing up. It turned out that the password-protected drive doesn't wake correctly from sleep and couldn't be accessed through the LAN, so I wanted to remove the password. The software is buggy but I finally managed, and also removed all WD software. The WD Unlock partition however remained there, and remounted immediately each time I Ejected (cmd-E) or dragged it to the garbage.

However, through Disk Utility, when you Eject the WD Unlocker volume (not the WD Virtual CD device), it disappears - until the next system reboot. I can live with that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .