PC: Lenovo Yoga Pro 3 (1370) OS: Windows 10 Pro, clean install

When configured to use Icelandic keyboard, the key combination to make a @ (at-sign) is normally altgr+q. After installing Windows 10, that has stopped working.

enter image description here


  • It worked in Windows 8 on the same PC
  • There are no driverless devices in the device manager in Windows
  • No specific keyboard driver exists from Lenovo (as far as I can tell)
  • If I enable the onscreen keyboard and press alt, the @ sign is visible on the Q key, and if I press that, it works

How can I fix this and get the altgr-q combo at-sign to work again?

If everything else fails, I can create an autohotkey script, but I was really hoping to properly fix this.


It seems like the upgrade to Windows 10 kept the Windows 8/8.1 Synaptic driver instead of replacing it with a newer version, this causing a problem with the AltGr key.

To force the newer version to be installed, find in Device manager the Synaptic device, then delete it and reboot.

The AltGr key should now work correctly.

(Old more complexe answer)

In the thread Windows 10 TP - AltGr Key has lost functionality these solutions were offered :

The pointing device driver seemed to be the problem in Lenovo Yoga 3 Pro as well. I did a rollback of the pointing device driver from Device Manager - now it uses the "Lenovo Pointing Device" driver from 2014 instead of the latest one installed by Windows 10 and AltGR is back!

A later remark says (I suppose that "windows control panel" refers to the Device Manager) :

It worked for me : I uninstalled the Synaptic driver from the windows control panel and restarted.

Alt Gr was back but gestures didn't work anymore on the trackpad.

I downloaded the driver again from Sony's support website (here) and reinstalled it.

I cannot test this, but it wouldn't surprise me if all you have to do is install the above driver and reboot.

I you wish to block future updates by Windows 10 to this device, see this other answer of mine. Another remark was :

Ctrl-Alt doesn't work either, but Ctrl-AltGr does. Looks like a bad mapping in the driver...

  • Confirmed working, by simply uninstalling the synaptics drivers (two) and reboot. Presto, everything worked again. It was my wife's pc, so you most likely saved my life. :D – Kjensen Sep 9 '15 at 21:14
  • 1
    You life or your marriage? Anyway, the conclusion is that the upgrade to Win10 kept the Win8 Synaptic driver instead of replacing it with a newer version. This method forces that version to be installed. – harrymc Sep 11 '15 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.