I'm attempting to array data using the frequency function in excel. When I select my data and bin, hit control enter, I get only the answer of the first cell. When I attempt to drag the t cursor down to put the formula in the other cells, I get incorrect numbers. I heard something about F2 working but I can't quite figure it out. Help!

  • 3
    Post a small dataset together with the results of the formula and, importantly, what you think the results should be. Note that this example does not have to be your actual data; a small, mocked-up one will suffice. – XOR LX Sep 7 '15 at 6:38
  • 1
    Did you figure out the key command to populate an set of cells, instead of a single cell? the [cmd]+[enter] keyboard command seems to be broken when updating to 2016 – Michael Jasper Mar 18 '16 at 22:16

I, too, experienced this on my iMac. Only the first cell would populate, and no manner of dragging and dropping would fix it. I thought MS had shafted us Mac users once again, but then I found the answer somewhere, and it is basically this:

If your Mac keyboard has an "Fn" key in the extreme left lower corner, then open Keyboard Preferences and select the following:

"Use all F1, F2, etc. keys as standard function keys."

This essentially disables the special Mac functions depicted on the various Function keys. However, this action makes it possible to use the (standard) F2 function key needed for the FREQUENCY command.

(Note: When this option is selected and you do want to use the special features printed on each key, then you'll need to press the Fn key along with the desired Function key.)

Hope this makes sense.

Note: this does not appear to be necessary with the older Magic keyboards with the numeric keypad. In fact. the above-referenced option in Keyboard Preferences does not exist when using the older keyboard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.