0

After replacing Eclipse Luna with Eclipse Mars, the Run command (top bar button or CTRL+F11) does not execute a classes' main function or JUnit test anymore. Instead, the "Run configuration" menu is shown where it has to be configured manually. After a "restore defaults" in Window->Preferences->General->Keys, the last ran configuration is always executed, even if the active Tab contains a main class or a JUnit test case.

How can I restore the expected "Run" behaviour?

P.S.: Problem persists after upgrading from Eclipse 4.5.0 to 4.5.1.

1

You don't have a language perspective selected. In order to get your applet to run, you want to scroll over to the top corner and select or whatever else you're using. This will select the default language Eclipse must assume you are writing in, and you can press CTRL + F11 again.

  • I already have the Java perspective opened. – Konrad Höffner Oct 20 '15 at 11:33
  • If you have the <Java> perspective selected, the run button should be appearing. I know this because I had the same exact issue a couple of days ago, hence how I found this post. – Oleg Silkin Oct 23 '15 at 16:38
  • It could very well be possible that you don't have a JDK installed or that Java simply doesn't know where it exists. – Oleg Silkin Oct 23 '15 at 16:40
0

Open Window->Preferences->General->Keys, search for "Run Java Application" and associate it with Ctrl+F11. However now I cannot run JUnit test cases anymore.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.