I have upgraded to Windows 10 from Windows 7 Pro.

I cannot seem to find OneDrive anywhere and I cannot install it either. When I try to download and install it, it says I have the most up-to-date version installed.

How do I get OneDrive up and running?

  • Does anything appear in Programs and Features in Control Panel?
    – Kinnectus
    Sep 7, 2015 at 13:34
  • nothing appears. i done an upgrade reset install.
    – shorif2000
    Sep 7, 2015 at 13:47
  • 1
    It should be at All app (start menu) if not listed, click Cortana search bar and type "onedrive", it should be at the top Best match, if cannot find also, open task manager, click startup tab, it should be listed there, if cannot find also, search it at Windows Explorer, navigate to C:\Windows\System32 folder for 32 bit, or C:\Windows\SysWOW64 for 64 bit, then run OneDriveSetup.exe.
    – Jusup
    Sep 7, 2015 at 15:39
  • it says a new version is installed and current one needs to be uninstalled.
    – shorif2000
    Sep 7, 2015 at 15:47

11 Answers 11


I had a similar problem and tried all the suggested answers here without luck. What worked for me was the following :

execute %localappdata%\Microsoft\OneDrive\Update\OneDriveSetup.exe

It will ask you to sign in with your Microsoft account. After that it will start the sync process and the tray icon will be available again.


I recently shifted to Windows 10.

After a while OneDrive was gone. I mean gone, not in Control Panel > Installed Programs, not in features, not running, not in Task Manager, etc.

From what I could understand OneDrive comes shipped OOTB with Windows 10 so you're not supposed to even have to install it in the first place.

The main behaviour was that, whatever I did (install onedrive, run it, reset it) I would always get a brief window that eventually closed and nothing else happened.

Online I've found two recommendations:

Reset OneDrive:

%localappdata%\Microsoft\OneDrive\onedrive.exe /reset

Run OneDrive:


Sadly, none of that worked so I tried:

gpedit.msc > Computer Configuration > Administrative Templates > Windows Components > OneDrive > "Prevent the usage of OneDrive for file storage" > Disabled

That also failed, so in the end what worked was deleting a registry setting:

regedit > localmachine > software > policies > Microsoft > Windows > OneDrive > DisableFileSync

or alternatively, save and run the below in a .reg file:

Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\OneDrive] "DisableFileSyncNGSC"=-

run onedrive from local data and now it will open!


  • 1
    DisableFileSyncNGSC registry did it for me. Made a copy of my previous onedrive folder locally, just in case, deleted the original one, launched onedrive.exe. Started, answered the questions and it worked!
    – ixe013
    Feb 19, 2017 at 18:50
  • i had disabled onedrive before reinstalling didnt help , changing the value of disablefilesync to 0 , helped thanks , thumbs up from me.
    – Zany
    Jun 28, 2017 at 11:21
  • Changing gpedit.msc > Computer Configuration > Administrative Templates > Windows Components > OneDrive > "Prevent the usage of OneDrive for file storage" > Disabled (it was previously set to Enabled) and then launching OneDrive.exe worked for me. Thanks!
    – deadlydog
    Nov 27, 2017 at 22:15
  • The GPO fix did not work for me, but the registry fix did
    – David
    May 4, 2021 at 18:30

After having this same issue on a laptop & desktop after windows 10 upgrade I tried all of the things I read on the various forums. Ultimately for me the answer turned out to be very simple. I accessed the Onedrive account online. Then I removed all the connected devices. When I started Onedrive on the affected computers, it said it was no longer connected and asked for the username and password to reconnect. I entered it and it is back to normal. Did the same on the other PC and it worked as well. I believe the issue is somehow related to not recognizing the connected devices after the Win 10 upgrade. Anyway it worked for me, I hope it will help others.

  • 1
    the problem i have, onedrive is not available anywhere on the pc, no folders or no settings
    – shorif2000
    Sep 9, 2015 at 17:09

Worked well with Windows 10: If the OneDrive system tray icon does not re-appear after a few minutes, do the following. In the run window enter:


After resetting Onedrive , please right click on Onedrive icon from the system tray or from the right bottom of the screen and then click on setting. You can click on Choose folders from where you can check option of the folders which you want to sync with Onedrive applications.


Whilst the above responses may have been helpful in other situations they were not for me (as with many other "solutions" proffered elsewhere). So I took another route. Look at how OneDrive may have been disabled. The following post was my saviour (https://techjourney.net/disable-or-uninstall-onedrive-completely-in-windows-10/). I simply reversed the process (ie. "disabled" Prevent the Usage...) and back came my Onedrive. Simple as that! Hope that helps others who may have been as exasperated as I was. Cheers, David

  • 1
    Please include the relevant parts of the article in your answer in case the link breaks.
    – Ben N
    Mar 24, 2016 at 19:41
  1. Click Start
  2. Type "Add or Remove Programs" and open it
  3. Find OneDrive in that list
  4. Click uninstall
  5. Reinstall OneDrive
  • one drive is not on the list
    – shorif2000
    Sep 7, 2015 at 13:47
  • In which case have a look here: techjourney.net/…
    – Jay
    Sep 7, 2015 at 13:48
  • tried it, still does not let me install
    – shorif2000
    Sep 7, 2015 at 14:56

Try this:

  1. "WindowsKey + R"
  2. Write "taskmgr" and click Run.
  3. Go to Startup tab and check if OneDrive is disabled.

If disabled, right click and Enable.


Follow these steps:

  1. Open %localappdata% (C:\Users\<username>\AppData\Local) then go to Microsoft\OneDrive\Update
  2. Execute OneDriveSetup.exe
  3. Wait until the installer successfully installs OneDrive. If you ever used OneDrive on your computer, it will log in, appear in system tray and start syncing automatically.

Try resetting the OneDrive application. Here's how:

  1. Press Win+R to open the 'Run' window.
  2. In the Run window enter the following: %localappdata%\Microsoft\OneDrive\onedrive.exe /reset
  3. Click OK. The OneDrive system tray icon on the desktop should disappear and re-appear after a minute or two.
  4. If the OneDrive system tray icon does not re-appear after a few minutes, enter the following in the Run window: %localappdata%\Microsoft\OneDrive\onedrive.exe

After resetting OneDrive, right click on the OneDrive icon in the system tray or at the right bottom corner of the screen and select "Settings".

Then click "Choose folders" and you can check which folders you want to sync with OneDrive.

  • I have tried this and nothing happens
    – shorif2000
    Sep 13, 2015 at 20:56

What seems to happen for me is that, after a Windows 10 update, the OneDrive.exe file is removed from the c:\users\myusername\appdata\local\microsoft\onedrive folder (obviously myusername is whatever your own username is).

In that folder there are sub-folders with wonderful names such as 18.111.0603.0006. If you look in the latest one of these (it has the highest number) you will find onedrive.exe.

If you copy this into the c:\users\myusername\appdata\local\microsoft\onedrive folder you can restart OneDrive from the Start menu and all is OK. No resyncing of all your files is needed. Quick and easy. Works every time for me.


onedrive.exe did not exists in AppData. This worked:

Press the Windows + X key combinations to open the Quick Access menu. Select Command Prompt (Admin). To install the OneDrive in Windows 10 64-bit, issue the following commands:


Upon completing the installation, restart the computer and you can then use OneDrive again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .