11

I tried to find an answer to this a few years ago, but it seemed it wasn't possible then (I suspect it isn't now either! - but what the hell!)

I have a three monitor system, that I mostly use for remote desktop. However occasionally it would be useful to have remote desktop on two monitors and use the other monitor for the local machine.

I know it is possible to have a single monitor full screen, or to stretch an RDP session across monitors, but this loses things like snapping etc.

P.S. this is a duplicate of this thread, but that was a couple of years ago, I'm hoping things have changed.

6

The situation hasn't changed. Your only two choices when using multiple monitors through an RDP session are the /span and /multimon options.

/multimon will treat each screen as a separate display just like you would have on the host. You get snapping/clipping capabilities, but the downside is you can only use ALL of the screens for this.

/span allows you to use only two of your three screens, but the downside is that it's one big rectangle that spans across more than 1 screen. You lose each screen's identity as a separate, distinct display.

You can modify the local group policy on the target computer to specify a maximum of 2 displays for use with the /multimon switch. I don't know what that would look like on a 3-screen display however. I suspect the 3rd screen would just go black. You'd have to play with this yourself.

You can get to the local group policy by hitting Start -> Run and typing gpedit.msc. The setting you're looking for is Computer Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment. Set Limit Maximum Number of Monitors to enabled and specify 2.

NOTE You do this on the host computer (the one you're connecting to), not the client.

| improve this answer | |
  • 2
    I had a little moment of excitement as I wondered if they'd fixed the Maximum limit policy on Windows 10 (I'm connecting to a WIn10 desktop), but alas if you set that to anything it still limits it to a single screen – Michael B Sep 8 '15 at 2:11
  • 1
    I'm sure it's probably very low on Microsoft's priorities list. The reason /multimon requires all your screens is because your local computer's window manager is in charge of rendering GUI elements on the remote host. It lowers overhead because the host does not have to send pixels over the wire for drawing things like title bars and buttons. It just sends the raw GDI info and your computer renders it. That probably makes what you want harder for Microsoft to implement. – Wes Sayeed Sep 8 '15 at 2:18
  • Its clearly very low on their priority list ;) I was thinking it might have been something somebody had tweaked for Win10 (I live in hope!) – Michael B Sep 8 '15 at 2:25
  • @WesSayeed How does one go about using /span mode? When I try it, I'm restricted to a single monitor, even if my width is correct for 2 (I just get a scrollbar at the bottom, the window refuses to cross monitor boundaries during resize). – Brian Knoblauch May 4 '18 at 17:03
4

You can:

  • Save a .rdp conection file and check "Use multimonitor"
  • Execute mstc /l (list monitors, and show ID monitor)
  • Edit .rdp file in notepad
  • Change o add selectedmonitors:s:1,2 after use multimon:i:1

In selectedmonitors you can select yours monitors, listed with mstc. In my sample use 1,2 but you can use othes.

More info: https://www.hanselman.com/blog/HowToRemoteDesktopFullscreenRDPWithJustSOMEOfYourMultipleMonitors.aspx

| improve this answer | |
  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Apr 3 at 11:33
  • What? In question said that is a duplicate. My answer is correct. I have 3 monitors and I use 2 with RDP. – Victor Sanchez Apr 3 at 11:59
  • In the other answer you failed to notice that the OP was using Windows 7 Pro which does not support multiple monitors in RDP. So your answer is useless. – DavidPostill Apr 3 at 12:24
  • This question is Windows10. Not Windows 7. See tag. Please read a little. The one who has difficulties with English is me. – Victor Sanchez Apr 6 at 11:31
  • 2
    @abjbhat Thank you. I changed the wording a bit to make it clearer. I already wrote a lot of comments about this, but for now you are the first to help me explain it better ... despite my English. – Victor Sanchez Apr 24 at 12:49
0

As stated in the linked question, I have been using Vmware workstation to full screen on a subset of my monitors, running a stripped down version of Windows 7, it seems to be working well so far and I'll likely retain this as a solution (at least as something to use when I need to have that separation.)

It does get a little sluggish at times, but for the most part there is no difference in performance (I am primarily using office apps etc)

| improve this answer | |
0

I know that this question is a very old one, but i've had this problem currently with thw windows 10 and found one answer that works like magic for me:

https://www.hanselman.com/blog/how-to-remote-desktop-fullscreen-rdp-with-just-some-of-your-multiple-monitors

| improve this answer | |
  • Welcome to Super User! Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Oct 16 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.