15

I have upgraded to Windows 10 on a PC at home. But now whenever I RDP to it, and press Disconnect, instead it logs off. So when I connect again it logs in again, and all of the applications that I had open are closed.

I have already checked the settings in the Registry, and the timeout is Never.

In Windows 7, this didn't happen, and I could disconnect and remain logged in.

Can anyone help please?

  • What happens when you're logged in using RDP and you login from the computer as a local user? Your RDP session should obviously disconnect, but do the open applications remain open? – Chirag Bhatia - chirag64 Oct 22 '15 at 12:15
4
+50

I have tried closing RDP on Windows 10 virtual machine, and I cannot duplicate your problem.

Perhaps the difference is that I have applied this registry fix because I was getting the message of "the connection cannot proceed because authentication is not enabled" :

In Windows 10 Microsoft changed RDP’s defaults. They modified the default for SecurityLayer from 0 to 2. Even if you go into the user interface and disable: “Allow connections only from computers running Remote Desktop with Network Level Authentication (recommended)” Still doesn’t change that value to a 2.

Simple fix:

  • Open RegEdit
  • Navigate to this Key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp
  • Change SecurityLayer to a zero
  • Reboot and done
  • This issue I also experience in Windows 10. I think it is a Win 10 bug. – Shiro Oct 25 '15 at 14:57
  • @Shiro: Sorry, I meant Windows 10 - fixed above. I cannot think of any other difference between your case and mine, except for differing hardware & drivers. – harrymc Oct 25 '15 at 15:00
  • After I applied your registry edit. I seem like remain my previous session. Thank you very much! – Shiro Oct 26 '15 at 3:17
  • This question is not belong to mine :) I just start a bounty because I have same problem. Thank you so much~ – Shiro Oct 26 '15 at 13:58
3

Disable the "Session Time Limits" policies on the Windows 10 PC at home.

  1. Open gpedit.msc
  2. Navigate to:
    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits
  3. Disable any active policies.
  4. Navigate to:
    User Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits
  5. Disable any active policies.
  6. Reboot the computer.
1

Instead of disconnecting, just close the RDP application. This will keep you logged in on the remote computer.

Also, you'll noticed that reboot and shutdown are not part of you options. This you'll have to handle with the shutdown command.

0

Methinks this is a Windows 10 issue or perhaps Microsoft would call it a fix as it prevents dead sessions and potentially stopping other users logging in by running out of TS licenses.

0

You can try the latest Remote desktop client here : https://support.microsoft.com/en-us/kb/2923545 if you are on insider preview and installed last update, uninstall last update, I had a lot of trouble IMHO. If not check windows has the latest patchs.

  • That download is specifically for Windows 7. – Ramhound Oct 22 '15 at 16:38
  • we don't know the client OS version. – Deltaforest Oct 23 '15 at 7:34
  • So ask before answering – Ramhound Oct 23 '15 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.