In a nutshell, my Windows 7 Ultimate PC intermittently drops its Internet connection. Why?

Background: My PC is wired to my ADSL modem/router which is directly connected to the phone line. I also have wireless connectivity turned on within the router for a laptop to connect wirelessly.

Every few hours or so, when using my PC, I find I cannot access the Internet and pages will not load. Eventually, Windows 7 will update the network icon in the task-tray to show the exclamation mark symbol on the network icon. Opening up the Network And Sharing Centre will show the red cross between the "Multiple Networks" and "The Internet".

Here's a picture of the "Network And Sharing Centre" (grabbed when everything was working!)

alt text

As you can see, I'm running Sun's VirtualBox on this machine and that creates a network connection for itself. This doesn't seem to affect the intermittent dropping (i.e. the intermittent drops occur whether the VirtualBox connection is in use or not).

When the connection does drop, I cannot access any Internet pages, nor can I access the router's web admin page at, so I'm assuming I've lost all local LAN access too.

It's definitely not the router (or the Internet connection itself) as my laptop, using the wireless connection (and running Vista Home Premium) continues to be able to access the internet (and the router's web administration pages) just fine.

Every time this happens, I can immediately restore all Internet and LAN access by opening the Network Adapter page, disabling the "Local Area Connection" and then re-enabling it. Give it a few seconds and everything is fine again. I assume this is because, beneath the GUI, it's effectively doing an "ipconfig /release" then "ipconfig /renew".

Why does this happen in the first place, though? I've googled for this and seen quite a few other people (even on MSDN/Technet forums) experiencing the same or almost the same problem, but with no clear resolution. Suggestions of turning off IPv6 on the LAN adapter, and ensuring there's no power management "sleeping" the network adapter have been tried but do not cure the problem. There does not seem to be any particular sequence of events that cause it to happen either. I've had it go twice in 20 minutes when just randomly browsing the web with no other traffic, and I've also had it go once then not go again for 2-3 hours with the same sort of usage.

Why is this happening and how to make it stop?


Additional information based upon the answer provided so far:

Firstly, I forgot the mention that this is Windows 7 64 bit if that makes any difference at all.

I mentioned that I don't think the VirtualBox network adpater is causing this problem in any way, and I also have VirtualBox installed on two other machines, one running Windows Vista Home Premium and the other running Windows XP. Neither of these machine experience the same network connectivity issues as the Windows 7 machine.

The IP assignment for the Windows 7 machine is the same both before and after the "drop". I have a DHCP server on the router issuing IP Addresses, however my Windows 7 machine uses a static address. Here's the output from "ipconfig":

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :  
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller  
   DHCP Enabled. . . . . . . . . . . : No  
   Autoconfiguration Enabled . . . . : Yes  
   IPv4 Address. . . . . . . . . . . :  
   Subnet Mask . . . . . . . . . . . :  
   Default Gateway . . . . . . . . . :  
   DNS Servers . . . . . . . . . . . :  
   NetBIOS over Tcpip. . . . . . . . : Enabled  

Within the system's event logs, the only event that relates to the connection dropping is a "DNS Client Event" and this is generated after the connection has dropped and is an event detailing that DNS information can't be found for whatever website I may be trying to access, just as the connection drops:

Log Name:      System
Source:        Microsoft-Windows-DNS-Client
Event ID:      1014
Task Category: None
Level:         Warning
User:          NETWORK SERVICE
Name resolution for the name weather.service.msn.com timed out after none of the configured DNS servers responded.

The network adapter chipset is Realtek PCIe GBE Family Controller and I have confirmed that this is the correct chipset for the motherboard (Asus M4A77TD PRO), and in fact, Windows Update installed an updated driver for this on 12/Jan/2009. The details of the update say that it's a Realtek software update from December 2009. Incidentally, I was still having the same intermittent problems prior to this update. It seems to have made no difference at all.

EDIT 2 (1 Feb 2010):

In my quest to solve this problem, I have discovered some more interesting information.

On another forum, someone suggested that I should try running Windows in "Safe Mode With Networking" and see if the problem continues to occur. This was a fantastic suggestion and I don't know why I didn't think of it sooner myself. So, I proceeded to run in Safe Mode with Networking for a number of hours, and amazingly, the "drops" didn't occur once. It was a positive discovery, however, due to the intermittent nature of the original problem, I wasn't completely convinced that the problem was cured.

One thing I did note is that the fan on my GFX card was running a lot louder than normal. This is due to the fact that I have an ASUS ENGTS250 graphics card (http://www.asus.com/product.aspx?P_ID=B6imcoax3MRY42f3) which had a known problem with a noisy fan until a BIOS update fixed the issue. (See the "Manufacturer Response" here: http://www.newegg.com/Product/Product.aspx?Item=N82E16814121334 for details).

Well, running in safe mode had the fan running (incorrectly) at full speed (as it did before the BIOS update), but with an (apparently) stable network connection. Obviously some driver was not loaded for the GFX card when in Safe Mode so this got me thinking about the GFX card (since the very noisy fan was quite obvious when running in Safe Mode).

I rebooted into normal mode, and found that Nvidia had a very up-to-date new driver for my GFX card (only about 1 week old), so I downloaded the appropriate driver and installed it. After installation and a reboot, I was able to use my PC for an entire day with NO NETWORK DROPS!!! This was on Saturday. However, on the Sunday, I also had my PC for pretty much the entire day and experienced 2 network drops. No other changes have been made to my PC in this time.

So, the story seems to be that updating my graphics card drivers seems to have improved (if not completely fixed) the issue, however, I'm still searching for a proper fix for this problem. Hopefully, this information may help anyone who may have additional ideas as to why this problem is occuring in the first place. (And why does new GFX card drivers have anything to do with the network?)

I appreciate everyone's feedback so far. However, I'll have to ask once more for any further ideas of how to fix this particular problem?

  • This is happening to me too. It looks like the driver stops working after some time... I just reboot the machine when this happens for now. Wonder what the cause of this is and if it's fixable.
    – Zoran
    Jan 17 '10 at 23:15
  • @Zoran - Try stopping and restarting the LAN Adapter via the Network And Sharing Centre (as detailed in my question post). Hopefully, it'll make your LAN/internet connection work again without having to go through a complete reboot cycle. I'd be very interested to know if the LAN stopping/restarting works for you, too since you appear to be having an identical problem to me.
    – CraigTP
    Jan 24 '10 at 9:38
  • Unfortunately, in my case, it doesn't help. The only thing that restores it is reboot so far...
    – Zoran
    Jan 25 '10 at 4:36

13 Answers 13



I feel incredibly embarrassed to admit this, but I finally found the solution to my problem and, for me and my problem at least, it was a very easy fix.

In a nutshell, it was a dodgy network cable between my PC and my router. Although brand new, the cable was obviously intermittently defective, and replacing the cable (ironically, with my older, more battered and twisted but perfectly functioning network cable), my LAN has worked perfectly ever since without a single "drop". (And this is over the course of 4-5 weeks of "testing" to ensure that the intermittent problem had really disappeared).

What is interesting, and what completely threw me off the "scent" of looking at the physical hardware was how the problem manifests itself in Windows 7.

Basically, there must have been a slightly loose connection or wire in the LAN cable. When this would "break", Windows would show a broken LAN icon in the task tray area. This would remain broken until I manually went into the LAN Adapter properties, disabled the LAN, then re-enabled it. It was this software-driven temporary "fix" that lead me to believe that the fault itself was entirely software (ie. Operating System) based, rather than physical. Every time the LAN icon would show as "broken", I could "fix" the issue with this disable/re-enable series of steps. Every time!

After exhausting all the software avenues, I started on the hardware. I changed my router for a different one at first and that didn't "solve" the problem. Then I tried the LAN cable. Bingo!

Of course, due to the intermittent nature of the problem, every time I'd try something new, I'd have to "run with it" for a number of weeks to ensure that the problem had gone away (or not, in most cases) since even when the problem was there, I'd been able to go for 5-7 days without a single LAN "break" prior to the issue rearing it's ugly head again. This explains why I'm answering my own question 4 months later! :)

I've now been running with my new (old) LAN cable for 4-5 weeks, and in that time the network connection has not dropped once. I therefore believe I've fixed my problem.

I'm sharing my solution here in the hope that anyone else suffering from the same symptoms can try changing the LAN cable first (despite the symptoms looking very much like a software problem!) :)

I'd also like to thank everyone that responded with various suggestions! Thanks!

  • 4
    Back when I had my windows networking troubleshooting training (mid '90s) they said that 90% of networking problems are cable related. Jun 1 '11 at 14:49
  • Damn, after month of first experiencing this problem, and several attempts at solving it, still nothing. I have the exact same issue as you, and no, Jim, changing cables didn't help. The last resort is to gather all my patience, turn to Microsoft support and pray... :(
    – mnn
    Jan 12 '13 at 23:50
  • I seem to have just experienced the exact same problem and swapping the cable seems to have done the trick. In my case the issue also showed on the Ethernet card of the PC where the network speed indicator lights would start out green, indicating a high speed connection (100/1000 Mbit/s) but randomly drop to orange (10/100 Mbit/s) and lose connection. Apparently, in most cases this is simply a symptom of a shoddy cable that can't sustain a signal properly. In rare cases this can also be a conflict with the automatic network speed detection.
    – Lilienthal
    Nov 3 '16 at 17:01

Some things to try:

  1. In a command prompt (runned as administrator):

    netsh int ip reset intipreset.log
    Reset the TCP/IP stack = reset/rewrite the following TCP/IP-related registry keys:

    * SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\
    * SYSTEM\CurrentControlSet\Services\DHCP\Parameters\

    (you may need to re-configure your TCP/IP settings after that)

    netsh winsock reset
    Repair winsock It removes all Winsock LSP (Layered Service Providers) previously installed, including the potential malfunctioned LSP that causes loss of network packets transmission failure. So all previously-installed LSPs (antivirus/firewall) may need to be reinstalled

    netsh interface reset all
    Reset all interfaces: 6to4, HTTPSTunnel, ipv4, ipv6, isatap, portproxy, tcp, teredo
    But I don't know exactly what you risk to do it (not much I think, except reinstalling/reconfiguring network related software & windows parameters...)

  2. Uninstall your actual driver and install the one from asus: Realtek RTL8111C LAN Driver V7.3.522.2009 for Windows Win7 32bit/64bit

  3. Uninstall the asus driver and install the one from realtek: 7.011

  4. Find all .inf files in c:\windows\inf containing references to realtek lan drivers and move them all in another directory, except one. Remove your network card in the device manager and reboot. The one you left should be reinstalled. Test... If the issue is not resolved try another .inf file.

  • @fluxtendu - Points 2 & 3 have been tried with no real difference (I'm currently running the RealTek drivers as they have a more recent date on them). Points 1 & 4 have not been tried yet, and sound quite interesting. I shall attempt these and see how that goes. Thanks for your input.
    – CraigTP
    Feb 21 '10 at 11:15

Unbelievably, my drops from my Lenovo ThinkPad Y460 were almost entirely from the laptop going to my wireless box and that was the only computer running Windows 7.

My router is connected to a wireless bridge, which works flawlessly.

I shut down the Windows firewall, installed ZoneAlarm and the problems are gone.

Get rid of the Windows Firewall and use something like the free ZoneAlarm.


I had the same issue for a while. In my case it was due to problems with sleep/hibernate. I resolved it by disabling power off for the network adapter during sleep.

Go to device manager, find the NIC and view Power Management under properties. There's a check box that says "allow the computer to turn off this device to save power". Disabling that solved my problem.

  • @Brian - That was one of the first things I tried, and unfortunately, it didn't make any difference.
    – CraigTP
    Feb 1 '10 at 9:54
  • Okay, sorry I couldn't help. Feb 1 '10 at 10:52
  • 1
    No need to be sorry. I appreciate you taking the time to post, so thanks!
    – CraigTP
    Feb 1 '10 at 11:32

Set your IP to be static. This worked for me.

I also had this problem on a Windows 7 computer which had been operating fine for months. I followed many of the solutions on this page but none seemed to correct the problem.


I worked on this type of problem myself and found it was a conflict with IPv6 and the router.

Essentially, disabling IPV6 on all Windows 7 and Vista machines resolved the problem for the entire network. I wrote more details on this in a blog.

  • I can confirm this worked for my horrible Dell Vostro's Realtek PCIe GBE Family Controller and a fresh Windows 7 install on to a new SSD Feb 7 '14 at 15:10

The same is for me (Windows 7 Ultimate 32Bit + VMWare + Intel 1000/PM adapter).

I believe the problem is in power management – I've disallowed to "Turn off device to save power", and updated the driver from Microsoft to Intel.

It solved the problem.

  • 1
    This fixed it for me too - the powr management part, not the driver part
    – Rob Cowell
    Feb 19 '10 at 15:33
  • @Andy - This was one of the first things I tried, however, it made no difference for me.
    – CraigTP
    Feb 21 '10 at 11:10

I had this issue on new Dell laptops with Windows 7, the post by Brian Rasmussen clued me in, I removed the Dell Control Point and security software suites. This seems to have resolved the issue of the wired NIC card dropping off.

It would happen about every 10 minutes, the |Internet access would stop then the network access. Running the network troubleshooter would resolve it by reseting the NIC card. This seemed odd to me until I looked at the power options in the control panel and there was a Dell Control Point selection there for the NIC card. I also set the power option to never turn off or sleep while plugged into power.

I hope this helps someone.


I have a Dell Inspiron laptop with Windows 7 Home 64-bit and Intel WiFi adapter. I have been experiencing the same problem,

The solution I have found is that I change Power Plan in Power Options to High Performance and the problem is gone.

Now my problem is how to save this plan to be as a default plan when the computer starts. Every time I restart it changes back to Power Saver which seems to be default on my laptop.


One common reason for network drop in Windows 7 is having "side scaling" enabled in your card properties.

To fix this, go to Network and Sharing Center, click "Change Adapter Settings", select your card and go to "Properties".

Click "Configure card" and select the "Advanced" tab. Make sure that the "Receive side scaling" option is disabled.

  • First, check your IP assignment before and after it happens, if you have another machine you can connect to the modem/router to test, see if it is affected as well.

  • Check the system's event logs to see if there is any notification.

  • What is your network adapter's chipset? is there an updated driver from the chipset manufacturer?

  • Another issue could be that it is detected as the wrong chipset and using that chipset's driver, with another available from the manufacturer.

I would suggest seeing if there are any filters added to the network adapter. I know that virtualization software will add in additional filters to your physical adapter, as well as potentially add in additional virtual adapters.

I would suggest maybe uninstalling any virtualization software (you mention VirtualBox), rebooting, seeing if there are any filters other than that left, and if you can disable any that aren't needed.

  • @aztracker1 - Please see my edited question. I have added further information based upon your feedback/questions.
    – CraigTP
    Jan 18 '10 at 19:56
  • @aztracker1 - Thanks for your edit. I have both VirtualBox and Virtual PC. Both of these add their own "bridges" to my network adapter, but no filters that I'm aware of. I'll try disabling these and see how that goes. I'd rather not completely uninstall as I really need to run VBox for some VMs, and I have this running on Windows XP with no issues at all.
    – CraigTP
    Feb 21 '10 at 11:21

I think it's the VirtualBox that you are using that causes the problem.

It happens to all other virtualization applications like VMWare, VirtualPC, etc. They will reset your internet connection when you install them.

  • @Jonathan - Is this specific to Windows 7, though? I have VirtualBox installed on a Vista machine and an XP machine and I've never had this problem on those.
    – CraigTP
    Jan 17 '10 at 23:26
  • 1
    FWIW, I've had no issues like this with Virtualbox on Windows 7.
    – Dmatig
    Jan 18 '10 at 1:11
  • @Dmatig - Thanks for commenting. It goes towards suggesting (as I suspect) that VirtualBox has nothing to do with the problem.
    – CraigTP
    Jan 18 '10 at 13:20
  • it does, when you install any Virtual machine things like VMware, VirtualBox, VirtualPC it will reset your internet connection. It just happends that you are probably not in a corp network and your home network connection won't be affected
    – Jonathan
    Jan 22 '10 at 6:41
  • 1
    I'm aware that that it "resets" your LAN connection during installation as it has to install it's own connection bridge and this is applied to the LAN connection (which stops and restarts when this happens). This is only during installation of VirtualBox, though, and it not (as far as I'm aware) an ongoing thing. My problem is something that happens every day I use my PC, whether or not VirtualBox is loaded and used or not.
    – CraigTP
    Jan 24 '10 at 9:35

I had the same problem - internet connection being dropped randomly. I tried lot of "solutions" from answers of this question, and nothing worked. So, I started disabling other network adapters, and when I disabled LogMeIn Hamachi network adapter, the problem disappeared (please note that I had to disable LogMeIn Hamachi Service first to be able to disable the network adapter).

  • hi xhafan, could to provide more detail. eg: why disabling " LogMeIn Hamachi service and network adapter" helped with the problem, otherwise it should possibly be a comment
    – mic84
    Oct 24 '16 at 10:13
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review
    – mic84
    Oct 24 '16 at 10:14
  • I updated the answer to be more "rich". But basically the core of the answer is the same. Please explain why this is not an answer to the question.
    – xhafan
    Oct 24 '16 at 14:02
  • I don't know how the second comment ended up there, i have it in my page of standard superuser comments, i may have pasted it by accident while jumping around the answers
    – mic84
    Oct 24 '16 at 17:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.