12

I am running Win10x64 Home. (So no gpedit.msc)

I have previously used http://www.oo-software.com/en/shutup10 to change some Windows 10 settings, but have now reverted all changes it made. It gives me this message, with the "Send your device data to Microsoft" option disabled:

The Error

I would like to enable the option in order to give feedback.

I have searched for a long time, and can't seem to find a solution. I have made some changes in the resistry, seems to make no difference. I have also checked I am using Windows Default Settings when It comes to privacy.

Thanks for any help!

7
  • By the screenshot, seems like a policy is enforced. Group policy editor might be your way (run gpedit.msc) – Alfabravo Sep 8 '15 at 14:48
  • @Alfabravo "I am running Win10x64 Home. (So no gpedit.msc)" – DavidPostill Sep 8 '15 at 14:59
  • @Alfabravo - Windows 10 Home cannot join a domain, so given that fact, its unlikely a group policy is to blame. What is likely to blame is poorly written software, that claims to do something, which can already be disabled through the supplied options. – Ramhound Sep 8 '15 at 15:11
  • 1
    @harley_woop - Sadly this issue should be reported to the author of that program, since your inability to change it, is clearly because it change your configuration. – Ramhound Sep 8 '15 at 15:12
  • @Ramhound I've sent them a email. – harley_woop Sep 8 '15 at 15:23
26

O&O Software sent me a solution, it's very simple:

Jump into regedit

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\DataCollection

Delete the binary key "AllowTelemetry" (Right Side)

Fixes it :-)

1
  • This has bugged me on/off for years, thank you! PS - In in an effort to contribute something, I've converted this answer (and the one below) into a .reg file - Just copy + paste below code into notepad, save as "unlock settings.reg" (or whatever you prefer), double click the file... Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\DataCollection] "AllowTelemetry"=- [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\DataCollection] "AllowTelemetry"=- – Martin Jun 3 at 1:25
8

If you don't find an "AllowTelemetry" key in harley_woop's registry address, you may find it at this registry folder address instead.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\DataCollection

My PC is Windows 10, Home Edition. The "Basic" option was selected, but the "Full" option was greyed out/unselectable. This is the process I used to select "Full".

  1. Open Registry Editor with Administrator privileges
  2. Copy the below address into the address bar. Press the Enter key.
  3. Right-click on the AllowTelemetry DWORD > Modify
  4. Change the hexadecimal number to "3" ("Full")
  5. Exit Registry Editor
  6. Restart the Settings App
  7. Settings > Diagnostics and Feedback Settings
  8. The "Full" setting should now be selected (even though greyed out). No restart should be required.

AllowTelemetry DWORD Possible Options

0 = Security (Enterprise and Education editions only)

1 = Basic

2 = Enhanced

3 = Full (Recommended)

Information Source: Microsoft Answers Forum

2

This can also be because you've disabled the service "Connected User Experiences and Telemetry".

2

I had to change two keys under this location:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\DataCollection

Both of these are DWORD's.

First, this allows the user to change the setting on the "Diagnostics and Feedback" page under Windows Privacy settings:

MaxTelemetryAllowed = 3

And then. to set the level that you actually want, use this:

AllowTelemetry = 3

Where the number is:

0 = Security (Enterprise and Education editions only)
1 = Basic
2 = Enhanced
3 = Full (Recommended)

Not the answer you're looking for? Browse other questions tagged or ask your own question.