We are trying to setup application security policy in Windows 7 Pro. I Have enabled the system's local policy with configuration below:

{Policy sample}

Name    Type    Security Level  Description Last Modified Date
%HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRoot%    Path    Unrestricted
%HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramFilesDir%    Path    Unrestricted
C:\                       Path           Disallowed
C:\opt\libraries          Path           Unrestricted
Venkat                    Certificate    Unrestricted       

With this policy I was able to run my application as expected. However, the application requires certain Registry information during runtime. But, the application is not able to get the information from the Registry. The needed Registry information is located at:


How can I grant access to these registry locations?

  • I have no idea what you're asking here.
    – Wes Sayeed
    Sep 8, 2015 at 17:08
  • After enabling default policy and enabling certificate based unrestricted access in application security policy. My application is not able to access certain registry value. Just trying to fix that.Ned some guidance on that
    – Ragav
    Sep 8, 2015 at 17:11
  • 1
    What is your end goal? What configuration is needed to accomplish your goal? Your question is unclear on these points. Sep 8, 2015 at 17:23
  • 1
    Are you familiar with configuring permissions in the Registry? It sounds like you need to grant Full Control permissions for the keys you specified to the user account that is used when your application is run. Sep 8, 2015 at 17:46
  • 1
    Sure, when I get back to a hard line I'll provide that for you. Sep 8, 2015 at 17:55

1 Answer 1


It sounds like your application is not running because it doesn't have the necessary permissions to make changes to the Registry.

If this is only occurring when you install the application, then the correct solution is to require Administrative permissions to complete the installation.

However, if this is also happening when simply trying to run the application you need to grant some additional permissions in the Registry. To this as follows:

  1. Identify the account requiring additional permissions. Registry permissions aren't granted to applications; they're granted to Security Principles (i.e. user accounts, groups, etc.). Programs are run in the context of an account and in turn inherit that account's permissions. To grant the needed permissions to all users of the computer we'll use the Users group which will grant permissions to all users of the computer.
  2. Open Registry Editor by running regedit
  3. Navigate to the key to which additional permissions are needed, e.g. HKEY_LOCAL_MACHINE\SOFTWARE\XFS
  4. Right-click the key and click Permissions...
    enter image description here

  5. Click Add...

  6. Enter object name (e.g. Users) and click OK
    enter image description here
  7. Enable the Full Control checkbox (which automatically enables all other permissions) then click OK
    enter image description here
  8. Repeat as needed for other keys
  • Thanks for your efforts i did give permissions for the registry for both users and administrators. Still my application throws same error.
    – Ragav
    Sep 9, 2015 at 1:43
  • @Ragav Download and run Process Monitor from Microsoft. In the Filter dialog box, specify a filter of Process Name is and then provide the name of your application's process, then Include that filter. Then run your program and look for errors in the Result column. You can also filter out everything except for Registry operations if you're sure that's your problem. This will help you determine what exactly your application is running into that's preventing it from working. Sep 10, 2015 at 2:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.