6

I installed Linux, Windows XP and Chrome OS in VMware Workstation 7 and in every OS the USB host doesn't work. When I start some of the Operating Systems this message shows up:

Host USB device connections disabled

The connection to the VMware USB Arbitration Service was unsuccessful. Please check the status of this service in the Microsoft Management Console.

enter image description here

What can I do? What do I need to install to make the USB host work? I use Windows 7 as the host OS.

EDIT: if you have some programs from Sony or Sony Ericsson installed, go to Device Manager, then Drivers and set the certificate to Microsoft. See this:

http://ericwijaya.wordpress.com/2010/03/12/VMware-USB-cannot-connect-to-host-USB/ (thanks to https://superuser.com/users/33890/user33890)

  • Did you check the status of this service in the Microsoft Management Console? – Marcin Jan 17 '10 at 22:47
1

See the answer below, from this blog post.


The root cause of this problem is that VMWare only support USB root hub driver from Microsoft. When your USB root hub driver get updated by another software (sony ericsson pc suite, AMD, etc.) the vmware cannot detect the usb driver.

What you can do is install the Microsoft USB Hub Driver on your Host. This is how you do it:

  1. Right Click on your My Computer icon and click Manage. Go to Device Manager. Search for USB Root Hub.

  2. Double Click on one of USB Root Hub. Check the Driver Provider. If it is a Sony Ericsson or provider other than Microsoft, you should install the Microsoft Driver. Klik Update Driver to Install Microsoft Driver.

  3. Choose Install from a list or specific location.

  4. Don’t search. I will choose the driver to install.

  5. Choose USB Root Hub from the bottom.

  6. Check again the Manufacturer. Make sure it is already changed to Microsoft.

  7. Do step 1-6 on all the USB Root Hub.

  8. Restart the Computer.


| improve this answer | |
  • thank you soo much for answering and helping me...it means a lot :) thanks – kvizii Jun 18 '10 at 16:58
2

I face that problem as well on windows7 host, Just go to services and start the service name "VMWare USB Arbitration Service"

| improve this answer | |
1

I restored the usb root hub drivers to Microsoft and then I uninstaller vmware.After uninstalling vmware i tried to install vmware again and after that...IT FINALLY WORKED!!! try that and good luck from me...finally my vmware work like it should do. :)

| improve this answer | |
0

It worked for me to get in: start> run Type services.msc

Search for VMware USB Arbitrator Service Clicking the button RIGHT Arrow and click start.

It was not necessary to reboot the machine.

After that I started the VMware virtual machine and has displayed the message from a USB device connected! Listen Read phonetically

| improve this answer | |
  • 2
    Please keep in ming the Superuser (and all SE sites) are an English Community. Please use english next time. – Bobby Sep 18 '10 at 15:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.