7

I’m trying to install INetSim on Ubunutu 14.04 desktop. I edited the sources list with the pre compiled Debian Packages. Then when trying to install the signature key using wget I run across this issue here when I run the command:

sudo wget -O - 'http://www.inetsim.org/inetsim.org-archive-signing-key.asc' | apt-key add -

I get a broken pipe issue above.

What would be the reason for this? Do I have to add something after:

apt-key add

enter image description here

4
  • Try "sudo -i" instead of just "sudo".
    – Racing121
    Sep 8, 2015 at 22:10
  • @RACING121 Doesn't change anything Sep 8, 2015 at 22:12
  • 3
    Try with sudo apt-key add -
    – nKn
    Sep 8, 2015 at 22:17
  • See my answer below. This is similar to the situation you had in this question/answer thread here; you are missing the - right after apt-key add. Sep 8, 2015 at 22:44

7 Answers 7

8

What would be the reason for this? Do I have to add something after:

apt-key add

Yes. Exactly. Look at the official INetSim installation instructions and look at your command in the text example here:

sudo wget -O - 'http://www.inetsim.org/inetsim.org-archive-signing-key.asc' | apt-key add -

Note the - at the end right after apt-key add. Now look at your screenshot and the command you are using; text version below:

sudo wget -O - 'http://www.inetsim.org/inetsim.org-archive-signing-key.asc' | apt-key add

You are not including that - after apt-key add. So the output from sudo wget -O - which should be piped to apt-key add -. So yes, you definitely have a broken pipe happening—or not happening—right there.

0
8

You have to run

apt-key list

If there is an error of package gnupg not installed so you have to install it

sudo apt install gnupg && sudo apt install gnupg1

or

sudo apt install gnupg && sudo apt install gnupg2

It worked for me.

6

You can easily add sudo before apt-key, just like this:

sudo wget -O - 'http://www.inetsim.org/inetsim.org-archive-signing-key.asc' | sudo apt-key add -
5

I had the same problem with a docker image I was creating. I was using a slim base image which has only a minimal set of packages installed.

To investigate the issue I retrieved the key-file first. After this I tried the import command which failed. But this time I got a decent error message, which stated that I need to install gnupg, gnupg2 and gnupg1 packages. After I installed these packages import is working succesfully.

So I'd suggest that anyone facing this issue would first retrieve the key

wget http://[server]/file.key

and then do the import with

apt-key add file.key

If this still fails atleast you'll see the cause for failure.

1
  • thanks for explaining, I had the same issue with a miniconda3 base image which uses debian 10
    – joshi123
    Oct 18, 2020 at 9:27
4

I had the same problem and I discovered that was due to missing gpg package. I solve the problem with:

sudo aptitude install gpg
0

This problem is due to missing gnupg Try

apt install gnupg
apt install gnupg1
apt install gnupg2

It fixes the issue

-1

This type of broken pipe might also result when trying to write to a directory the current user doesn't have enough permissions.

3
  • Avoid posting answers to old questions that already have well received answers unless you have something substantial and new to add.
    – Toto
    Dec 21, 2022 at 15:25
  • @Toto Thanks for the downvote Toto, I had two colleagues getting this error simply because they did not have enough permissions to the specific subdirectory that they were trying to write to. This answer, though trivial, might be the case for someone who's a newbie.
    – Ari
    Dec 22, 2022 at 16:44
  • Sorry but I'm not the downvoter! Your answer doesn't add substantial info but I think it doesn't deserve a downvote.
    – Toto
    Dec 22, 2022 at 17:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .