25

Recently Chrome updated and since then every time I switch between tabs I have to wait for the activated tab to refresh. Is there a way to tell Chrome to quit hibernating inactive tabs?

  • 3
    see chrome://flags/#automatic-tab-discarding – John Henckel Mar 1 '16 at 19:43
12

From information written on Chromium OS site (which applies to the Chrome browser as well) here, it says that the tabs are getting "hibernated" because your device is getting low on memory.

It suggests that you: "Close some tabs or uninstall extensions that take a lot of memory. If there's a specific tab you don't want discarded, right-click on the tab and pin it."

Also, according to this second article, experimental version of Chrome (Chrome 46 Canary build, at the time of writing this answer) will implement a feature called Tab Discarding, which will preserve the state of the tabs that will be discarded.

Hope it helps.

  • 1
    Any idea how to turn it off? It brakes the sense of using tabs... – Tomasz Brzezina Sep 12 '15 at 21:52
  • @SledgehammerPL: Your best try will be to raise your page file size. – Mike Sep 12 '15 at 23:20
  • 2
    Chromium OS info doesn't always apply to Chrome on other OSs: Why doesn't Chrome do this on Mac / Windows / Goobuntu? Those machines swap memory out to disk when they get low on resources. Changing tabs then slows down as the data is loaded from disk. – user452888 Nov 2 '15 at 21:32
  • 5
    This feature is totally broken. Until it was added, I never had a single instance of memory overload. Right now, I have more than 1 GB of free RAM but Chrome has discarded 15 of my open tabs. I have a slow CPU, so clicking on a discarded tab takes 10-15 seconds each time. It's a good idea really, but way too aggressive. Interestingly, Google tells us the exact opposite on Android, unused memory is useless memory so nothing is discarded until it fills up. – Martin Hansen Nov 8 '15 at 18:05
  • 9
    @SledgehammerPL to turn it off use chrome://flags/#automatic-tab-discarding – John Henckel Mar 1 '16 at 19:44
25

What helped as a general solution for all tabs for me:

you can turn this off by going to "chrome://flags/" and selecting "Disabled" under "Enable tab discarding "

(taken from https://www.reddit.com/r/chrome/comments/3kg79l/chrome_keeps_refreshing_every_page_and_its/d0dtcqx)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.