19

I am a developer and have created a certificate for my application. The first time I access it Chrome states that the certificate is not recognized and suggests to leave the website.

There is however the option to add an exception, which I did, and the website becomes accessible.

Now I need to remove that exception, but I cannot find it any were in Chrome's settings. Chrome version is 45.0.2454.85 m

  • have you looked in Settings -> Show advanced settings -> Manage certificates? – Shevek Sep 9 '15 at 10:13
  • Ok, I've found it. In the address bar, clicking on the lock next to the URL will show the certificate details. There is a button to stop using the certificate. – algiogia Sep 9 '15 at 10:31
12

I've finally found the answer.

On the address bar, click on the padlock to show the certificate details. In the Connection tab there is a button "Stop using this certificate". Click it to remove the exception.

enter image description here

  • 3
    This probably works, but what if the URL causes a 302/301, so you never stay at its location for long enough to do this? – Alex Feb 13 '18 at 6:52
6

01/2017 - After many Chrome updates, now you just click to the left of the URL, where the padlock is, or if something else (mine is a local server, displaying a "red triangle Not secure"), click that to display the information about the connection, then click "Re-enable warnings"

  • 1
    Which is basically what explained in my answer ;) – algiogia Feb 13 '18 at 12:39
4

Chrome looks a little different these days, so here's an updated picture of where to re-enable the warnings.

You still begin by clicking the "Not secure" indicator to the left of the URL. Then, in the panel that pops up, you click the "Re-enable warnings" link.

enter image description here

1

In case the HTTPS URL triggers a 301/302 redirection to an HTTP URL, the methods described above won't work since the browser immediately redirects to a non-secure page which doesn't include the padlock button (as pointed out by Alex in the comments).

In this case, it's possible to work around this problem by disabling redirections for the website: Settings -> Advanced -> Site Settings -> Pop ups and redirects -> Block -> Add -> Add the URL -> Visit the URL -> Disable the exception according to the accepted answer -> Remove redirection block.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.