1

I got an Banana Pi with Bananian running on it. I installed xbmc on it. When I connect my Banana Pi to my TV with a HDMI cable it shows an TTY as expected. When I try to run xinit /usr/bin/xbmc --standalone from a PuTTY session I get this error:

ERROR: Unable to create GUI. Exiting
Segmentation fault (core dumped)

Crash report:

############## XBMC CRASH LOG ###############

################ SYSTEM INFO ################
 Date: Wed Sep  9 13:31:03 CEST 2015
 XBMC Options:
 Arch: armv7l
 Kernel: Linux 3.4.108-bananian #2 SMP PREEMPT Thu Aug 13 06:08:25 UTC 2015
 Release: Debian GNU/Linux 8 (jessie)
############## END SYSTEM INFO ##############

############### STACK TRACE #################
gdb not installed, can't get stack trace.
############# END STACK TRACE ###############

################# LOG FILE ##################

13:31:02 T:3000336384  NOTICE: special://profile/ is mapped to: special://masterprofile/
13:31:02 T:3000336384  NOTICE: -----------------------------------------------------------------------
13:31:02 T:3000336384  NOTICE: Starting XBMC from Debian (13.2 Debian package version:2:13.2+dfsg1-4). Platform: ARM (Thumb) Linux 32-bit
13:31:02 T:3000336384  NOTICE: Using Debug XBMC x32 build, compiled Nov  8 2014 by GCC 4.9.2 for ARM (Thumb) Linux 32-bit 3.16.5
13:31:02 T:3000336384  NOTICE: Running on Linux 32-bit (Debian GNU/Linux 8 (jessie), 3.4.108-bananian armv7l)
13:31:02 T:3000336384  NOTICE: Host CPU: ARMv7 Processor rev 4 (v7l), 2 cores available
13:31:02 T:3000336384  NOTICE: ARM Features: Neon enabled
13:31:02 T:3000336384  NOTICE: special://xbmc/ is mapped to: /usr/share/xbmc
13:31:02 T:3000336384  NOTICE: special://xbmcbin/ is mapped to: /usr/lib/xbmc
13:31:02 T:3000336384  NOTICE: special://masterprofile/ is mapped to: /root/.xbmc/userdata
13:31:02 T:3000336384  NOTICE: special://home/ is mapped to: /root/.xbmc
13:31:02 T:3000336384  NOTICE: special://temp/ is mapped to: /root/.xbmc/temp
13:31:02 T:3000336384  NOTICE: The executable running is: /usr/lib/xbmc/xbmc.bin
13:31:02 T:3000336384  NOTICE: Local hostname: peter
13:31:02 T:3000336384  NOTICE: Log File is located: /root/.xbmc/temp/xbmc.log
13:31:02 T:3000336384  NOTICE: -----------------------------------------------------------------------
13:31:02 T:3000336384   DEBUG: ConsoleKit.Manager: org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.ConsoleKit was not provided by any .service files
13:31:02 T:3000336384   DEBUG: Previous line repeats 1 times.
13:31:02 T:3000336384   DEBUG: DeviceKit.Power: org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.DeviceKit.Disks was not provided by any .service files
13:31:02 T:3000336384    INFO: Selected UPower as PowerSyscall
13:31:02 T:3000336384   ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - No such property CanSuspend
13:31:02 T:3000336384   ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - No such property CanHibernate
13:31:02 T:3000336384  NOTICE: load settings...
13:31:02 T:3000336384   DEBUG: CSettings: loaded settings definition from special://xbmc/system/settings/settings.xml
13:31:02 T:3000336384   DEBUG: CSettings: loaded settings definition from special://xbmc/system/settings/linux.xml
13:31:02 T:3000336384   ERROR: PulseAudio: Failed to connect context
13:31:02 T:3000336384  NOTICE: PulseAudio might not be running. Context was not created.
13:31:02 T:3000336384    INFO: CAESinkALSA - Unable to open device "surround71" for playback
13:31:02 T:3000336384    INFO: CAESinkALSA - Unable to open device "surround51" for playback
13:31:02 T:3000336384    INFO: CAESinkALSA - Unable to open device "surround71" for playback
13:31:02 T:3000336384    INFO: CAESinkALSA - Unable to open device "surround40" for playback
13:31:02 T:3000336384    INFO: CAESinkALSA - Unable to open device "surround51" for playback
13:31:02 T:3000336384    INFO: CAESinkALSA - Unable to open device "surround71" for playback
13:31:02 T:3000336384  NOTICE: Found 1 Lists of Devices
13:31:02 T:3000336384  NOTICE: Enumerated ALSA devices:
13:31:02 T:3000336384  NOTICE:     Device 1
13:31:02 T:3000336384  NOTICE:         m_deviceName      : @
13:31:02 T:3000336384  NOTICE:         m_displayName     : Default (sunxi-CODEC sunxi PCM)
13:31:02 T:3000336384  NOTICE:         m_displayNameExtra:
13:31:02 T:3000336384  NOTICE:         m_deviceType      : AE_DEVTYPE_PCM
13:31:02 T:3000336384  NOTICE:         m_channels        : FL,FR
13:31:02 T:3000336384  NOTICE:         m_sampleRates     : 8000,11025,16000,22050,32000,44100,48000,96000,192000
13:31:02 T:3000336384  NOTICE:         m_dataFormats     : AE_FMT_S16NE,AE_FMT_S16LE
13:31:02 T:3000336384  NOTICE: No settings file to load (special://xbmc/system/advancedsettings.xml)
13:31:02 T:3000336384  NOTICE: No settings file to load (special://masterprofile/advancedsettings.xml)
13:31:02 T:3000336384  NOTICE: Default DVD Player: dvdplayer
13:31:02 T:3000336384  NOTICE: Default Video Player: dvdplayer
13:31:02 T:3000336384  NOTICE: Default Audio Player: paplayer
13:31:02 T:3000336384  NOTICE: Disabled debug logging due to GUI setting. Level 0.
13:31:02 T:3000336384  NOTICE: Log level changed to 0
13:31:02 T:3000336384  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
13:31:02 T:3000336384   DEBUG: CPlayerCoreConfig::<ctor>: created player DVDPlayer for core 1
13:31:02 T:3000336384   DEBUG: CPlayerCoreConfig::<ctor>: created player oldmplayercore for core 1
13:31:02 T:3000336384   DEBUG: CPlayerCoreConfig::<ctor>: created player PAPlayer for core 3
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: system rules
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: rtv
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: hdhomerun/myth/mms/udp
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: lastfm/shout
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: rtmp
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: rtsp
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: streams
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: aacp/sdp
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: mp2
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: dvd
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: dvdimage
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: sdp/asf
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: nsv
13:31:02 T:3000336384   DEBUG: CPlayerSelectionRule::Initialize: creating rule: radio
13:31:02 T:3000336384  NOTICE: Loaded playercorefactory configuration
13:31:02 T:3000336384  NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
13:31:02 T:3000336384  NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
13:31:02 T:3000336384    INFO: creating subdirectories
13:31:02 T:3000336384    INFO: userdata folder: special://masterprofile/
13:31:02 T:3000336384    INFO: recording folder:
13:31:02 T:3000336384    INFO: screenshots folder:
13:31:02 T:3000336384    INFO: load language info file: special://xbmc/language/English/langinfo.xml
13:31:02 T:3000336384   DEBUG: trying to set locale to en_US.UTF-8
13:31:02 T:3000336384    INFO: global locale set to en_US.UTF-8
13:31:02 T:3000336384    INFO: load English language file, from path: special://xbmc/language/
13:31:02 T:3000336384   DEBUG: POParser: loaded 3162 strings from file /usr/share/xbmc/language/English/strings.po
13:31:02 T:3000336384   DEBUG: DllAvUtilBase: Using libavutil system library
13:31:02 T:3000336384   DEBUG: DllAvCodec: Using libavcodec system library
13:31:02 T:3000336384   DEBUG: DllAvFormat: Using libavformat system library
13:31:02 T:2931606432  NOTICE: Thread ActiveAE start, auto delete: false
13:31:02 T:2921329568  NOTICE: Thread AESink start, auto delete: false
13:31:02 T:2921329568    INFO: CActiveAESink::OpenSink - initialize sink
13:31:02 T:2921329568   DEBUG: CActiveAESink::OpenSink - trying to open device ALSA:@
13:31:02 T:2921329568   DEBUG: CAESinkALSA::GetChannelLayout - Input Channel Count: 2 Output Channel Count: 2
13:31:02 T:2921329568   DEBUG: CAESinkALSA::GetChannelLayout - Requested Layout: FL,FR
13:31:02 T:2921329568   DEBUG: CAESinkALSA::GetChannelLayout - Got Layout: FL,FR
13:31:02 T:2921329568    INFO: CAESinkALSA::Initialize - Attempting to open device "@"
13:31:02 T:2921329568    INFO: CAESinkALSA::Initialize - Opened device "sysdefault"
13:31:02 T:2921329568    INFO: CAESinkALSA::InitializeHW - Your hardware does not support AE_FMT_FLOAT, trying other formats
13:31:02 T:2921329568    INFO: CAESinkALSA::InitializeHW - Using data format AE_FMT_S16NE
13:31:02 T:2921329568   DEBUG: CAESinkALSA::InitializeHW - Request: periodSize 2048, bufferSize 8192
13:31:02 T:2921329568   DEBUG: CAESinkALSA::InitializeHW - Got: periodSize 2048, bufferSize 8192
13:31:02 T:2921329568   DEBUG: CAESinkALSA::InitializeHW - Setting timeout to 186 ms
13:31:02 T:2921329568   DEBUG: CAESinkALSA::GetChannelLayout - Input Channel Count: 2 Output Channel Count: 2
13:31:02 T:2921329568   DEBUG: CAESinkALSA::GetChannelLayout - Requested Layout: FL,FR
13:31:02 T:2921329568   DEBUG: CAESinkALSA::GetChannelLayout - Got Layout: FL,FR
13:31:02 T:2921329568   DEBUG: CActiveAESink::OpenSink - ALSA Initialized:
13:31:02 T:2921329568   DEBUG:   Output Device : Default (sunxi-CODEC sunxi PCM)
13:31:02 T:2921329568   DEBUG:   Sample Rate   : 44100
13:31:02 T:2921329568   DEBUG:   Sample Format : AE_FMT_S16NE
13:31:02 T:2921329568   DEBUG:   Channel Count : 2
13:31:02 T:2921329568   DEBUG:   Channel Layout: FL,FR
13:31:02 T:2921329568   DEBUG:   Frames        : 2048
13:31:02 T:2921329568   DEBUG:   Frame Samples : 4096
13:31:02 T:2921329568   DEBUG:   Frame Size    : 4
13:31:02 T:2931606432   DEBUG: DllAvUtilBase: Using libavutil system library
13:31:02 T:2931606432   DEBUG: DllAvFormat: Using libswresample system library
13:31:02 T:3000336384  NOTICE: Running database version Addons16
13:31:02 T:3000336384   DEBUG: SECTION:LoadDLL(special://xbmcbin/system/libcpluff-arm.so)
13:31:02 T:3000336384   DEBUG: Loading: /usr/lib/xbmc/system/libcpluff-arm.so
13:31:03 T:3000336384    INFO: ADDON: cpluff: 'Could not read plug-in directory /usr/lib/xbmc/addons: No such file or directory'
13:31:03 T:3000336384  NOTICE: ADDONS: Using repository repository.xbmc.org
13:31:03 T:3000336384    INFO: LIRC Initialize: using: /dev/lircd
13:31:03 T:3000336384    INFO: LIRC Initialize: connect failed: No such file or directory
13:31:03 T:3000336384   DEBUG: Failed to connect to LIRC. Retry in 10s.
13:31:03 T:3000336384   DEBUG: LoadMappings - loaded node "Motorola Nyxboard Hybrid"
13:31:03 T:3000336384   DEBUG: LoadMappings - loaded node "CEC Adapter"
13:31:03 T:3000336384   DEBUG: LoadMappings - loaded node "Pulse-Eight CEC Adapter"
13:31:03 T:3000336384   DEBUG: LoadMappings - loaded node "iMON HID device"
13:31:03 T:3000336384   DEBUG: CPeripheralBusUSB - initialised udev monitor
13:31:03 T:3000336384   DEBUG: SECTION:LoadDLL(libcec.so.2)
13:31:03 T:3000336384   DEBUG: Loading: libcec.so.2
13:31:03 T:3000336384   ERROR: Unable to load libcec.so.2, reason: libcec.so.2: cannot open shared object file: No such file or directory
13:31:03 T:3000336384   DEBUG: Dll libcec.so.2 was not found in path
13:31:03 T:3000336384   ERROR: Initialise - failed to initialise bus cec
13:31:03 T:2910843808  NOTICE: Thread PeripBusUSBUdev start, auto delete: false
13:31:03 T:3000336384   DEBUG: UDisks: org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UDisks was not provided by any .service files
13:31:03 T:3000336384   DEBUG: DeviceKit.Disks: org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.DeviceKit.Disks was not provided by any .service files
13:31:03 T:3000336384   DEBUG: Selected UDev as storage provider
13:31:03 T:3000336384   ERROR: InitWindowSystem: Could not initialize
13:31:03 T:3000336384   FATAL: CApplication::Create: Unable to init windowing system
13:31:03 T:3000336384   DEBUG: PVRManager - destroyed

What is causing this error and how can I fix this?

By the way, I am able to run startxfce4 and get the XFCE GUI on my TV.

Update: I tried to run xbmc inside KDE and Xfce and I still get the same error.

  • I don't see anything in the log about displays / screens being detected- can you try it plugged into a monitor instead of a TV? What version of xbmc/kodi? – bertieb Sep 9 '15 at 11:52
  • How did you obtain your copy of Kodi? – Daniel B Sep 9 '15 at 12:19
  • @DanielB I installed it with apt-get install xbmc – Peter Sep 9 '15 at 12:21
1

You have the following line:

13:31:03 T:3000336384 FATAL: CApplication::Create: Unable to init windowing system

This seems to suggest that the standalone Xbmc call is unable to start a graphical environment.

You may try the following alternative path:

  1. Start Xfce4;

  2. create a launch icon for Xbmc on your desktop, or on your panel.

  3. start Xbmc now from the launch icon, i.e. with the graphical environment already started.

This is what I do under Debian and KDE (not a RPI, though). And, just for the fun of it, I found that CuBoxTV, with Xbmc/Kodi pre-installed, is a much superior alternative, and worth every penny it costs more than an RPI.

Edit:

if you want to execute Xbmc automatically when you activate Xfce4, just place an executable file in /etc/X11/Xsession.d called 99zz so that it executes last, with the following content:

  #!/bin/bash
  /usr/bin/xbmc &

and you are done.

  • I created the launch icon but when I start it (double click or right click -> execute) nothing happens even though it seems that the process is running. (I find it with htop). Is Exec=xinit /usr/bin/xbmc --standalone right for the desktop file? – Peter Sep 9 '15 at 13:19
  • @Peter I use simply /usr/bin/xbmc to start the program. Please also see my edit. – MariusMatutiae Sep 9 '15 at 13:24
  • This won't open the xbmc GUI for me. Do I have to do anything else to see the xbmc GUI? – Peter Sep 9 '15 at 13:37
  • @Peter It does open the Xbmc on my two systems. Then I cannot help you there, sorry. – MariusMatutiae Sep 9 '15 at 13:52
  • I still get the error FATAL: CApplication::Create: Unable to init windowing system. I think thats why I can't see anything. – Peter Sep 9 '15 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.