2

I am trying to build a Virtual Network in Ubuntu with two virtual machines who only have the means to communicate with each other independent of the host.

enter image description here

On both machines I went to Settings->Network Adapter and set to Custom (VMnet 2)

However I noticed after doing this one of my virtual machines (the ubuntu machine) - does not have it's own IP assigned by the DHCP server. It's 127.0.0.1

enter image description here

Why is there no 192.168.x.x IP assigned?

  • Your Host OS is? – Francisco Tapia Sep 9 '15 at 12:43
  • @FranciscoTapia I am running VMWare Workstation on Windows 7 – BDillan Sep 9 '15 at 12:54
2

Set eth0 inteface edit the following file

/etc/network/interfaces

and be sure it is configured as this:

auto eth0
iface eth0 inet dhcp

Then be sure the VMNet 2 (Custom) is rightly configured:

To change(check) DHCP settings:

  • Click Edit > Virtual Network Editor and select the virtual network adapter.

enter image description here

  • Select Use local DHCP service to distribute IP address to VMs and click DHCP settings.

enter image description here

  • Modify the third number in the IP address. For example, 192.168.x.0 or 198.16.x.0. In general, do not change the subnet mask. Certain virtual network services might not work as well with a customized subnet mask.

enter image description here

  • Click Apply.

Source


Aditional Resourses

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.