0

I installed Win10. I have also installed vbox. Vboxhas a NAT host-only adapter. I added port forwarding to my NAT so I can ssh via it. I can also ssh via the host-only adapter.

Guest-OS is Ubuntu Server 14.04.3 LTS. I've installed samba via the ubuntu installer.

So, the Problem is, I can't set up Samba. I'm a noob when it Comes to samba but until now I always was able to set it up and get it working but now I just don't know what's the Problem.

I followed this: https://help.ubuntu.com/community/How%20to%20Create%20a%20Network%20Share%20Via%20Samba%20Via%20CLI%20(Command-line%20interface/Linux%20Terminal)%20-%20Uncomplicated,%20Simple%20and%20Brief%20Way! So my settings are

[foo]
path = /home/me/foo
available = yes
valid users = me
read only = no
browseable = yes
public = yes
writable = yes

As they said I added it to the end of the file.

Now, sometimes I see my server listed in the network. (Sometimes I don't, I really don't get it) If I do, I can't connect. As usual at Windows, the error msg isn't helping, it says "can't Access". I also can't Access it via explorer directly.

I just have no clue why it doesn't work at all.

I really hope you can help me. I've googled for like 6 hours and I just can't anymore.

Ah btw: sudo smbstatus --Shares doesn't show anything - it used to. . . I didn't rly change a lot, I basically just tried a few different configs but nothing big.

I have a local win10 account.

Edit:

I used to be able to smbclient //devserver/www -U me on my server. Doesn't work anymore.

Edit2: I reinstalled Ubuntu server, now I use the above config, which is basically the same. I can now Access the samba share on the server itself but still the same problem from Windows.

Edit3: I just saw that Windows says "network path not found" and 0x80070035 but it's listed in network.

  • Is that setting list verbatim? If so there is a typo. First line should be [www]. – alienth Sep 9 '15 at 17:24
  • I just reinstalled the server and did the tutorial again. I updated the config in the init post but the missing ] was a typo. – xotix Sep 9 '15 at 17:38
0

I think you are missing the ending ] at the share name --> [www]

Also, I didn't find an "available" option in the docs, maybe just use writable and browsable.

|improve this answer|||||
  • I just reinstalled the server and did the tutorial again. I updated the config in the init post but the missing ] was a typo. Thanks for pointing out the issue with available option. I'll check it. – xotix Sep 9 '15 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.